New issue

Have a question about this project? Sign up for a free GitHub account to open an issue and contact its maintainers and the community.

By clicking “Sign up for GitHub”, you agree to our terms of service and privacy statement. We’ll occasionally send you account related emails.

Already on GitHub? Sign in to your account

INSTALL instructions fail #1148

Closed
DanGrayson opened this Issue Jan 10, 2019 · 3 comments

Comments

Projects
None yet
1 participant
@DanGrayson
Copy link
Member

DanGrayson commented Jan 10, 2019

When installing UniMath according to instructions in INSTALL.md on Mac OS X, using the first alternative, I run into this failure:

"/usr/local/bin/ocamlfind" ocamlc -thread -rectypes -w +a-4-9-27-41-42-44-45-48-50-58-59   -safe-string  -g  -I "/usr/local/Cellar/camlp5/7.07/lib/ocaml/camlp5" -I grammar -c grammar/q_util.mli
File "grammar/q_util.mli", line 1:
Error: /usr/local/Cellar/camlp5/7.07/lib/ocaml/camlp5/mLast.cmi
is not a compiled interface for this version of OCaml.
It seems to be for an older version of OCaml.
make[2]: *** [grammar/q_util.cmi] Error 2
make[2]: Leaving directory `/Users/dan/src/ProofChecking/UniMath/UniMath/sub/coq'
make[1]: *** [submake] Error 2
make[1]: Leaving directory `/Users/dan/src/ProofChecking/UniMath/UniMath/sub/coq'
make: *** [sub/coq/bin/coq_makefile] Error 2

I wonder if anyone else gets this.

@DanGrayson DanGrayson self-assigned this Jan 10, 2019

@DanGrayson

This comment has been minimized.

Copy link
Member

DanGrayson commented Jan 10, 2019

The work-around seems to be to force camlp5 to be recompiled:

    brew remove camlp5
    brew install --build-bottle camlp5
@DanGrayson

This comment has been minimized.

Copy link
Member

DanGrayson commented Jan 11, 2019

I've started a discussion about this bug in homebrew here: https://discourse.brew.sh/t/prebuilt-bottle-dependencies/3853

@DanGrayson

This comment has been minimized.

Copy link
Member

DanGrayson commented Jan 11, 2019

I've submitted a pull request to homebrew-core to fix the test for camlp5:

Homebrew/homebrew-core#35916

Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment