Have a question about this project? Sign up for a free GitHub account to open an issue and contact its maintainers and the community.

Already on GitHub? Sign in to your account

Update `composer.json` with the correct package type for Lithium libraries #606

Merged
merged 2 commits into from Aug 9, 2012

Conversation

Projects
None yet
2 participants
Contributor

mehlah commented Aug 8, 2012

Installing Lithium with Composer will install it to libraries/UnionOfRAD/lithium.

Composer knows lithium-library type and make use of a custom installer to install the library to libraries/{$name} (without $vendor)
See: https://github.com/composer/installers

Note: I'm getting requires composer/installers * -> no matching package found. but this seems to be a composer related issue.
Requiring "composer/installers": "dev-master" in your app composer file is a workaround.

UPDATE: Composer installers aren't yet flagged as stable, requiring them need to explicitly ask for a dev version.
Explanation got from IRC

@nateabele nateabele added a commit that referenced this pull request Aug 9, 2012

@nateabele nateabele Merge pull request #606 from mehlah/composer-fix-type
Update `composer.json` with the correct package type for Lithium libraries
0809552

@nateabele nateabele merged commit 0809552 into UnionOfRAD:dev Aug 9, 2012

Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment