Skip to content
New issue

Have a question about this project? Sign up for a free GitHub account to open an issue and contact its maintainers and the community.

By clicking “Sign up for GitHub”, you agree to our terms of service and privacy statement. We’ll occasionally send you account related emails.

Already on GitHub? Sign in to your account

Universal Mailer for MacOS 10.15Beta #120

Open
jaefchong opened this issue Jun 14, 2019 · 10 comments
Open

Universal Mailer for MacOS 10.15Beta #120

jaefchong opened this issue Jun 14, 2019 · 10 comments

Comments

@jaefchong
Copy link

@jaefchong jaefchong commented Jun 14, 2019

10.15 After installation, the mail plugin does not see
The previous 10.14 method is not working anymore.
Excuse me, do you still have a way?

@wellblink

This comment has been minimized.

Copy link

@wellblink wellblink commented Aug 26, 2019

I have the same problem and hope to be solved.

@jarsofclay72

This comment has been minimized.

Copy link

@jarsofclay72 jarsofclay72 commented Oct 7, 2019

Found a fix to this as well. You can add the following to the info.plist file in Library > Mail > Bundles for Universal Mailer

<key>Supported10.15PluginCompatibilityUUIDs</key>
<array>
<string># UUIDs for versions from 10.12 to 99.99.99</string>
<string># For mail version 12.0 (3445.100.39) on OS X Version 10.14.1 (build 18B45d)</string>
<string>A4343FAF-AE18-40D0-8A16-DFAE481AF9C1</string>
<string># For mail version 13.0 (3594.4.2) on OS X Version 10.15 (build 19A558d)</string
<string>6EEA38FB-1A0B-469B-BB35-4C2E0EEA9053</string>
</array>
@P4TR1CKB

This comment has been minimized.

Copy link

@P4TR1CKB P4TR1CKB commented Oct 9, 2019

Found a fix to this as well. You can add the following to the info.plist file in Library > Mail > Bundles for Universal Mailer

<key>Supported10.15PluginCompatibilityUUIDs</key>
<array>
<string># UUIDs for versions from 10.12 to 99.99.99</string>
<string># For mail version 12.0 (3445.100.39) on OS X Version 10.14.1 (build 18B45d)</string>
<string>A4343FAF-AE18-40D0-8A16-DFAE481AF9C1</string>
<string># For mail version 13.0 (3594.4.2) on OS X Version 10.15 (build 19A558d)</string
<string>6EEA38FB-1A0B-469B-BB35-4C2E0EEA9053</string>
</array>

Hey jarsofclay72.. Thanks for the post. Unfortunately, the change had no effect. Mail is still disabling UniversalMailer for the reason, that is the plugIn is no longer compatible.

Here is my full info.plist:

<?xml version="1.0" encoding="UTF-8"?>
<!DOCTYPE plist PUBLIC "-//Apple//DTD PLIST 1.0//EN" "http://www.apple.com/DTDs/PropertyList-1.0.dtd">
<plist version="1.0">
<dict>
	<key>BuildMachineOSBuild</key>
	<string>16F73</string>
	<key>CFBundleDevelopmentRegion</key>
	<string>en</string>
	<key>CFBundleExecutable</key>
	<string>UniversalMailer</string>
	<key>CFBundleIdentifier</key>
	<string>it.noware.UniversalMailer</string>
	<key>CFBundleInfoDictionaryVersion</key>
	<string>6.0</string>
	<key>CFBundleName</key>
	<string>UniversalMailer</string>
	<key>CFBundlePackageType</key>
	<string>BNDL</string>
	<key>CFBundleShortVersionString</key>
	<string>3.0</string>
	<key>CFBundleSignature</key>
	<string>????</string>
	<key>CFBundleSupportedPlatforms</key>
	<array>
		<string>MacOSX</string>
	</array>
	<key>CFBundleVersion</key>
	<string>19</string>
	<key>DTCompiler</key>
	<string>com.apple.compilers.llvm.clang.1_0</string>
	<key>DTPlatformBuild</key>
	<string>8E3004b</string>
	<key>DTPlatformVersion</key>
	<string>GM</string>
	<key>DTSDKBuild</key>
	<string>16E185</string>
	<key>DTSDKName</key>
	<string>macosx10.12</string>
	<key>DTXcode</key>
	<string>0833</string>
	<key>DTXcodeBuild</key>
	<string>8E3004b</string>
	<key>NSHumanReadableCopyright</key>
	<string>Copyright © 2017 noware. All rights reserved.</string>
	<key>NSPrincipalClass</key>
	<string>UniversalMailer</string>
	<key>SUFeedURL</key>
	<string>https://universalmailer.github.io/UniversalMailer/appcast/appcast.xml</string>
	<key>SUPublicDSAKeyFile</key>
	<string>dsa_pub.pem</string>
	<key>Supported10.12PluginCompatibilityUUIDs</key>
	<array>
		<string>A4343FAF-AE18-40D0-8A16-DFAE481AF9C1</string>
	</array>
	<key>Supported10.13PluginCompatibilityUUIDs</key>
	<array>
		<string>A4343FAF-AE18-40D0-8A16-DFAE481AF9C1</string>
	</array>
	<key>Supported10.14PluginCompatibilityUUIDs</key>
	<array>
		<string>A4343FAF-AE18-40D0-8A16-DFAE481AF9C1</string>
	</array>
	<key>Supported10.15PluginCompatibilityUUIDs</key>
	<array>
		<string># UUIDs for versions from 10.12 to 99.99.99</string>
		<string># For mail version 12.0 (3445.100.39) on OS X Version 10.14.1 (build 18B45d)</string>
		<string>A4343FAF-AE18-40D0-8A16-DFAE481AF9C1</string>
		<string># For mail version 13.0 (3594.4.2) on OS X Version 10.15 (build 19A558d)</string
		<string>6EEA38FB-1A0B-469B-BB35-4C2E0EEA9053</string>
	</array>
	<key>SupportedPluginCompatibilityUUIDs</key>
	<array>
		<string>A4343FAF-AE18-40D0-8A16-DFAE481AF9C1</string>
	</array>
</dict>
</plist>

Do I have to change anything else? Thanks for a reply

@jarsofclay72

This comment has been minimized.

Copy link

@jarsofclay72 jarsofclay72 commented Oct 9, 2019

One thing I did prior to this as I was testing was completely uninstall the UniversalMailer plugin - basically delete the file in the Bundles folder and re-install prior to adding the code I mentioned.

@jaefchong

This comment has been minimized.

Copy link
Author

@jaefchong jaefchong commented Oct 9, 2019

I didn't succeed.

@aus-coder

This comment has been minimized.

Copy link

@aus-coder aus-coder commented Oct 10, 2019

It actually works. Just that @P4TR1CKB's sample config had a missing >.

Here is corrected config to include.

<key>Supported10.15PluginCompatibilityUUIDs</key>
<array>
<string># UUIDs for versions from 10.12 to 99.99.99</string>
<string># For mail version 12.0 (3445.100.39) on OS X Version 10.14.1 (build 18B45d)</string>
<string>A4343FAF-AE18-40D0-8A16-DFAE481AF9C1</string>
<string># For mail version 13.0 (3594.4.2) on OS X Version 10.15 (build 19A558d)</string>
<string>6EEA38FB-1A0B-469B-BB35-4C2E0EEA9053</string>
</array>
@jaefchong

This comment has been minimized.

Copy link
Author

@jaefchong jaefchong commented Oct 10, 2019

niubility

@P4TR1CKB

This comment has been minimized.

Copy link

@P4TR1CKB P4TR1CKB commented Oct 10, 2019

Thanks a lot for for the assistance to jarsofclay72 and aus-coder! Really did not sees the missing > ... facepalm
It works just fine now!

@owellsjr

This comment has been minimized.

Copy link

@owellsjr owellsjr commented Dec 17, 2019

Thanks so much for this! The updated info.plist file brought this plug-in back to life for me.

@plsalvado

This comment has been minimized.

Copy link

@plsalvado plsalvado commented Feb 10, 2020

Thanks @P4TR1CKB , worked nicely.

Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment
Projects
None yet
Linked pull requests

Successfully merging a pull request may close this issue.

None yet
7 participants
You can’t perform that action at this time.