gngr v0.3.5 throws exception when first run on windows #92

Closed
xaoseric opened this Issue Jan 28, 2015 · 2 comments

Comments

Projects
None yet
2 participants
@xaoseric

gngrerror
Not sure if anyone else has noticed this, but gngr is not creating the .gngr folder. I notice that gngr v0.3.5 will only work after running gngrv0.3.1.

@hrj

This comment has been minimized.

Show comment
Hide comment
@hrj

hrj Jan 29, 2015

Member

Oh, thanks for reporting, @xaoseric

We don't use Windows much, hence missed it. Will try to analyse and fix this soon.

Member

hrj commented Jan 29, 2015

Oh, thanks for reporting, @xaoseric

We don't use Windows much, hence missed it. Will try to analyse and fix this soon.

@hrj hrj added the bug label Jan 29, 2015

@hrj hrj added this to the 0.4 milestone Jan 29, 2015

hrj added a commit that referenced this issue Feb 1, 2015

@hrj hrj changed the title from gngr v0.3.5 does not create .gngr folder on windows to gngr v0.3.5 throws exception when first run on windows Feb 1, 2015

@hrj

This comment has been minimized.

Show comment
Hide comment
@hrj

hrj Feb 1, 2015

Member

The .gngr folder was being created. But the permissions were not set correctly for Windows. h2 uses different paths on Windows and hence the problem was not detected. It worked fine in earlier releases, probably because h2 permissions were slightly different.

Fixed in version 0.3.6

Member

hrj commented Feb 1, 2015

The .gngr folder was being created. But the permissions were not set correctly for Windows. h2 uses different paths on Windows and hence the problem was not detected. It worked fine in earlier releases, probably because h2 permissions were slightly different.

Fixed in version 0.3.6

Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment