Skip to content

Make sure you link against python2 #2

Closed
RedBeard0531 opened this Issue Jan 30, 2013 · 9 comments

10 participants

@RedBeard0531

On Archlinux the default python is 3.x and you need to use python2 to get 2.x. Also need to include from /usr/lib/python2.7 not /usr/lib/python3.3m. Interestingly the ycm_core module compiles and loads fine as Py3 but ycm.py won't as it uses Py2 syntax. The error message in vim for this case incorrectly suggests that a missing libclang.so is to blame.

@Valloric Valloric closed this in 594d836 Jan 30, 2013
@Valloric
Owner

Thanks for catching this; should be fixed now.

@jan--f
jan--f commented Feb 5, 2013

Issue seems to be still present.
When starting vim the following error is produced:
YouCompleteMe unavailable: requires python 2.x

python 2.7.3 is installed (also python3). vim is on version 7.3.754. ycm was build without semantic support for c family and worked very well. System is 64 bit Arch Linux 3.7.4-1.

@stuartmemo

Having same issue...

Screen Shot 2013-02-05 at 16 29 52

@stelleg
stelleg commented Feb 5, 2013

Same issue, set default python to alias to python2.7.3, still getting "YouCompleteMe unavailable: requires python 2.x"

python --version
Python 2.7.3

vim
YouCompleteMe unavailable: requires python 2.x
@mispencer mispencer referenced this issue in mispencer/YouCompleteMe Jul 15, 2013
@Chiel92 Chiel92 minor refactoring PR #2 e15ec6e
This was referenced Sep 7, 2013
@jhannah01 jhannah01 pushed a commit that referenced this issue Nov 8, 2013
@Chiel92 Chiel92 minor refactoring PR #2 9f19ae7
@frankyjuang

Still having this issue
screenshot3

@vheon
Collaborator
vheon commented Jun 25, 2014

@frankyjuang what is the output of vim --version?

@pinkisemils

Updated 5 minutes ago, and python/ycm/base.py and python/ycm/vimsupport.py still reference python instead of python2.
Changing the shebang to use
#!/usr/bin/env python2
instead of
#!/usr/bin/env python
should not be that hard ;)

@micbou
Collaborator
micbou commented Nov 11, 2015

Changing those shebangs would do nothing. In fact, we should remove them. There are only useful for the install.py and run_tests.py scripts.

@Yamakaky

Could this be fixed for install.py and run_tests.py? This issue has been open for two years, even if it's a small change to make.

Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment
Something went wrong with that request. Please try again.