Skip to content
New issue

Have a question about this project? Sign up for a free GitHub account to open an issue and contact its maintainers and the community.

By clicking “Sign up for GitHub”, you agree to our terms of service and privacy statement. We’ll occasionally send you account related emails.

Already on GitHub? Sign in to your account

Beam NG (284160) #1237

Open
JamesHealdUK opened this issue Sep 4, 2018 · 17 comments

Comments

Projects
None yet
10 participants
@JamesHealdUK
Copy link

commented Sep 4, 2018

It launches fine, switches to full screen at which point its black.... Then it crashes and the BeamNG crash reporter comes up: https://gist.github.com/JamesHealdUK/2497ce5b2c5c123d4ad5878ed1042e67

Steam generates a huge ass log file for it too (16mb big!) https://gist.github.com/JamesHealdUK/478e3dc53c14a2168a05ba5a0755d729
Tried with both esync enabled and disabled to no avail.

@kisak-valve kisak-valve changed the title Beam NG Launches but full black screen and crash Beam NG Launches but full black screen and crash (284160) Sep 4, 2018

@tele1

This comment has been minimized.

Copy link

commented Sep 5, 2018

Beam NG installed from Steam, not working for Steam.
But working with Wine "Wine Staging 3.14"

just run command from place with game

wine BeamNG.drive.exe

test it, have fun. 😄

Tested on Hardware & Software:
OS: Linux Mint 18.3 Sylvia 64bit
DRIVER: NVIDIA 396.54 from repository
deb-src http://ppa.launchpad.net/graphics-drivers/ppa/ubuntu xenial main
GPU: Nvidia GTX 660
CPU: i5-3470
STEAM: Beta / Proton 3.7-5
also
Wine Staging 3.14 from repository
deb https://dl.winehq.org/wine-builds/ubuntu/ xenial main

confirmed it also on the website where is list of tested games by Steam Beta users
( "Steam Play Compatibility Reports" , I get this link from other user )
https://docs.google.com/spreadsheets/d/e/2PACX-1vQ3_odz8JzEVK80vkku-b6FsICWb45xGf4VYnzYz5cNSMVQ-5BA2WoHBGAScw96MgLj1ONA7Cx0tyGa/pubhtml#

Inside this website (... docs.google ...) you have
on the top a link to report your tests.

@bfayers

This comment has been minimized.

Copy link

commented Sep 24, 2018

Just tested for myself and can confirm that via proton version 3.7-6 it black screens and crashes, using wine staging from winehq it works fine

@bfayers

This comment has been minimized.

Copy link

commented Sep 26, 2018

@tele1 The crash seems to be due to wine-mono/gecko being missing. Following this: https://www.reddit.com/r/wine_gaming/comments/8r6low/guide_how_to_install_net_45_on_64bit_prefixes/ makes it work but when launching via steam it seems to remove any custom additions to the prefix.

@Maltahl

This comment has been minimized.

Copy link

commented Nov 15, 2018

As of the new update last week beamng is unable to launch anymore with Wine 3.14+ and DXVK.
I suspect that the developer have changed something major since it wont go past splashscreen anymore on old working setups.

I get this in the console. Seems like some Nvidia API being used despite having an AMD GPU.

[1115/222729:ERROR:network_change_notifier_win.cc(159)] WSALookupServiceBegin failed with: 8 [1115/222729:ERROR:gpu_info_collector_win.cc(102)] Can't retrieve a valid WinSAT assessment. 0.00000|I|WinMain|launcher command line: Z:\media\maltahl\Storage\Games\SteamLibrary\steamapps\common\BeamNG.drive\BeamNG.drive.exe 0.00000|I|WinMain|launcher args (1): 0.00000|I|WinMain| - 0 = Z:\media\maltahl\Storage\Games\SteamLibrary\steamapps\common\BeamNG.drive\BeamNG.drive.exe 0.01834|D|baseFS|gameroot = 'Z:\media\maltahl\Storage\Games\SteamLibrary\steamapps\common\BeamNG.drive\' 0.01839|D|baseFS|userpath = 'C:\users\maltahl\My Documents\BeamNG.drive\' , Reason = Default path 0.18342|E|fixNvidia|NVAPI: Failed NvAPI_DRS_CreateSession 0.22181|E|fixNvidia|NVAPI: Failed NvAPI_DRS_CreateSession 1.79046|E|BNGBase::Power::setPowerSchemeMaxPerformance|Failed to get active performance scheme 1.84586|D|launchGame|launched, waiting for it now ... 0.00000|E|blacklist::Initialize|Failed to load and parse the settings file to get blacklisted DLLs 'Z:\media\maltahl\Storage\Games\SteamLibrary\steamapps\common\BeamNG.drive\settings\thirdpartyFilter.ini' Setting breakpad minidump AppID = 284160 Steam_SetMinidumpSteamID: Caching Steam ID: 76561198035895524 [API loaded no]

@mrdev023

This comment has been minimized.

Copy link

commented Nov 19, 2018

It doesn't work for me. Error 0x00000001

@echoz28

This comment has been minimized.

Copy link

commented Dec 13, 2018

Game runs now with 3.16-5. I am however unable to change controls properly. Whatever changes I make do not register and then upon the next loading of some sort of resources (reload car, load a map, restart the game) only the last change I've made gets saved. I have to repeat this process for every button I want to change.

@echoz28

This comment has been minimized.

Copy link

commented Dec 14, 2018

It also crashes quite frequently, after loading maybe 5-7 different cars, not at the same time but in total over one session. Seemingly takes fewer cars to crash the game on bigger maps.

@ShaneTursam

This comment has been minimized.

Copy link

commented Dec 17, 2018

With Proton version 3.16-5 I can load and play the game but it is horribly slow no matter what graphic setting I choose. I'm using a I5-6500k and 960gtx. When running natively within Windows I can almost max everything and stay above 60fps. I have no idea what the issue is or what is bogging down but my GPU usage hovers at around 30% and my Quad core has all cores at about 70%. Any help would be appreciated, or if you have any settings I would be able to change for a performance increase I would be interested.

@ShaneTursam

This comment has been minimized.

Copy link

commented Dec 17, 2018

So my problem was I had to uncheck limit FPS, if I had it set to 60fps I would get around 20FPS. I also noticed that certain custom vehicles would cause the fps to crash pretty hard. Other than that things seem about normal for playing a game inside of wine instead of natively. Thanks for the hard work!

@daprice

This comment has been minimized.

Copy link

commented Jan 16, 2019

I'm using a Logitech Momo racing wheel and force feedback only works under certain (bizarre) conditions. I have to be driving a non-power-steering variant of the Gavril Vanster (no other car works for this, power steering or not), and if at any point I drive a different vehicle, force feedback stops working until I restart the game. This means that to get it working in the first place, I had to open the Garage, load the "Drift Missile" or "Off-Road" Vanster, save it as the default vehicle, then quit and relaunch the game and play free roam. The only clue I have to help explain this is that with any other vehicle, DirectInputDevice::sendForceFeedback|Failed to start FF effect: DIERR_GENERIC appears in the in-game console, but that line doesn't appear when driving either of those two vans. None of the game's force feedback compatibility settings (update rate, fast/full updates, etc) seem to affect this phenomenon.

I also get frequent crashes, usually when loading levels or vehicles. It seems like larger maps (Italy and San Francisco, especially) crash on load the first few attempts but then start working (possibly something to do with caching? Clearing the game's cache makes the maps crash again)

@echoz28 I found that I could change multiple settings at a time, then immediately quit and relaunch the game and they'd all be saved (even though some of the changes didn't show up while I was changing them).

@kisak-valve

This comment has been minimized.

Copy link
Member

commented Jan 16, 2019

Hello @daprice, please copy your system information from steam (Steam -> Help -> System Information) and put it in a gist, then include a link to the gist in this issue report. Also, please add PROTON_LOG=1 %command% to the game's launch options, reproduce one of the crashes you are seeing, and drag and drop the generated $HOME/steam-$APPID.log into the comment box.

@daprice

This comment has been minimized.

Copy link

commented Jan 16, 2019

@kisak-valve Steam System Information: https://gist.github.com/daprice/2ae2906d58f4e753554ab80d8e869640

Uncompressed, the proton log is 464MB! To get it small enough to upload I had to compress it with .tar.xz, then again with .zip so GitHub would take it (sorry!). Prior to this session, I cleared the game's cache. The log is of opening the game, choosing Play -> Free Roam -> Italy -> Default spawn, then the game shows its loading screen for a while, when it finishes loading it displays a few frames with a lot of missing scenery then crashes.
steam-284160.tar.xz.zip

Edit: Sorry, forgot to mention this is with Proton 3.16-6 beta

@daprice

This comment has been minimized.

Copy link

commented Jan 16, 2019

Here's a separate log from testing the steering wheel force feedback issue (same System Information as my previous comment).

For this log, I opened the game, chose Play -> Free Roam -> Grid, Small, Pure map -> Default spawn with the Off Road Vanster as default vehicle, the game loads, when it's finished loading I move the wheel back and forth to test force feedback (it's working), then I switch to a different vehicle, the Ibishu Covet Beater, and move the wheel again (now force feedback is no longer working but wheel input still works), then I exit from the game. (thankfully this one only needed zip compression)
steam-284160.zip

@echoz28

This comment has been minimized.

Copy link

commented May 5, 2019

Seems to get stuck on a black screen for me, too. Tried launching through a terminal but there was no interesting output. I hear the little sound that you'd normally hear when you get to the main menu but the image remains completely black. Steam overlay works fine and shows that it's rendering the black screen at 1000+ FPS.

@BieHDC

This comment has been minimized.

Copy link

commented May 6, 2019

The black screen issue is more of a general issue, the workaround by the devs fixed it for me.
https://www.beamng.com/threads/0-16-black-screen-issue-info-and-fix.62130/

@echoz28

This comment has been minimized.

Copy link

commented May 13, 2019

The black screen issue has been fixed in the most recent update for the game.

@kisak-valve kisak-valve changed the title Beam NG Launches but full black screen and crash (284160) Beam NG (284160) May 13, 2019

@BieHDC

This comment has been minimized.

Copy link

commented May 16, 2019

The black screen issue has been fixed in the most recent update for the game.

To clarify, fixed as in they disabled the multi threaded renderer by default

Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment
You can’t perform that action at this time.