Skip to content


Subversion checkout URL

You can clone with
Download ZIP


[CS:S and TF2] No voice input VIA HD Audio #1307

gutigen opened this Issue · 4 comments

4 participants


Update: Problem persist in Ubuntu 13.04.

I can hear people talking on voice chat, but they can't hear me. Mic is working in Skype, TS3 and any other app. Everything in CS:S and TF2 voice options is fine (sliders at max).

"Test microphone" in game shows that mic is working. Tried switchting to AC97 and back to HD Audio, still not working.

My Sound settings in System Settings looks like this:
So I installed Pulse Audio Volume Control from Ubuntu repository (pavucontrol package) and there I got my mic visible with monitors showing it's working, I checked every single setting for it, no effect.
Another thing I've noticed is that "test microphone" tool in game doesn't work anymore after I join any server, I have to start game again to use it.

Worked for a moment with this fix (doesn't anymore after few restarts for some reason):

Go to Bios > Chipset > Front Panel (or something like that), change it to AC97, boot your system.
Now follow this steps:

Ubuntu 12.10 Gnome Remix
Kernel 3.5.0-23
Terminal output:
Analog headset


Same issue here. I can hear myself when testing the microphone in the voice options tab but people in game can't hear me even though I can hear them.

@bdeen-valve bdeen-valve was assigned

Actually this is no longer an issue for me.

Which is weird because I didn't notice any updates to CSS. I was testing it with a brand new microphone so it's also possible I was just doing something stupid.
Also, my system just went through several updates, so if it was an issue before perhaps it was fixed there.

But I did confirm just now that others could hear me on the mic.


This seems to work here...and you're no longer hearing an issue.

@gutigen: if you could get me more information ala,, that would be helpful.

@jorgenpt jorgenpt referenced this issue in ValveSoftware/Source-1-Games

[CS:S and TF2] No voice input VIA HD Audio [Updated] #106


Issue transferred to ValveSoftware/Source-1-Games#106.

This issue is closed - continue conversation there.

@jorgenpt jorgenpt closed this
Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment
Something went wrong with that request. Please try again.