HL1: all save games disappeared #1336

Closed
aruseni opened this Issue Feb 6, 2013 · 11 comments

Comments

Projects
None yet
5 participants

aruseni commented Feb 6, 2013

I just tried to run Half-Life 1 (just after it updated another time) and faced the fact that all the save games are lost (and the Half-Life/valve/SAVE directory is empty).

Here is system info:

Processor Information:
    Vendor:  GenuineIntel
    Speed: 2670 Mhz
    4 logical processors
    4 physical processors
    HyperThreading:  Unsupported
    FCMOV:  Supported
    SSE2:  Supported
    SSE3:  Supported
    SSSE3:  Supported
    SSE4a:  Unsupported
    SSE41:  Supported
    SSE42:  Unsupported

Network Information:
    Network Speed:  

Operating System Version:
    Ubuntu 12.10 (64 bit)
    Kernel Name:  Linux
    Kernel Version:  3.5.0-23-generic
    X Server vendor:  The X.Org Foundation
    X Server release:  11300000

Video Card:
    Driver:  NVIDIA Corporation GeForce 9600 GT/PCIe/SSE2

    Driver Version:  3.3.0 NVIDIA 304.51
    Desktop Color Depth: 24 bits per pixel
    Monitor Refresh Rate: 60 Hz
    VendorID:  0x10de
    DeviceID:  0x622
    Number of Monitors:  1
    Number of Logical Video Cards:  1
    Primary Display Resolution:  1920 x 1080
    Desktop Resolution: 1920 x 1080
    Primary Display Size: 20.08" x 11.30"  (23.03" diag)
                                            51.0cm x 28.7cm  (58.5cm diag)
    Primary Bus: PCI Express 16x
    Primary VRAM: 512 MB
    Supported MSAA Modes:  2x 4x 8x 16x 

Sound card:
    Audio device: Realtek ALC1200

Memory:
    RAM:  2002 Mb

Miscellaneous:
    UI Language:  English
    LANG:  en_US.UTF-8
    Microphone:  Not set
    Total Hard Disk Space Available:  151189 Mb
    Largest Free Hard Disk Block:  105657 Mb

Installed software:

Recent Failure Reports:
    Mon Feb  4 21:55:11 2013 GMT: file ''/tmp/dumps/assert_20130204235509_1.dmp'', upload yes: ''CrashID=bp-13c5964c-ce1e-44fd-9653-41fa62130204''

The crash dump mentioned in the system info: assert_20130204235509_1.dmp

@ghost ghost assigned alfred-valve Feb 6, 2013

Tele42 commented Feb 6, 2013

For me, the old save folder was ~/.local/share/Steam/SteamApps/common/Half-Life/SAVE and the new save folder is ~/.local/share/Steam/SteamApps/common/Half-Life/valve/SAVE. Simply moving the save files made them reappear.

aruseni commented Feb 7, 2013

Hmm. Thanks, Tele42.

In fact, some of the save games appeared in the loading menu after moving the files, but the latest ones didn’t.

aruseni commented Feb 7, 2013

Oh, wait, I’ve found them.

The thing is I had the latest saves in ~/.local/share/Steam/SteamApps/common/Half-Life/valve_hd/SAVE/.

I found them using the find command:

cd ~/.local/share/Steam/SteamApps/
find . -name *.sav -type f

Once again, thanks for the help!

This is a side effect of the bug I fixed today, we were saving games in the wrong place, it is fixed but the game may not longer see your old games. The fixes above to manually copy them are the right answer, it won't happen again as we now land the saves in the right place.

Yulike commented Feb 7, 2013

Any chance we'll see cloud saving?

We already have cloud saves for HL1 :), anything from valve/save/* is automatically clouded and restored (which is why I had to fix the bug of saves going to save/ or valve_hd/save by mistake).

aruseni commented Feb 7, 2013

Wow, thanks for that!

By the way, amazing work. 👍

Yulike commented Feb 7, 2013

Fantastic, thank you. :) You should update the store page to show that, now about those Achievements...

I'm using Steam on Mac, and had the same issue with HL1. The entire ~/.local/share/Steam directory referenced above doesn't exist on my machine, and I assume that there's some alternate location for Mac. Should I open a new bug report for this?

Tele42 commented Feb 8, 2013

@wylieconlon: The folder locations vary from OS to OS, but the fix is the same, and there is nothing to be done to the game. This is just one of those growing pain experiences of a beta.
EDIT: Try to find where the SteamApps folder is tucked away and go from there.

@Tele42 Thanks, on Mac I found the existing saves at ~/Library/Application\ Support/Steam/SteamApps/common/Half-Life/valve_hd/SAVE and moved that directory to ~/Library/Application\ Support/Steam/SteamApps/common/Half-Life/valve/SAVE which appears to fix the issue.

Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment