New issue

Have a question about this project? Sign up for a free GitHub account to open an issue and contact its maintainers and the community.

By clicking “Sign up for GitHub”, you agree to our terms of service and privacy statement. We’ll occasionally send you account related emails.

Already on GitHub? Sign in to your account

Steam Chat issue #5612

Open
armangido opened this Issue Aug 8, 2018 · 7 comments

Comments

Projects
None yet
6 participants
@armangido
Copy link

armangido commented Aug 8, 2018

Your system information

  • Steam client version (build number or date): Aug 1, 2018
  • Distribution (e.g. Ubuntu): ParrotOS(Kali Linux
  • Opted into Steam client beta?: [Yes/No] No
  • Have you checked for system updates?: [Yes/No] Yes

Please describe your issue in as much detail as possible:

The issue everytime I login on steam then it will say "Friends Network Unreachable
Screenshot:https://prnt.sc/kg5xvg (I can't upload here)

System Ver: 4.16.0-parrot16-amd64
Add:Linux parrot 4.16.0-parrot16-amd64 #1 SMP Parrot 4.16.16-2parrot16 (2018-07-08) x86_64 GNU/Linux
I contacted steam support already for this they recommend posting here.

@johndrinkwater

This comment has been minimized.

Copy link
Member

johndrinkwater commented Aug 26, 2018

Held off updating Steam because the beta client had this issue and Ti8 was just around the corner, however now updating into the latest beta shows it still remains.

Not only does friends network never get reachable, it breaks dota2

20180826123045_1

Using steam runtime with a pinned lib fix here for libnss, nothing obviously appears in logs for why this fails. No software firewall is running.

@kgdowner

This comment has been minimized.

Copy link

kgdowner commented Aug 28, 2018

I'm getting this as well. Just installed a new system, and the chat will not connect. Running steam with steam -nochatui -nofriendsui works to bring back the old friends list, which connects fine, just stops me from using any of the new chat features. Bug is there in both beta and non-beta steam.

Your system information

  • Steam client version (build number or date): 1533766730, Aug 8 2018, at 21:32:49
  • Distribution (e.g. Ubuntu): Void Linux x86_64 Linux 4.17.18_1
  • Opted into Steam client beta?: [Yes/No] both
  • Have you checked for system updates?: [Yes/No] yes

edit: not sure if related, but when using the new chat ui, I get a bunch of JS method call log entries:

JS method call WebChat.GetWebChatLanguage with 1 arguments
JS method call WebChat.RegisterForFriendPostMessage with 1 arguments
JS method call WebChat.GetSignIntoFriendsOnStart with 1 arguments
JS method call WebChat.RegisterForFriendPostMessage with 1 arguments
JS method call WebChat.GetWebChatURL with 1 arguments
JS method call WebChat.GetLocalPersonaName with 1 arguments
JS method call WebChat.GetLocalAvatarBase64 with 1 arguments

@johndrinkwater

This comment has been minimized.

Copy link
Member

johndrinkwater commented Sep 3, 2018

Can you both share your TZ setting?

Had added the below code to my environment to resolve a Firefox bug that was triggering during early multiprocess work; setting to TZ=Europe/London resolved this issue for me.

# make our system stop stat-ing https://blog.packagecloud.io/eng/2017/02/21/set-environment-variable-save-thousands-of-system-calls/
export TZ=":/etc/localtime"  

Adding some reference bug reports:

@kgdowner

This comment has been minimized.

Copy link

kgdowner commented Sep 6, 2018

Alright, got some spare time and did some more testing.
I didn't have TZ set on my system (although that was a good read, I'll probably set that now), however looking into my time zone was exactly what I needed. I had setup the system to use posix/US/Pacific, and setting it to just US/Pacific fixed the chat connection.

@majcherek2048

This comment has been minimized.

Copy link

majcherek2048 commented Sep 16, 2018

Thank you @kgdowner !
The old version works just fine here as well, whereas the new one is broken in the latest non-beta release here. Steam API: v018, Built: Sep 8 2018 at 19:21:25

For reference, I'm using family mode here (which I unlock on my own PC) in case the issue is related to this.
As a bouns the client seems to be much more responsive again, now that I'm using these flags.

@Anonymous1157

This comment has been minimized.

Copy link

Anonymous1157 commented Sep 28, 2018

I had TZ=:/etc/localtime on my system and starting steam with TZ=America/New_York made the new Friends interface work. Thanks everyone in this thread for a simple workaround!

@Israphel

This comment has been minimized.

Copy link

Israphel commented Feb 10, 2019

I exectuted:

export TZ=America/Argentina/Buenos_Aires

and still the chat won't work. Am I missing something?

Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment