Have a question about this project? Sign up for a free GitHub account to open an issue and contact its maintainers and the community.

Already on GitHub? Sign in to your account

Steam starts again on Exit #605

Closed
Majkl578 opened this Issue Jan 9, 2013 · 28 comments

Comments

Projects
None yet

Majkl578 commented Jan 9, 2013

After today's update, when I run Steam and then exit it (Steam -> Exit), it starts again. After second attempt, it really quits.

Debian x64 experimental, Gnome Shell 3.6.

micb25 commented Jan 9, 2013

I have the same problem on openSUSE 12.2 x86_64 with KDE 4.8.5.

Same issue in Ubuntu 12.10 x86_32. Also I am unable to launch any games unless I exit and allow it to reopen.

It appears to try and reapply the update after the first close.

@ghost ghost assigned johnv-valve Jan 9, 2013

fur0n commented Jan 9, 2013

I too have the same issue.

@ghost

ghost commented Jan 9, 2013

Same thing over Kubuntu 12.10 64-bits.

Same here. On Archlinux 64bit and Xfce 4.10 with current kernel and nouveau driver.

sinatosk commented Jan 9, 2013

Archlinux 64bit with KDE 4.9.5

Same here. Kubuntu 12.04 (32bits)

w-flo commented Jan 9, 2013

Same. Kubuntu 12.10 64 bit. [Skipping detailed system info, as it is probably not important.]

Skiski commented Jan 9, 2013

I have the same problem on Fedora 17 64bit since yesterday's update.

When I launch Steam, some games, like SPAZ, don't work because they fail to detect that Steam is running.

When I close Steam, it restarts, updates itself and then everything is working right.

l1bbcsg commented Jan 9, 2013

It seems I have the same problem: Games can't connect to steam network (TF2 can't find servers or connect to item server, Trine 2 fails to load my cloud saves). Upon restarting, steam shows Updating dialog for a brief moment, then restarts. Pressing Exit again does close it finally. But even after restart games still can't connect to servers.
I tried getting rid of ClientRegistry.blob, but that didn't help. Then I cleaned some files from steam folder and it's redownloading them now, but it seems I just wasted some time and traffic.

Wait,it actually helped with network problems.

Same in KDE KUbuntu 12.04. Always open an additional time before i exit.

Same. Ubuntu 12.04 64bit

Member

johndrinkwater commented Jan 9, 2013

Each time, If I start a new steam client and close it, it will open again.

Member

MrSchism commented Jan 9, 2013

Likewise. Happening here, too.

Same here on Arch64 + KDE.

@ghost ghost assigned slouken Jan 9, 2013

dilworks commented Jan 9, 2013

Same. Debian Wheezy AMD64 + KDE4.

@ghost ghost assigned johnv-valve Jan 9, 2013

Owner

johnv-valve commented Jan 9, 2013

oops!

I'm having this issue too. Ubuntu 12.04 64 bits with Unity

Gps2010 commented Jan 9, 2013

Same here, also after rebooting pc.

openSuse 12.2 - 64 bit - kde.

I also notice a screen with a X in the top left corner.
It states its updating steam ( again? )

Before steam restarts.

When I check in the gui for updates, it says latest version.

Since the update can join servers, but It tells me it can't sync with the cloud, progress might be lost. I am not sure if its related though..

Same here. :)
Ubuntu 12.04 64bit, Fluxbox

dNovel commented Jan 9, 2013

Can confirm this on Ubuntu 12.04 LTS.

Member

johndrinkwater commented Jan 9, 2013

That’s enough confirmations please, peeps, it has been noticed. :)

I think everyone's voice is important - statistical data can be also needed for management etc.
It can be also affecting only some versions of Ubuntu or (put whatever software/library/OS part here).

Owner

johnv-valve commented Jan 9, 2013

it's fixed in the next update, no more data required!

Good to hear that!

l1bbcsg : I seem to have acquired the same issue and it might be related to my bug, although this started happening afterwards. Still, the same issues occurs.

|1bbcsg wrote:

It seems I have the same problem: Games can't connect to steam network (TF2 can't find servers or connect to item server, Trine 2 fails to load my cloud saves). Upon restarting, steam shows Updating dialog for a brief moment, then restarts. Pressing Exit again does close it finally. But even after restart games still can't connect to servers.
I tried getting rid of ClientRegistry.blob, but that didn't help. Then I cleaned some files from steam folder and it's redownloading them now, but it seems I just wasted some time and traffic.

#635

You guys know this is still happening right? I just had steam restart itself after closing 3 times in a row, really annoying! I'm using the latest beta build:
image

Tele42 commented May 30, 2016

@Fornax96 since this issue had been closed for 3 years and did not have any activity in that time, you should go ahead and open a new issue report with your system information as requested at https://github.com/ValveSoftware/steam-for-linux#reporting-issues.

Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment