DEFCON crashes when trying to authenticate #654

Closed
EoD opened this Issue Jan 11, 2013 · 30 comments

Comments

Projects
None yet
9 participants
@EoD

EoD commented Jan 11, 2013

While using Steam 1.0.0.18 DEFCON was not able to authenticate me as a user and therefore dropped to "DEMO mode":

Game update: AppID 1520 "DEFCON", ProcID 22843, IP 0.0.0.0:0
Steam: An X Error occurred
X Error of failed request: BadWindow (invalid Window parameter)
Major opcode of failed request: 40 (X_TranslateCoords)
Resource id in failed request: 0x14022c7
Serial number of failed request: 221421
ERROR: ld.so: object 'gameoverlayrenderer.so' from LD_PRELOAD cannot be preloaded: ignored.
ERROR: ld.so: object 'gameoverlayrenderer.so' from LD_PRELOAD cannot be preloaded: ignored.
saving roaming config store to 'sharedconfig.vdf'
roaming config store 2 saved successfully
[S_API FAIL] SteamAPI_Init() failed; SteamAPI_IsSteamRunning() failed.
[S_API FAIL] SteamAPI_Init() failed; unable to locate a running instance of Steam, or a local steamclient.dll.
Installing breakpad exception handler for appid(gameoverlayui)/version(20130108113744_client)
Installing breakpad exception handler for appid(gameoverlayui)/version(1.0_client)
Installing breakpad exception handler for appid(gameoverlayui)/version(1.0_client)
Installing breakpad exception handler for appid(gameoverlayui)/version(1.0_client)
[0111/185734:ERROR:object_proxy.cc(239)] Failed to call method: org.freedesktop.DBus.Error.ServiceUnknown: The name org.freedesktop.NetworkManager was not provided by any .service files
[0111/185734:WARNING:proxy_service.cc(646)] PAC support disabled because there is no system implementation
Game removed: AppID 1520 "DEFCON", ProcID 22845
saving roaming config store to 'sharedconfig.vdf'
roaming config store 2 saved successfully

When I updated to 1.0.0.20, it seems to be able to authenticate but it segfaults before I get to read what's happening. It's definitely crashing before the main menu.

Game update: AppID 1520 "DEFCON", ProcID 32533, IP 0.0.0.0:0
ERROR: ld.so: object 'gameoverlayrenderer.so' from LD_PRELOAD cannot be preloaded: ignored.
ERROR: ld.so: object 'gameoverlayrenderer.so' from LD_PRELOAD cannot be preloaded: ignored.
saving roaming config store to 'sharedconfig.vdf'
roaming config store 2 saved successfully
Setting breakpad minidump AppID = 1520
Steam_SetMinidumpSteamID: Caching Steam ID: 76561198054163081 [API loaded no]
Installing breakpad exception handler for appid(gameoverlayui)/version(20130108113744_client)
Installing breakpad exception handler for appid(gameoverlayui)/version(1.0_client)
Installing breakpad exception handler for appid(gameoverlayui)/version(1.0_client)
Installing breakpad exception handler for appid(gameoverlayui)/version(1.0_client)
[0111/191712:ERROR:object_proxy.cc(239)] Failed to call method: org.freedesktop.DBus.Error.ServiceUnknown: The name org.freedesktop.NetworkManager was not provided by any .service files
[0111/191712:WARNING:proxy_service.cc(646)] PAC support disabled because there is no system implementation
/data/Games/Steam_Linux/SteamApps/common/Defcon/run_steam.sh: line 10: 32534 Segmentation fault ./defcon.bin.x86
Game removed: AppID 1520 "DEFCON", ProcID 32534
saving roaming config store to 'sharedconfig.vdf'
roaming config store 2 saved successfully

System info can be found here: https://gist.github.com/4512834

@johndrinkwater

This comment has been minimized.

Show comment Hide comment
@johndrinkwater

johndrinkwater Jan 11, 2013

Member

The error from 1.0.0.18 can be ignored (see #626). If you disable the in-game community overlay, does that stop DEFCON from crashing?

Member

johndrinkwater commented Jan 11, 2013

The error from 1.0.0.18 can be ignored (see #626). If you disable the in-game community overlay, does that stop DEFCON from crashing?

@EoD

This comment has been minimized.

Show comment Hide comment
@EoD

EoD Jan 11, 2013

No, it doesn't stop it from crashing.

Game update: AppID 1520 "DEFCON", ProcID 3812, IP 0.0.0.0:0
saving roaming config store to 'sharedconfig.vdf'
roaming config store 2 saved successfully
Setting breakpad minidump AppID = 1520
Steam_SetMinidumpSteamID:  Caching Steam ID:  76561198054163081 [API loaded no]
/data/Games/Steam_Linux/SteamApps/common/Defcon/run_steam.sh: line 10:  3813 Segmentation fault      ./defcon.bin.x86
Game removed: AppID 1520 "DEFCON", ProcID 3813 
saving roaming config store to 'sharedconfig.vdf'
roaming config store 2 saved successfully

EoD commented Jan 11, 2013

No, it doesn't stop it from crashing.

Game update: AppID 1520 "DEFCON", ProcID 3812, IP 0.0.0.0:0
saving roaming config store to 'sharedconfig.vdf'
roaming config store 2 saved successfully
Setting breakpad minidump AppID = 1520
Steam_SetMinidumpSteamID:  Caching Steam ID:  76561198054163081 [API loaded no]
/data/Games/Steam_Linux/SteamApps/common/Defcon/run_steam.sh: line 10:  3813 Segmentation fault      ./defcon.bin.x86
Game removed: AppID 1520 "DEFCON", ProcID 3813 
saving roaming config store to 'sharedconfig.vdf'
roaming config store 2 saved successfully
@urkle

This comment has been minimized.

Show comment Hide comment
@urkle

urkle Jan 11, 2013

There is an update to DEFCON linux that i'll be pushing out this weekend (After more testing with newer client) that will hopefully fix this issue.

urkle commented Jan 11, 2013

There is an update to DEFCON linux that i'll be pushing out this weekend (After more testing with newer client) that will hopefully fix this issue.

@Pr0b

This comment has been minimized.

Show comment Hide comment
@Pr0b

Pr0b Jan 13, 2013

The problem still persists ..

Game update: AppID 1520 "DEFCON", ProcID 2002, IP 0.0.0.0:0
ERROR: ld.so: object 'gameoverlayrenderer.so' from LD_PRELOAD cannot be preloaded: ignored.
ERROR: ld.so: object 'gameoverlayrenderer.so' from LD_PRELOAD cannot be preloaded: ignored.
Steam: An X Error occurred
X Error of failed request:  BadWindow (invalid Window parameter)
Major opcode of failed request:  20 (X_GetProperty)
Resource id in failed request:  0x260011a
Serial number of failed request:  621730
saving roaming config store to 'sharedconfig.vdf'
roaming config store 2 saved successfully
Setting breakpad minidump AppID = 1520
Steam_SetMinidumpSteamID:  Caching Steam ID:  76561197976233996 [API loaded no]
Installing breakpad exception handler for appid(gameoverlayui)/version(20130111144324_client)
Installing breakpad exception handler for appid(gameoverlayui)/version(1.0_client)
Installing breakpad exception handler for appid(gameoverlayui)/version(1.0_client)
Installing breakpad exception handler for appid(gameoverlayui)/version(1.0_client)

(gameoverlayui:2010): Gtk-WARNING **: Unable to locate theme engine in module_path: "adwaita",
[0113/182429:ERROR:object_proxy.cc(239)] Failed to call method: org.freedesktop.systemd1.LoadFailed: Unit dbus-org.freedesktop.NetworkManager.service failed to load: No such file or directory. See system logs and 'systemctl status dbus-org.freedesktop.NetworkManager.service' for details.
[0113/182429:WARNING:proxy_service.cc(646)] PAC support disabled because there is no system implementation
/home/rob/.local/share/Steam/SteamApps/common/Defcon/run_steam.sh: line 10:  2003 Segmentation fault      (core dumped) ./defcon.bin.x86
Game removed: AppID 1520 "DEFCON", ProcID 2003 
saving roaming config store to 'sharedconfig.vdf'
roaming config store 2 saved successfully

EDIT: I am not sure if it's relevant, but I also don't use NetworkManager.

Pr0b commented Jan 13, 2013

The problem still persists ..

Game update: AppID 1520 "DEFCON", ProcID 2002, IP 0.0.0.0:0
ERROR: ld.so: object 'gameoverlayrenderer.so' from LD_PRELOAD cannot be preloaded: ignored.
ERROR: ld.so: object 'gameoverlayrenderer.so' from LD_PRELOAD cannot be preloaded: ignored.
Steam: An X Error occurred
X Error of failed request:  BadWindow (invalid Window parameter)
Major opcode of failed request:  20 (X_GetProperty)
Resource id in failed request:  0x260011a
Serial number of failed request:  621730
saving roaming config store to 'sharedconfig.vdf'
roaming config store 2 saved successfully
Setting breakpad minidump AppID = 1520
Steam_SetMinidumpSteamID:  Caching Steam ID:  76561197976233996 [API loaded no]
Installing breakpad exception handler for appid(gameoverlayui)/version(20130111144324_client)
Installing breakpad exception handler for appid(gameoverlayui)/version(1.0_client)
Installing breakpad exception handler for appid(gameoverlayui)/version(1.0_client)
Installing breakpad exception handler for appid(gameoverlayui)/version(1.0_client)

(gameoverlayui:2010): Gtk-WARNING **: Unable to locate theme engine in module_path: "adwaita",
[0113/182429:ERROR:object_proxy.cc(239)] Failed to call method: org.freedesktop.systemd1.LoadFailed: Unit dbus-org.freedesktop.NetworkManager.service failed to load: No such file or directory. See system logs and 'systemctl status dbus-org.freedesktop.NetworkManager.service' for details.
[0113/182429:WARNING:proxy_service.cc(646)] PAC support disabled because there is no system implementation
/home/rob/.local/share/Steam/SteamApps/common/Defcon/run_steam.sh: line 10:  2003 Segmentation fault      (core dumped) ./defcon.bin.x86
Game removed: AppID 1520 "DEFCON", ProcID 2003 
saving roaming config store to 'sharedconfig.vdf'
roaming config store 2 saved successfully

EDIT: I am not sure if it's relevant, but I also don't use NetworkManager.

@urkle

This comment has been minimized.

Show comment Hide comment
@urkle

urkle Jan 13, 2013

Can you re-test with the latest update I just pushed.

urkle commented Jan 13, 2013

Can you re-test with the latest update I just pushed.

@EoD

This comment has been minimized.

Show comment Hide comment
@EoD

EoD Jan 13, 2013

The authentication seems to pass, I now get into the main menu. But I seem to be a DEMO user (it's too fast to be really sure) and it still crashes after a few milliseconds in the main menu:

Game update: AppID 1520 "DEFCON", ProcID 3152, IP 0.0.0.0:0
saving roaming config store to 'sharedconfig.vdf'
roaming config store 2 saved successfully
Setting breakpad minidump AppID = 1520
Steam_SetMinidumpSteamID:  Caching Steam ID:  76561198054163081 [API loaded no]
/data/Games/Steam_Linux/SteamApps/common/Defcon/run_steam.sh: line 10:  3153 Segmentation fault      ./defcon.bin.x86
Game removed: AppID 1520 "DEFCON", ProcID 3153 
saving roaming config store to 'sharedconfig.vdf'
roaming config store 2 saved successfully

EoD commented Jan 13, 2013

The authentication seems to pass, I now get into the main menu. But I seem to be a DEMO user (it's too fast to be really sure) and it still crashes after a few milliseconds in the main menu:

Game update: AppID 1520 "DEFCON", ProcID 3152, IP 0.0.0.0:0
saving roaming config store to 'sharedconfig.vdf'
roaming config store 2 saved successfully
Setting breakpad minidump AppID = 1520
Steam_SetMinidumpSteamID:  Caching Steam ID:  76561198054163081 [API loaded no]
/data/Games/Steam_Linux/SteamApps/common/Defcon/run_steam.sh: line 10:  3153 Segmentation fault      ./defcon.bin.x86
Game removed: AppID 1520 "DEFCON", ProcID 3153 
saving roaming config store to 'sharedconfig.vdf'
roaming config store 2 saved successfully
@urkle

This comment has been minimized.

Show comment Hide comment
@urkle

urkle Jan 13, 2013

you should see "STEAM AUTHENTICATION: SUCCESS" in the upper left corner. that means it successfully authenticated.. you can try deleting the authkey that is in the ~/Steam/SteamApps/common/Defcon/authkey and see if that resolves the issue.. I just pushed up one more update that fixes an issue where one couldn't join network games with other steam users. (and been playing right now )

urkle commented Jan 13, 2013

you should see "STEAM AUTHENTICATION: SUCCESS" in the upper left corner. that means it successfully authenticated.. you can try deleting the authkey that is in the ~/Steam/SteamApps/common/Defcon/authkey and see if that resolves the issue.. I just pushed up one more update that fixes an issue where one couldn't join network games with other steam users. (and been playing right now )

@EoD

This comment has been minimized.

Show comment Hide comment
@EoD

EoD Jan 14, 2013

After the recent update, we are back to the old behaviour. It crashes during authentication (never getting into the main menu). I tried deleting the authkey file, but it didn't change anything.

Game update: AppID 1520 "DEFCON", ProcID 3225, IP 0.0.0.0:0
saving roaming config store to 'sharedconfig.vdf'
roaming config store 2 saved successfully
Setting breakpad minidump AppID = 1520
Steam_SetMinidumpSteamID:  Caching Steam ID:  76561198054163081 [API loaded no]
/data/Games/Steam_Linux/SteamApps/common/Defcon/run_steam.sh: line 10:  3226 Segmentation fault      ./defcon.bin.x86
Game removed: AppID 1520 "DEFCON", ProcID 3226 
saving roaming config store to 'sharedconfig.vdf'
roaming config store 2 saved successfully

Any suggestions? Maybe some debug parameter, I should start defcon with?

EoD commented Jan 14, 2013

After the recent update, we are back to the old behaviour. It crashes during authentication (never getting into the main menu). I tried deleting the authkey file, but it didn't change anything.

Game update: AppID 1520 "DEFCON", ProcID 3225, IP 0.0.0.0:0
saving roaming config store to 'sharedconfig.vdf'
roaming config store 2 saved successfully
Setting breakpad minidump AppID = 1520
Steam_SetMinidumpSteamID:  Caching Steam ID:  76561198054163081 [API loaded no]
/data/Games/Steam_Linux/SteamApps/common/Defcon/run_steam.sh: line 10:  3226 Segmentation fault      ./defcon.bin.x86
Game removed: AppID 1520 "DEFCON", ProcID 3226 
saving roaming config store to 'sharedconfig.vdf'
roaming config store 2 saved successfully

Any suggestions? Maybe some debug parameter, I should start defcon with?

@urkle

This comment has been minimized.

Show comment Hide comment
@urkle

urkle Jan 14, 2013

What is the MD5 has of the defcon.bin.86? Also, can you simply try running it OUTSIDE of steam? (preferably in GDB if it still crashes so we can get a backtrace).

urkle commented Jan 14, 2013

What is the MD5 has of the defcon.bin.86? Also, can you simply try running it OUTSIDE of steam? (preferably in GDB if it still crashes so we can get a backtrace).

@EoD

This comment has been minimized.

Show comment Hide comment
@EoD

EoD Jan 14, 2013

$ md5sum defcon.bin.x86
98a4ed17279becc72cde5bc0b0b9b009  defcon.bin.x86

Launching it outside of Steam (or with gdb for that matter) doesn't reproduce the issue. When launched outside of Steam it just fails to authenticate with Steam and puts me into DEMO mode without crashing (same behaviour as in Steam 1.0.0.18, see above). It only fails if I launch it via the Steam interface.

I'm not experienced enough, but can't I just write some kind of gdb+defcon wrapper and add it to my Steam game library somehow in order to make the authentication work with gdb?

EoD commented Jan 14, 2013

$ md5sum defcon.bin.x86
98a4ed17279becc72cde5bc0b0b9b009  defcon.bin.x86

Launching it outside of Steam (or with gdb for that matter) doesn't reproduce the issue. When launched outside of Steam it just fails to authenticate with Steam and puts me into DEMO mode without crashing (same behaviour as in Steam 1.0.0.18, see above). It only fails if I launch it via the Steam interface.

I'm not experienced enough, but can't I just write some kind of gdb+defcon wrapper and add it to my Steam game library somehow in order to make the authentication work with gdb?

@ioga

This comment has been minimized.

Show comment Hide comment
@ioga

ioga Feb 3, 2013

I can confirm that issue.
Segmentation fault is reproduced only if the defcon is launched via steam; md5sum is the same.

ioga commented Feb 3, 2013

I can confirm that issue.
Segmentation fault is reproduced only if the defcon is launched via steam; md5sum is the same.

@Shished

This comment has been minimized.

Show comment Hide comment
@Shished

Shished Feb 7, 2013

Still crashes.

Shished commented Feb 7, 2013

Still crashes.

@drewofdoom

This comment has been minimized.

Show comment Hide comment
@drewofdoom

drewofdoom Feb 15, 2013

Issue is still persistent. Game launched from Steam crashes. Game launched from command-line successfully loads, but only Demo access is granted.

Issue is still persistent. Game launched from Steam crashes. Game launched from command-line successfully loads, but only Demo access is granted.

@hackerboy777

This comment has been minimized.

Show comment Hide comment
@hackerboy777

hackerboy777 Feb 18, 2013

Issue sill in effect.

Issue sill in effect.

@urkle

This comment has been minimized.

Show comment Hide comment
@urkle

urkle Feb 18, 2013

hmm.. can someone try running steam w/ the steam runtime disabled?? and see if the crash persists?

STEAM_RUNTIME=0 steam

(I myself am still unable to recreate any crash locally, which is rather infuriating as it makes it difficult to debug)

urkle commented Feb 18, 2013

hmm.. can someone try running steam w/ the steam runtime disabled?? and see if the crash persists?

STEAM_RUNTIME=0 steam

(I myself am still unable to recreate any crash locally, which is rather infuriating as it makes it difficult to debug)

@ioga

This comment has been minimized.

Show comment Hide comment
@ioga

ioga Feb 18, 2013

@urkle Crash persists.

ioga commented Feb 18, 2013

@urkle Crash persists.

@urkle

This comment has been minimized.

Show comment Hide comment
@urkle

urkle Feb 18, 2013

Do any of you have a authkey file in the Steam/SteamApps/common/Defcon folder? (and don't paste it here please).. if you do, it should start with STEAM. (and not DEMO) If not let me know.

Also, do you have an authkey file in ~/.defcon , if so does it start with STEAM or DEMO?

Also try removing all copies of authkey (backing them up, of course, so we can recreate)

I'm searching through the code to see why the exception handler isn't triggering like it should..

urkle commented Feb 18, 2013

Do any of you have a authkey file in the Steam/SteamApps/common/Defcon folder? (and don't paste it here please).. if you do, it should start with STEAM. (and not DEMO) If not let me know.

Also, do you have an authkey file in ~/.defcon , if so does it start with STEAM or DEMO?

Also try removing all copies of authkey (backing them up, of course, so we can recreate)

I'm searching through the code to see why the exception handler isn't triggering like it should..

@ioga

This comment has been minimized.

Show comment Hide comment
@ioga

ioga Feb 18, 2013

@urkle I had authkey in the Steam/SteamApps/common/Defcon, and it started with DEMO. I removed it (while steam was ON), but game still crashes. Restarted steam both with and without STEAM_RUNTIME, still crashes.

I don't have an authkey in ~/.defcon.

ioga commented Feb 18, 2013

@urkle I had authkey in the Steam/SteamApps/common/Defcon, and it started with DEMO. I removed it (while steam was ON), but game still crashes. Restarted steam both with and without STEAM_RUNTIME, still crashes.

I don't have an authkey in ~/.defcon.

@urkle

This comment has been minimized.

Show comment Hide comment
@urkle

urkle Feb 19, 2013

I pushed up a beta build with the crash handler fixed. Simply right click on Defcon and "opt-in" to the "beta" branch. Re-run and check the /tmp/blackbox.txt file.

urkle commented Feb 19, 2013

I pushed up a beta build with the crash handler fixed. Simply right click on Defcon and "opt-in" to the "beta" branch. Re-run and check the /tmp/blackbox.txt file.

@Pr0b

This comment has been minimized.

Show comment Hide comment
@Pr0b

Pr0b Feb 19, 2013

Ok, i tested it.

Here's content of /tmp/blackbox.txt

=========================
=   BLACK BOX REPORT    =
=========================

Defcon 1.62 STEAM built Feb 19 2013
Date 17:12, 19/2/2013


=========================
=      STACKTRACE       =
=========================

./defcon.bin.x86(_Z19AppGenerateBlackBoxPcS_+0x1e7)[0x81f6af7]
./defcon.bin.x86[0x80b4095]
linux-gate.so.1(__kernel_rt_sigreturn+0x0)[0xf7795410]
./defcon.bin.x86(_Z12GetLocalHostv+0x2e)[0x81d4a0e]
./defcon.bin.x86(_Z13GetSteam3Authv+0x1a)[0x81d0ada]
./defcon.bin.x86[0x81d0e65]
/usr/lib32/libpthread.so.0(+0x6d08)[0xf7509d08]
/usr/lib32/libc.so.6(clone+0x5e)[0xf72ebe0e]

I have also slightly different ouput in terminal after executing DEFCON via steam. i guess, you used handler from the game Darwinia?

Failed to load installscript /home/rob/.local/share/Steam/SteamApps/common/Defcon/installscript.vdf
Game update: AppID 1520 "DEFCON", ProcID 10186, IP 0.0.0.0:0
ERROR: ld.so: object 'gameoverlayrenderer.so' from LD_PRELOAD cannot be preloaded: ignored.
ERROR: ld.so: object 'gameoverlayrenderer.so' from LD_PRELOAD cannot be preloaded: ignored.
saving roaming config store to 'sharedconfig.vdf'
roaming config store 2 saved successfully
Setting breakpad minidump AppID = 1520
Steam_SetMinidumpSteamID:  Caching Steam ID:  76561197976233996 [API loaded no]
Installing breakpad exception handler for appid(gameoverlayui)/version(20130215122411_client)
Installing breakpad exception handler for appid(gameoverlayui)/version(1.0_client)
Installing breakpad exception handler for appid(gameoverlayui)/version(1.0_client)
Installing breakpad exception handler for appid(gameoverlayui)/version(1.0_client)
[0219/171446:ERROR:object_proxy.cc(239)] Failed to call method: org.freedesktop.systemd1.LoadFailed: Unit dbus-org.freedesktop.NetworkManager.service failed to load: No such file or directory. See system logs and 'systemctl status dbus-org.freedesktop.NetworkManager.service' for details.
[0219/171446:WARNING:proxy_service.cc(646)] PAC support disabled because there is no system implementation


Darwinia has unexpectedly encountered a fatal error.
A full description of the error can be found in the file
/tmp/blackbox.txt

[xcb] Unknown request in queue while dequeuing
[xcb] Most likely this is a multi-threaded client and XInitThreads has not been called
[xcb] Aborting, sorry about that.
defcon.bin.x86: ../../src/xcb_io.c:178: dequeue_pending_request: Assertion `!xcb_xlib_unknown_req_in_deq' failed.
/home/rob/.local/share/Steam/SteamApps/common/Defcon/run_steam.sh: line 10: 10187 Aborted                 (core dumped) ./defcon.bin.x86
Game removed: AppID 1520 "DEFCON", ProcID 10187 
saving roaming config store to 'sharedconfig.vdf'
roaming config store 2 saved successfully

Hope it helps

Pr0b commented Feb 19, 2013

Ok, i tested it.

Here's content of /tmp/blackbox.txt

=========================
=   BLACK BOX REPORT    =
=========================

Defcon 1.62 STEAM built Feb 19 2013
Date 17:12, 19/2/2013


=========================
=      STACKTRACE       =
=========================

./defcon.bin.x86(_Z19AppGenerateBlackBoxPcS_+0x1e7)[0x81f6af7]
./defcon.bin.x86[0x80b4095]
linux-gate.so.1(__kernel_rt_sigreturn+0x0)[0xf7795410]
./defcon.bin.x86(_Z12GetLocalHostv+0x2e)[0x81d4a0e]
./defcon.bin.x86(_Z13GetSteam3Authv+0x1a)[0x81d0ada]
./defcon.bin.x86[0x81d0e65]
/usr/lib32/libpthread.so.0(+0x6d08)[0xf7509d08]
/usr/lib32/libc.so.6(clone+0x5e)[0xf72ebe0e]

I have also slightly different ouput in terminal after executing DEFCON via steam. i guess, you used handler from the game Darwinia?

Failed to load installscript /home/rob/.local/share/Steam/SteamApps/common/Defcon/installscript.vdf
Game update: AppID 1520 "DEFCON", ProcID 10186, IP 0.0.0.0:0
ERROR: ld.so: object 'gameoverlayrenderer.so' from LD_PRELOAD cannot be preloaded: ignored.
ERROR: ld.so: object 'gameoverlayrenderer.so' from LD_PRELOAD cannot be preloaded: ignored.
saving roaming config store to 'sharedconfig.vdf'
roaming config store 2 saved successfully
Setting breakpad minidump AppID = 1520
Steam_SetMinidumpSteamID:  Caching Steam ID:  76561197976233996 [API loaded no]
Installing breakpad exception handler for appid(gameoverlayui)/version(20130215122411_client)
Installing breakpad exception handler for appid(gameoverlayui)/version(1.0_client)
Installing breakpad exception handler for appid(gameoverlayui)/version(1.0_client)
Installing breakpad exception handler for appid(gameoverlayui)/version(1.0_client)
[0219/171446:ERROR:object_proxy.cc(239)] Failed to call method: org.freedesktop.systemd1.LoadFailed: Unit dbus-org.freedesktop.NetworkManager.service failed to load: No such file or directory. See system logs and 'systemctl status dbus-org.freedesktop.NetworkManager.service' for details.
[0219/171446:WARNING:proxy_service.cc(646)] PAC support disabled because there is no system implementation


Darwinia has unexpectedly encountered a fatal error.
A full description of the error can be found in the file
/tmp/blackbox.txt

[xcb] Unknown request in queue while dequeuing
[xcb] Most likely this is a multi-threaded client and XInitThreads has not been called
[xcb] Aborting, sorry about that.
defcon.bin.x86: ../../src/xcb_io.c:178: dequeue_pending_request: Assertion `!xcb_xlib_unknown_req_in_deq' failed.
/home/rob/.local/share/Steam/SteamApps/common/Defcon/run_steam.sh: line 10: 10187 Aborted                 (core dumped) ./defcon.bin.x86
Game removed: AppID 1520 "DEFCON", ProcID 10187 
saving roaming config store to 'sharedconfig.vdf'
roaming config store 2 saved successfully

Hope it helps

@urkle

This comment has been minimized.

Show comment Hide comment
@urkle

urkle Feb 19, 2013

OK.. So, it looks like there is something funky with your hostname configuration on your system.

Can you type "hostname" on the CLI and see what it spits out. And then, also try the new build I pushed out.

urkle commented Feb 19, 2013

OK.. So, it looks like there is something funky with your hostname configuration on your system.

Can you type "hostname" on the CLI and see what it spits out. And then, also try the new build I pushed out.

@Pr0b

This comment has been minimized.

Show comment Hide comment
@Pr0b

Pr0b Feb 19, 2013

$ hostname
robdesktop

I just tried lastest build and i can cofirm that it works now :)
THX

EDIT: OK, at first look the steem authentication was successull, i got full game and authentication status is accepted.
But after few mins in the top left corner appers "steam authenttication failed"

Pr0b commented Feb 19, 2013

$ hostname
robdesktop

I just tried lastest build and i can cofirm that it works now :)
THX

EDIT: OK, at first look the steem authentication was successull, i got full game and authentication status is accepted.
But after few mins in the top left corner appers "steam authenttication failed"

@Shished

This comment has been minimized.

Show comment Hide comment
@Shished

Shished Feb 19, 2013

After entering beta game works normally.
UPD
Same error message as for robdesktop.

Shished commented Feb 19, 2013

After entering beta game works normally.
UPD
Same error message as for robdesktop.

@rcarmonas

This comment has been minimized.

Show comment Hide comment
@rcarmonas

rcarmonas Feb 19, 2013

same here

thx for ur support urkle

same here

thx for ur support urkle

@urkle

This comment has been minimized.

Show comment Hide comment
@urkle

urkle Feb 19, 2013

@Pr0b can you do a

host robdesktop

The bug I fixed was that the game fetched the hostname, and then tried to resolve the hostname (which failed). so honestly it looks like your local /etc/hosts files are rather broken as the hostname should resolve. (but yes, Defcon should not crash for broken setups, which it shouldn't now).

urkle commented Feb 19, 2013

@Pr0b can you do a

host robdesktop

The bug I fixed was that the game fetched the hostname, and then tried to resolve the hostname (which failed). so honestly it looks like your local /etc/hosts files are rather broken as the hostname should resolve. (but yes, Defcon should not crash for broken setups, which it shouldn't now).

@hackerboy777

This comment has been minimized.

Show comment Hide comment
@hackerboy777

hackerboy777 Feb 19, 2013

Beta patch worked like a charm. Thanks for a lot for the support urkle.

Beta patch worked like a charm. Thanks for a lot for the support urkle.

@Pr0b

This comment has been minimized.

Show comment Hide comment
@Pr0b

Pr0b Feb 20, 2013

@urkle Yeah, you're right.

$ dig robdesktop +noall +answer

; <<>> DiG 9.9.2-P1 <<>> robdesktop +noall +answer
;; global options: +cmd

I couldn't resolve my hostname. I bet majority of users expereincing this bug use Arch. Because of transition to systemd based system, lots of ppl, including me, during re-set forgot to tell systemd hostname :)

To correct it on system using this ugly systemd, use this

hostnamectl set-hostname myhostname

or just update /etc/host :-)

Pr0b commented Feb 20, 2013

@urkle Yeah, you're right.

$ dig robdesktop +noall +answer

; <<>> DiG 9.9.2-P1 <<>> robdesktop +noall +answer
;; global options: +cmd

I couldn't resolve my hostname. I bet majority of users expereincing this bug use Arch. Because of transition to systemd based system, lots of ppl, including me, during re-set forgot to tell systemd hostname :)

To correct it on system using this ugly systemd, use this

hostnamectl set-hostname myhostname

or just update /etc/host :-)

@urkle

This comment has been minimized.

Show comment Hide comment
@urkle

urkle Feb 20, 2013

Sweet! Then this issue can be resolved now!

urkle commented Feb 20, 2013

Sweet! Then this issue can be resolved now!

@rcarmonas

This comment has been minimized.

Show comment Hide comment
@rcarmonas

rcarmonas Feb 20, 2013

Great, i'm on Arch too and i forgot to set the hostname when migrating to systemd.
Now works great!
THX

Great, i'm on Arch too and i forgot to set the hostname when migrating to systemd.
Now works great!
THX

@EoD

This comment has been minimized.

Show comment Hide comment
@EoD

EoD Feb 21, 2013

I neither use ARCH nor systemd and my hostname was set, but I can confirm that it works now properly!

EoD commented Feb 21, 2013

I neither use ARCH nor systemd and my hostname was set, but I can confirm that it works now properly!

Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment