Skip to content

HTTPS clone URL

Subversion checkout URL

You can clone with HTTPS or Subversion.

Download ZIP

Loading…

Harvest: Massive Encounter won't run #71

Closed
tdenholm opened this Issue · 7 comments

7 participants

@tdenholm

When I try to start the game, a terminal window opens and it wants me to install missing dependencies. However, it doesn't seem to work. I'm running Ubuntu 12.10 64-bit. Here is the output:

ERROR: ld.so: object 'gameoverlayrenderer.so' from LD_PRELOAD cannot be preloaded: ignored.
WARNING:
This script is intended for Steam Linux Beta i386 and requires apt-get
if the script fails, please install the dependencies manually using
the available package manager.
Harvest:Massive Encounter requires some missing dependencies:
libstdc++6 libc6 libgcc1 libgtk2.0-0 libvorbisfile3 nvidia-cg-toolkit libjpeg62
Do you want to install them now? (Y/N):
y
ERROR: ld.so: object 'gameoverlayrenderer.so' from LD_PRELOAD cannot be preloaded: ignored.
[sudo] password for matachi:
Reading package lists... Done
Building dependency tree
Reading state information... Done
libc6 is already the newest version.
libgcc1 is already the newest version.
libgtk2.0-0 is already the newest version.
libjpeg62 is already the newest version.
libstdc++6 is already the newest version.
libvorbisfile3 is already the newest version.
nvidia-cg-toolkit is already the newest version.
The following packages were automatically installed and are no longer required:
gtk2-engines-pixbuf libgoocanvas-common libgoocanvas3 libmlt++3 libmlt-data libmlt5 libquicktime2 libserf1 libsox-fmt-alsa libsox-fmt-base libsox2
libsvn1 melt openshot-doc python-mlt5 python-pygoocanvas
Use 'apt-get autoremove' to remove them.
0 upgraded, 0 newly installed, 0 to remove and 0 not upgraded.
ERROR: ld.so: object 'gameoverlayrenderer.so' from LD_PRELOAD cannot be preloaded: ignored.
ERROR: ld.so: object 'gameoverlayrenderer.so' from LD_PRELOAD cannot be preloaded: ignored.
ERROR: ld.so: object 'gameoverlayrenderer.so' from LD_PRELOAD cannot be preloaded: ignored.
ERROR: ld.so: object 'gameoverlayrenderer.so' from LD_PRELOAD cannot be preloaded: ignored.
ERROR: ld.so: object 'gameoverlayrenderer.so' from LD_PRELOAD cannot be preloaded: ignored.
ERROR: ld.so: object 'gameoverlayrenderer.so' from LD_PRELOAD cannot be preloaded: ignored.
ERROR: ld.so: object 'gameoverlayrenderer.so' from LD_PRELOAD cannot be preloaded: ignored.
ERROR: ld.so: object 'gameoverlayrenderer.so' from LD_PRELOAD cannot be preloaded: ignored.
ERROR: ld.so: object 'gameoverlayrenderer.so' from LD_PRELOAD cannot be preloaded: ignored.
ERROR: ld.so: object 'gameoverlayrenderer.so' from LD_PRELOAD cannot be preloaded: ignored.
ERROR: ld.so: object 'gameoverlayrenderer.so' from LD_PRELOAD cannot be preloaded: ignored.
ERROR: ld.so: object 'gameoverlayrenderer.so' from LD_PRELOAD cannot be preloaded: ignored.
ERROR: ld.so: object 'gameoverlayrenderer.so' from LD_PRELOAD cannot be preloaded: ignored.
ERROR: ld.so: object 'gameoverlayrenderer.so' from LD_PRELOAD cannot be preloaded: ignored.
ERROR: ld.so: object 'gameoverlayrenderer.so' from LD_PRELOAD cannot be preloaded: ignored.
ERROR: ld.so: object 'gameoverlayrenderer.so' from LD_PRELOAD cannot be preloaded: ignored.
ERROR: ld.so: object 'gameoverlayrenderer.so' from LD_PRELOAD cannot be preloaded: ignored.
ERROR: ld.so: object 'gameoverlayrenderer.so' from LD_PRELOAD cannot be preloaded: ignored.
ERROR: ld.so: object 'gameoverlayrenderer.so' from LD_PRELOAD cannot be preloaded: ignored.
ERROR: ld.so: object 'gameoverlayrenderer.so' from LD_PRELOAD cannot be preloaded: ignored.
ii nvidia-cg-toolkit 3.1.0013-1 amd64 Cg Toolkit - GPU Shader Authoring Language
ERROR: ld.so: object 'gameoverlayrenderer.so' from LD_PRELOAD cannot be preloaded: ignored.
ERROR: ld.so: object 'gameoverlayrenderer.so' from LD_PRELOAD cannot be preloaded: ignored.
ERROR: ld.so: object 'gameoverlayrenderer.so' from LD_PRELOAD cannot be preloaded: ignored.
ERROR: ld.so: object 'gameoverlayrenderer.so' from LD_PRELOAD cannot be preloaded: ignored.
ERROR: ld.so: object 'gameoverlayrenderer.so' from LD_PRELOAD cannot be preloaded: ignored.

@gdrewb-valve gdrewb-valve was assigned
@johnv-valve johnv-valve was assigned
@Fornax96

I have this too, when I type my password and press enter it just opens a new window asking to download dependencies.

@johnv-valve
Owner

Did you try installing the 32-bit versions of those libraries?

sudo apt-get install libstdc++6:i386 libc6:i386 libgcc1:i386 libgtk2.0-0:i386 libvorbisfile3:i386 nvidia-cg-toolkit:i386 libjpeg62:i386
@Fornax96

Your command didn't change anything. :(

@filesunknownxx

I am experiencing the same issue. after it downloads the dependencies it doesn't start the game.
I am running 64 bit 12.04 Ubuntu
System info: https://gist.github.com/4412979

After installing your 32 bit version of the dependancies and editing the "run harvest" file, as in the link below, It started to work.
https://wiki.archlinux.org/index.php/Steam#Harvest:_Massive_Encounter

@brunojcm

Same problem here...

@sorokin

I have the same problem too.

@gdrewb-valve

This bug was closed because the issue concerns the game and not the Steam client. Please contact the game developer on their official website with this information.

Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment
Something went wrong with that request. Please try again.