Arch Linux x86_64 with KDE: Segmentation fault crash on start. #878

Closed
TorinCooperBennun opened this Issue Jan 25, 2013 · 12 comments

Projects

None yet

6 participants

@TorinCooperBennun

When I run steam, I get this output:

[user@hostname ~]$ steam
Installing breakpad exception handler for appid(steam)/version(1359141904_client)
Looks like steam didn't shutdown cleanly, scheduling immediate update check
Installing breakpad exception handler for appid(steam)/version(1359141904_client)
Installing breakpad exception handler for appid(steam)/version(1359141904_client)
unlinked 0 orphaned pipes
removing stale semaphore last operated on by process 2524 with name 0eBlobRegistryMutex_518C8B9374CCABD22300A6C3C13FA64C
removing stale semaphore last operated on by process 2524 with name 0eBlobRegistrySignal_518C8B9374CCABD22300A6C3C13FA64C
removing stale semaphore last operated on by process 2524 with name 0emSteamEngineInstance
removing stale semaphore last operated on by process 2524 with name 0eSteamEngineLock
Installing breakpad exception handler for appid(steam)/version(1359141904_client)
[0125/234914:ERROR:object_proxy.cc(239)] Failed to call method: org.freedesktop.DBus.Error.ServiceUnknown: The name org.freedesktop.NetworkManager was not provided by any .service files
[0125/234914:WARNING:proxy_service.cc(646)] PAC support disabled because there is no system implementation
/home/user/.local/share/Steam/steam.sh: line 343:  2648 Segmentation fault      (core dumped) $STEAM_DEBUGGER "$STEAMROOT/$PLATFORM/$STEAMEXE" "$@"

As superuser, I get this:

[user@hostname ~]$ sudo steam
[sudo] password for user: 
Installing breakpad exception handler for appid(steam)/version(1359141904_client)
No protocol specified
main.cpp (369) : Assertion Failed: failed to intiialize update status ui, or create initial window
Assert( Assertion Failed: failed to intiialize update status ui, or create initial window ):/home/buildbot/buildslave_steam/steam_rel_client_ubuntu12_linux/build/src/steamexe/./main.cpp:369

Installing breakpad exception handler for appid(steam)/version(1359141904_client)
Uploading dump (in-process) [proxy '']
/tmp/dumps/assert_20130125235016_1.dmp
success = yes
response:  CrashID=bp-47b11d17-de6c-4e9c-add3-b3f892130125
Installing bootstrap /home/user/.local/share/Steam/bootstrap.tar.xz
Installing breakpad exception handler for appid(steam)/version(1359141904_client)
No protocol specified
main.cpp (367) : Assertion Failed: failed to intiialize update status ui, or create initial window
Assert( Assertion Failed: failed to intiialize update status ui, or create initial window ):/data/steamlinux/src/steamexe/./main.cpp:367

Installing breakpad exception handler for appid(steam)/version(1359141904_client)
Uploading dump (in-process) [proxy '']
/tmp/dumps/assert_20130125235018_1.dmp
success = yes
response:  CrashID=bp-c0e33eeb-2701-41dc-96fc-656be2130125
@davidw-valve davidw-valve was assigned Jan 26, 2013
@davidw-valve
Contributor

This problem might be a problem loading libraries -- can you run with LD_DEBUG=libs and tell me the output?

@TorinCooperBennun

Okay, well the output is huge, but here's the last few lines (and they seem important):

EDIT: I've added more lines to this, there are more undefined symbol errors I missed:

EDIT 2: Okay, I redirected stderr instead. Here's the full output: http://pastebin.com/nghew8Hv

@haarp
haarp commented Jan 27, 2013

Same problem here. Problem appeared a while ago, Steam was running fine before that.
Gentoo Linux, AMD64, Intel GM45 graphics, SNA

Seems to be a bunch of undefined symbols in the 32bit emul libs: http://pastebin.com/P8JMSJba

@davidw-valve
Contributor

The latest release should have a little more diagnostic output. Can you please try running with the latest release and tell me what you get? Please post the full output (no need for using LD_DEBUG).

@haarp
haarp commented Jan 30, 2013

Is this release live yet? I didn't get an update.

@Vash63
Vash63 commented Jan 31, 2013

Same issue for me. Also on Arch x64. Was working fine yesterday, today's or last night's update broke it. On nvidia.

$ steam
/home/vash/.local/share/Steam/steam.sh: line 376: 3272 Segmentation fault (core dumped) $STEAM_DEBUGGER "$STEAMROOT/$PLATFORM/$STEAMEXE" "$@"
Installing bootstrap /home/vash/.local/share/Steam/bootstrap.tar.xz
/home/vash/.local/share/Steam/steam.sh: line 169: 3276 Segmentation fault (core dumped) tar xf "$STEAMBOOTSTRAPARCHIVE"

@Vash63
Vash63 commented Jan 31, 2013

Moving ~/.local/share/Steam fixed it. I kept the original though if it helps for debugging. Something went wrong with the update I guess.

@haarp
haarp commented Feb 7, 2013

Several updates later, it's still segfaulting for me :(

Running Steam on Linux 3.6.11-gentoo 64-bit STEAM_RUNTIME is enabled automatically Installing breakpad exception handler for appid(steam)/version(1360108773_client) Looks like steam didn't shutdown cleanly, scheduling immediate update check Installing breakpad exception handler for appid(steam)/version(1360108773_client) Installing breakpad exception handler for appid(steam)/version(1360108773_client) unlinked 1 orphaned pipes removing stale semaphore last operated on by process 6777 with name 0eBlobRegistryMutex_17AFF11CD4F533038D57637BCC498098 removing stale semaphore last operated on by process 6777 with name 0eBlobRegistrySignal_17AFF11CD4F533038D57637BCC498098 removing stale semaphore last operated on by process 6777 with name 0emSteamEngineInstance removing stale semaphore last operated on by process 6777 with name 0eSteamEngineLock Installing breakpad exception handler for appid(steam)/version(1360108773_client) Uploading dump (in-process) [proxy ''] /tmp/dumps/crash_20130207102418_1.dmp [0207/102418:WARNING:proxy_service.cc(646)] PAC support disabled because there is no system implementation success = yes response: CrashID=bp-dda9a940-b064-4381-a0a1-19baa2130207 /home/haarp/.steam/steam.sh: line 474: 30270 Segmentation fault $STEAM_DEBUGGER "$STEAMROOT/$PLATFORM/$STEAMEXE" "$@"

@haarp
haarp commented Feb 8, 2013

Today's update fixed it for me. Thanks, Valve!

@gdrewb-valve
Contributor

Is this still active?

@TorinCooperBennun

No, I'm having no such problems now. I've changed a lot of hardware and software since then anyway...

@Stark2x
Stark2x commented Dec 29, 2013

I'm having issues with segfaults on Arch x64 again. Also did a clean install and removed the ~/.local/share/Steam directory. Nothing helped so far.

Full output with LD_DEBUG=libs: http://pastebin.com/VHmWPdRJ

Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment