Skip to content
Permalink
master
Switch branches/tags
Go to file
 
 
Cannot retrieve contributors at this time

[VS-2018-024] SaferVPN for Windows Privilege Escalation Vulnerability

CVE ID

CVE-2018-10647

CVSS Score

Pending

Vendor

Safer Social Ltd

Product

SaferVPN

Product Version

4.2.5

Vulnerability Details

SaferVPN for Windows suffers from a SYSTEM privilege escalation vulnerability in its SaferVPN.Service service. The SaferVPN.Service service executes openvpn.exe using OpenVPN config files located within the current user's local application data directory i.e. \AppData\Local\SaferVPN\OvpnConfig\. An authenticated attacker may modify these configuration files to specify a dynamic library plugin that should run for every new VPN connection attempt. This plugin will execute code in the context of the SYSTEM user.

Vendor Response

A release is scheduled.

Disclosure Timeline

  • 04-09-2018 - Vendor disclosure via email
  • 04-09-2018 - Vendor notified via Facebook
  • 04-10-2018 - Vendor response via email: Reviewing
  • 04-18-2018 - Vendor followup
  • 04-20-2018 - Vendor response: A release is scheduled that resolves this issue
  • 05-01-2018 - Vendor notified of the advisory release

Credit

Fabius Watson of VerSprite Security (@FabiusArtrel)