New issue

Have a question about this project? Sign up for a free GitHub account to open an issue and contact its maintainers and the community.

By clicking “Sign up for GitHub”, you agree to our terms of service and privacy statement. We’ll occasionally send you account related emails.

Already on GitHub? Sign in to your account

Transition end events don't fire with speed: 0 #64

Closed
sirtawast opened this Issue Feb 20, 2015 · 1 comment

Comments

Projects
None yet
2 participants
@sirtawast

sirtawast commented Feb 20, 2015

Hello!

Thanks for the great work with Shuffle.

Unfortunately I'm having hard times disabling the animation on V3. When speed is set to 0 it seems that Shuffle won't work more than once.

The reason I want to disable animations is to boost mobile performance.

Here's a jsFiddle pinpointing the problem.

@Vestride

This comment has been minimized.

Show comment
Hide comment
@Vestride

Vestride Mar 1, 2015

Owner

It's breaks because the transitionend event never triggers. You can work around this by using the supported option and setting it to false, which will use jQuery's .animate() method.

Owner

Vestride commented Mar 1, 2015

It's breaks because the transitionend event never triggers. You can work around this by using the supported option and setting it to false, which will use jQuery's .animate() method.

@Vestride Vestride changed the title from Shuffle not working with speed: 0 to Transition end events don't fire with `speed: 0` Mar 1, 2015

@Vestride Vestride changed the title from Transition end events don't fire with `speed: 0` to Transition end events don't fire with speed: 0 Mar 1, 2015

@Vestride Vestride closed this in 86c8d2e Mar 14, 2015

Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment