Skip to content
Allows the connection of newer clients to older server versions for Minecraft servers.
Java
Branch: master
Clone or download
Latest commit 8d16ebf Jan 15, 2020
Permalink
Type Name Latest commit message Commit time
Failed to load latest commit information.
.github/ISSUE_TEMPLATE Minor bug report typo Oct 28, 2018
bukkit Update authors Jan 14, 2020
bungee Update authors Jan 14, 2020
common Fix 1.11 evocation id Jan 15, 2020
jar Back to snapshot Dec 20, 2019
sponge-legacy Back to snapshot Dec 20, 2019
sponge *sobs* Jan 14, 2020
velocity Update authors Jan 14, 2020
.gitignore Prepare for 1.0.0 Nov 13, 2016
.travis.yml oraclejdk8 doesn't work anymore Jul 20, 2019
LICENSE Update License to 2019 Jan 31, 2019
README.md Update readme Dec 17, 2019
circle.yml Tidy up code to make it consistent Oct 27, 2018
pom.xml Back to snapshot Dec 20, 2019

README.md

ViaVersion 2.2.2 - Spigot, Sponge, BungeeCord, Velocity

Build Status Discord

Allows the connection of higher client versions to lower server versions

Supported Versions:

Table (https://i.imgur.com/yDtAgF7.png)

On Bukkit you may also use ProtocolSupport, but ensure you have the right build for your server version.

User Docs: https://docs.viaversion.com/display/VIAVERSION/

Sources:

wiki.vg (Used for various information, we also contribute back)

Burger (See PAaaS)

OpenNBT (used for slot rewriting)

Releases / Dev Builds:

You can find official releases here:

https://www.spigotmc.org/resources/viaversion.19254/history


You can find official dev builds here:

Jenkins: https://ci.viaversion.com

JavaDocs: https://jd.viaversion.com

Maven Repo: https://repo.viaversion.com

License:

MIT License, see LICENSE for more details.

Special thanks to all our Contributors

You can’t perform that action at this time.