Skip to content

Desktop Install

Oliver Kennedy edited this page Aug 5, 2019 · 17 revisions

Install Prerequisites

Docker

See instructions here

Ubuntu

$> sudo apt install python2.7 python-pip openjdk-8-jre
$> pip2 install setuptools wheel

macOS

You will need to download and install Java JDK-8 (v9 or higher will not work with Spark)

With Homebrew
$> brew install python@2 
$> pip2 install setuptools wheel
With MacPorts
$> sudo port install py27-pip
$> pip2 install setuptools wheel

Windows 10

Enable Windows Subsystem for Linux

Install bash

$> sudo apt install python2.7 openjdk-8-jre-headless
$> ln -s /usr/bin/python2.7 /usr/local/bin/python
$> curl https://bootstrap.pypa.io/get-pip.py -o get-pip.py
$> python get-pip.py

Install Vizier

$> pip2 install --user vizier-webapi

You may need to add your user bin directory (typically ~/.local/bin) to your PATH environment variable

Run

$> vizier

FAQ

How do I uninstall Vizier?

$> pip2 uninstall vizier-webapi
$> rm -r ~/.cache/coursier

Why don't you support Java 11?

Spark, which we use for most data processing, does not currently support Java JRE 9 or later. We plan to add support for Java 11 as soon as Spark does.

Why don't you support Python 3?

We're working on it.

I get a bunch of goop saying "java.lang.IllegalArgumentException"

Spark does not support Java JRE 9 or later. You need Java JRE 8 installed (note that you can have multiple JREs installed at the same time). You can download Java JRE 8 from here.

You can’t perform that action at this time.