Have a question about this project? Sign up for a free GitHub account to open an issue and contact its maintainers and the community.

Already on GitHub? Sign in to your account

Is IE8 supported? #44

Open
sidkshatriya opened this Issue Sep 4, 2012 · 13 comments

Comments

Projects
None yet
2 participants

Do you support IE8 in this library?

Member

xavijam commented Sep 4, 2012

Yes, we do. Have you found any issue?

Cheers!

I have a layer that has some transparency. The transparency is shown properly in IE9/Chrome etc. but not in IE8

Member

xavijam commented Sep 4, 2012

Have you tried this example? http://vizzuality.github.com/cartodb-gmapsv3/examples/custom-infowindow.html

I can set the opacity correctly in IE8.

Which library version are you using?

I'm using version 0.46

Yes, the example link you gave me works. I'm specifying the following for a particular layer via carto css:

#my_table_name {
polygon-fill:#FF6600;
line-color:grey;
polygon-opacity:0.01;
line-width:0;
line-opacity:0;
}

I add that layer using new CartoDBLayer({ ... }). It works in IE9/Chrome etc (but not in IE8)

Member

xavijam commented Sep 4, 2012

I've use your carto css code in this example and works in all browsers, IE7 and IE8 included, see the source code:

http://vizzuality.github.com/cartodb-gmapsv3/examples/custom-infowindow.html

Member

xavijam commented Sep 4, 2012

Any luck?

Thanks for asking. No luck!

When I specify opacity for a layer by saying:

new CartoDBLayer({ opacity: 0.50 .... }) the layer is shown with the correct opacity.

However, if I specify opacity 0.50 via carto css on cartodb.com the layer is shown with opacity of 1. Somehow IE8 does not take the pre-set opacity of the PNG tiles into account.

Please note that the example you provided (http://vizzuality.github.com/cartodb-gmapsv3/examples/custom-infowindow.html) has opacity set in the CartoDBLayer constructor.

Member

xavijam commented Sep 5, 2012

Ok, so the problem is when changes the opacity in the CartoCSS, isn't it? In execution time? Or at the beginning as well?

On Wednesday 5 de September de 2012 at 08:55, Sidharth Kshatriya wrote:

Please note that the example you provided (http://vizzuality.github.com/cartodb-gmapsv3/examples/custom-infowindow.html) has opacity set in the CartoDBLayer constructor.


Reply to this email directly or view it on GitHub (#44 (comment)).

The problem occurs whenever any layer has transparency specified via CartoCSS e.g. polygon-opacity: 0.4

Basically PNG tiles which already have some alpha in them seem to cause problems

Member

xavijam commented Sep 5, 2012

I've tried changing the carto-css in the polygons and works ok (IE7-8-9 and rest), at least for me (last version of the library), see screenshots attached:

https://dl.dropbox.com/u/931536/cartodb/Screen%20shot%202012-09-05%20at%207.29.29%20PM.png
https://dl.dropbox.com/u/931536/cartodb/Screen%20shot%202012-09-05%20at%207.29.52%20PM.png

Also, change the opacity of the layer is not the same as change the carto-css. So, if you have the layer opacity set to 0.5, and then your tile_style has the polygon-opacity set to 0.5, both are complementary.

Appreciate you spending time on this. Add another layer on top of this
(preferably a tilejson with wax ) and try this again please.

On Wed, Sep 5, 2012 at 11:05 PM, Javier Álvarez Medina <
notifications@github.com> wrote:

I've tried changing the carto-css in the polygons and works ok (IE7-8-9
and rest), at least for me (last version of the library), see screenshots
attached:

https://dl.dropbox.com/u/931536/cartodb/Screen%20shot%202012-09-05%20at%207.29.29%20PM.png

https://dl.dropbox.com/u/931536/cartodb/Screen%20shot%202012-09-05%20at%207.29.52%20PM.png

Also, change the opacity of the layer is not the same as change the
carto-css. So, if you have the layer opacity set to 0.5, and then your
tile_style has the polygon-opacity set to 0.5, both are complementary.


Reply to this email directly or view it on GitHubhttps://github.com/Vizzuality/cartodb-gmapsv3/issues/44#issuecomment-8306993.

Sidharth Kshatriya
www.sidk.info

Member

xavijam commented Sep 11, 2012

Hi Sidharth!

I've added a wax layer + 2 cartodb layers, and then I have edited one of the cartodb layer and seems like it is working properly. The example is here:

http://vizzuality.github.com/cartodb-gmapsv3/examples/custom-infowindow.html

Is it the scenario I should replicate? Could you try it?

Also a screenshot working in IE8:

IE8 + WAX + CartoDB Leaflet

Cheers!

Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment