Skip to content


Subversion checkout URL

You can clone with
Download ZIP


successful install under Lion with Ruby 1.9.3 #141

kbigler opened this Issue · 3 comments

2 participants


My soon-to-be new server is a MacMini with MacOSX Lion preinstalled. There is a compatibility issue: the default Xcode gcc install being LLVM-based is incompatible with the requirements for Ruby 1.9.2. Available info indicates 1.9.3 or newer is required.

Having looked at several other possibilities (downgrading XCode, hand-installing gcc) with no quick success I decided the straightforward route was most likely to go to Ruby 1.9.3, and that appears to have proven true. I had no issues whatsoever after making that switch, or at least not with the wiki server as I am able to observe it through my exploratory use. I have a little server running here ( but not 24/7, only 1pm to 1am pacific time due to house limitations here, as long as the server is on my desk rather than colo'd. Since I know neither github nor ruby I'd say that all went rather remarkably well, although the documentation seemed like mere hints at times.

However I figured that especially since I was treading on new ground it would be good to run the test suite. (That's really cool, running Firefox programmatically. I couldn't imagine what the documentation was talking about until I tried it.) The results are positive. Here is the evidence:

server:sinatra kurt$ bundle exec rake spec
/Users/kurt/.rvm/gems/ruby-1.9.3-p125/gems/rake-0.8.7/lib/rake/alt_system.rb:32: Use RbConfig instead of obsolete and deprecated Config.
(in /Users/kurt/Smallest-Federated-Wiki)
/Users/kurt/.rvm/rubies/ruby-1.9.3-p125/bin/ruby -S bundle exec rspec ./spec/favicon_spec.rb ./spec/integration_spec.rb ./spec/page_spec.rb ./spec/server_spec.rb

Finished in 23.57 seconds
51 examples, 0 failures
server:sinatra kurt$

I'm not worrying about Config vs RbConfig but feel free to advise if you like.


We've been developing on ruby 1.9.2 and have the expectation that bundler can assemble a workable complement of gems in that environment. I run sinatra on older macs using ruby 1.8.5 because I can't get 1.9.2 to compile with the older versions of osx. I have to admit that I'm new to bundler with this project and may not use it to best advantage.


I have used neither bundler nor ruby before, and am newbie here to perhaps an unusual extent. There is so much I can't speak to that I may have little idea of the implications of what I suggest. So I have to qualify what I say here as merely my best guess (as far as knowing all the implications for your project) and then go ahead and say it.

I submitted the issue thinking you might be collecting evidence that would permit the ruby version number to be moved forward. Such movement forward may be motivated by the fact that without moving to 1.9.3 using OSX Lion will be problematic in many cases. It may be workable but may require having multiple parallel versions of gcc in a way that at the very least requires a lot of side-stepping learning curve for the less-sophisticated server maintainer (me). If the server is to be dedicated to this project then the ruby-1.9.2-compatible gcc could be installed and there'd be no issues, but that was not my situation and is likely not to be the typical situation especially since new Macs ship with Lion.

Since I moved to 1.9.3 with no hitch it might suggest 1.9.3 might be just as inter-developable (term?) with 1.8.5 as was 1.9.2.

What I know nothing about is whether 1.9.3 has any problems with OS's that would run 1.9.2. I could try 1.9.3 on my Snow Leopard desktop machine if you like.


You're experience is valuable. Thanks.

Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment
Something went wrong with that request. Please try again.