Skip to content
Permalink
Browse files
2010-03-19 Laszlo Gombos <laszlo.1.gombos@nokia.com>
        Reviewed by Simon Hausmann.

        [Qt] Disable TILED_BACKING_STORE if Qt version is earlier than Qt4.6
        https://bugs.webkit.org/show_bug.cgi?id=36348

        Backing store implementation for QtWebKit requires at least Qt
        version 4.6.

        No new tests as there is no new functionality.

        * WebCore.pri:

Canonical link: https://commits.webkit.org/47537@main
git-svn-id: https://svn.webkit.org/repository/webkit/trunk@56243 268f45cc-cd09-0410-ab3c-d52691b4dbfc
  • Loading branch information
eseidel committed Mar 19, 2010
1 parent 923f2ba commit 9f2948d0ed567ddda4365eb93194e6aa17596eda
Showing with 17 additions and 1 deletion.
  1. +14 −0 WebCore/ChangeLog
  2. +3 −1 WebCore/WebCore.pri
@@ -1,3 +1,17 @@
2010-03-19 Laszlo Gombos <laszlo.1.gombos@nokia.com>

Reviewed by Simon Hausmann.

[Qt] Disable TILED_BACKING_STORE if Qt version is earlier than Qt4.6
https://bugs.webkit.org/show_bug.cgi?id=36348

Backing store implementation for QtWebKit requires at least Qt
version 4.6.

No new tests as there is no new functionality.

* WebCore.pri:

2010-03-19 Joseph Pecoraro <joepeck@webkit.org>

Reviewed by David Kilzer.
@@ -80,7 +80,9 @@ greaterThan(QT_MINOR_VERSION, 5) {
!contains(DEFINES, ENABLE_DATALIST=.): DEFINES += ENABLE_DATALIST=1

# Tiled Backing Store support
!contains(DEFINES, ENABLE_TILED_BACKING_STORE=.): DEFINES += ENABLE_TILED_BACKING_STORE=1
greaterThan(QT_MINOR_VERSION, 5) {
!contains(DEFINES, ENABLE_TILED_BACKING_STORE=.): DEFINES += ENABLE_TILED_BACKING_STORE=1
}

# Nescape plugins support (NPAPI)
!contains(DEFINES, ENABLE_NETSCAPE_PLUGIN_API=.) {

0 comments on commit 9f2948d

Please sign in to comment.