Skip to content
Permalink
Browse files
Make the override-feature-defines script compatible with Python v3
https://bugs.webkit.org/show_bug.cgi?id=105742

Reviewed by Martin Robinson.

Instead of printing output through a statement, use the print function and format
the output using the str.format method. This makes the script runnable with Python v3.

* gtk/override-feature-defines:
(adjust_feature_defines_makefile):


Canonical link: https://commits.webkit.org/124521@main
git-svn-id: https://svn.webkit.org/repository/webkit/trunk@139065 268f45cc-cd09-0410-ab3c-d52691b4dbfc
  • Loading branch information
zdobersek committed Jan 8, 2013
1 parent ef3e9bc commit c824a96e85a55613ff350b90333d4f8e4dd31a2c
Showing 2 changed files with 14 additions and 1 deletion.
@@ -1,3 +1,16 @@
2013-01-08 Zan Dobersek <zandobersek@gmail.com>

Make the override-feature-defines script compatible with Python v3
https://bugs.webkit.org/show_bug.cgi?id=105742

Reviewed by Martin Robinson.

Instead of printing output through a statement, use the print function and format
the output using the str.format method. This makes the script runnable with Python v3.

* gtk/override-feature-defines:
(adjust_feature_defines_makefile):

2013-01-08 Heikki Paajanen <heikki.paajanen@palm.com>

[Qt] Fix libxml2 config test
@@ -30,7 +30,7 @@ def adjust_feature_defines_makefile(build_dir, feature_defines_overriding):
f.write(feature_defines_makefile)

if overriden_feature_defines:
print "The following feature defines were overriden:\n%s" % ', '.join(overriden_feature_defines)
print("The following feature defines were overriden:\n{0}".format(', '.join(overriden_feature_defines)))

def override_feature_defines(build_dir):
copy_feature_defines_makefile()

0 comments on commit c824a96

Please sign in to comment.