Permalink
Browse files

Fix Facebook submodule, build paths, and README instructions

Looks like Facebook rolled out a new version of their SDK since this
app was built, so the submodule needs to point to the old version
(v1.last) to work.
  • Loading branch information...
1 parent 2172493 commit 5e167896b1cfc352073685f9276b1b0742bd452f @jcromartie jcromartie committed Sep 7, 2012
Showing with 7 additions and 1 deletion.
  1. +4 −0 README.md
  2. +2 −0 WhiteHouseApp.xcodeproj/project.pbxproj
  3. +1 −1 libs/facebook
View
@@ -57,6 +57,10 @@ To intialize submodules, run:
git submodule update --init
+To build Facebook, `cd` into `libs/facebook` and run
+`./scripts/build_facebook_ios_sdk_static_lib.sh`. This will build the
+static library used by the app.
+
### Binary Libraries
The following libraries must be downloaded and installed manually:
@@ -1591,6 +1591,7 @@
HEADER_SEARCH_PATHS = (
"\"${SDK_DIR}/usr/include/libxml2\"",
"\"$(SRCROOT)/libs/Airship\"",
+ "\"$(SRCROOT)/libs/facebook/lib/facebook-ios-sdk\"",
);
INFOPLIST_FILE = "WhiteHouseApp/WhiteHouseApp-Info.plist";
LIBRARY_SEARCH_PATHS = (
@@ -1617,6 +1618,7 @@
HEADER_SEARCH_PATHS = (
"\"${SDK_DIR}/usr/include/libxml2\"",
"\"$(SRCROOT)/libs/Airship\"",
+ "\"$(SRCROOT)/libs/facebook/lib/facebook-ios-sdk\"",
);
INFOPLIST_FILE = "WhiteHouseApp/WhiteHouseApp-Info.plist";
LIBRARY_SEARCH_PATHS = (
Submodule facebook updated 381 files

0 comments on commit 5e16789

Please sign in to comment.