Skip to content
New issue

Have a question about this project? Sign up for a free GitHub account to open an issue and contact its maintainers and the community.

By clicking “Sign up for GitHub”, you agree to our terms of service and privacy statement. We’ll occasionally send you account related emails.

Already on GitHub? Sign in to your account

Cannot install software with dnf after dnf update #46

Open
LuoZhongYao opened this issue Sep 9, 2019 · 29 comments
Open

Cannot install software with dnf after dnf update #46

LuoZhongYao opened this issue Sep 9, 2019 · 29 comments
Labels
bug

Comments

@LuoZhongYao
Copy link

@LuoZhongYao LuoZhongYao commented Sep 9, 2019

sudo dnf update -y
sudo dnf install bat fd-find
[sudo] password for wms: 
whitewaterfoundry_wslu                          183  B/s | 833  B     00:04    
Dependencies resolved.
================================================================================
 Package      Arch   Version                              Repository       Size
================================================================================
Installing:
 bat          x86_64 0.11.0-3.module_f30+5045+5668d494    updates-modular 1.6 M
 fd-find      x86_64 7.3.0-3.module_f30+5180+e6d08112     updates-modular 780 k
Installing dependencies:
 http-parser  x86_64 2.9.2-1.fc30                         updates          36 k
 libgit2_0.28 x86_64 0.28.2-1.fc30                        updates         424 k
 libssh2      x86_64 1.9.0-1.fc30                         updates         112 k
Enabling module streams:
 bat                 latest                                                    
 fd-find             rolling                                                   

Transaction Summary
================================================================================
Install  5 Packages

Total download size: 2.9 M
Installed size: 7.8 M
Is this ok [y/N]: y
Downloading Packages:
(1/5): http-parser-2.9.2-1.fc30.x86_64.rpm      139 kB/s |  36 kB     00:00    
(2/5): fd-find-7.3.0-3.module_f30+5180+e6d08112 1.6 MB/s | 780 kB     00:00    
(3/5): bat-0.11.0-3.module_f30+5045+5668d494.x8 2.6 MB/s | 1.6 MB     00:00    
(4/5): libgit2_0.28-0.28.2-1.fc30.x86_64.rpm    1.0 MB/s | 424 kB     00:00    
(5/5): libssh2-1.9.0-1.fc30.x86_64.rpm          323 kB/s | 112 kB     00:00    
--------------------------------------------------------------------------------
Total                                           902 kB/s | 2.9 MB     00:03     
Running transaction check
Transaction check succeeded.
Running transaction test
Transaction test succeeded.
Running transaction
RPM: error: db5 error(-30969) from dbenv->open: BDB0091 DB_VERSION_MISMATCH: Database environment version mismatch
RPM: error: cannot open Packages index using db5 -  (-30969)
RPM: error: cannot open Packages database in /var/lib/rpm
The downloaded packages were saved in cache until the next successful transaction.
You can remove cached packages by executing 'dnf clean packages'.
Error: Could not run transaction.
@unrealps

This comment has been minimized.

Copy link

@unrealps unrealps commented Sep 9, 2019

I had the same problem. Running rm -f /var/lib/rpm/__db* and then dnf update, solved this.

@sirredbeard

This comment has been minimized.

Copy link
Member

@sirredbeard sirredbeard commented Sep 9, 2019

Is this occurring on a fresh install?

@LuoZhongYao

This comment has been minimized.

Copy link
Author

@LuoZhongYao LuoZhongYao commented Sep 10, 2019

Is this occurring on a fresh install?

yes.

@LuoZhongYao

This comment has been minimized.

Copy link
Author

@LuoZhongYao LuoZhongYao commented Sep 10, 2019

I had the same problem. Running rm -f /var/lib/rpm/__db* and then yum update, solved this.

This method did not solve the problem

[lzy@DESKTOP-GLN7DSM ~]$ sudo rm -f /var/lib/rpm/__db*
[sudo] password for lzy:
[lzy@DESKTOP-GLN7DSM ~]$ sudo yum update
Segmentation fault (core dumped)
[lzy@DESKTOP-GLN7DSM ~]$
@tmarton

This comment has been minimized.

Copy link

@tmarton tmarton commented Sep 10, 2019

I'm experiencing same issue on my fresh installation

@unrealps

This comment has been minimized.

Copy link

@unrealps unrealps commented Sep 10, 2019

I had the same problem. Running rm -f /var/lib/rpm/__db* and then yum update, solved this.

This method did not solve the problem

[lzy@DESKTOP-GLN7DSM ~]$ sudo rm -f /var/lib/rpm/__db*
[sudo] password for lzy:
[lzy@DESKTOP-GLN7DSM ~]$ sudo yum update
Segmentation fault (core dumped)
[lzy@DESKTOP-GLN7DSM ~]$

My fault... dnf update

@LuoZhongYao

This comment has been minimized.

Copy link
Author

@LuoZhongYao LuoZhongYao commented Sep 11, 2019

I'm experiencing same issue on my fresh installation

This update contains rpm, dnf, it should be a problem with these two packages, I have excluded these two packages in /etc/dnf/dnf.conf and then update.

@LuoZhongYao

This comment has been minimized.

Copy link
Author

@LuoZhongYao LuoZhongYao commented Sep 11, 2019

I had the same problem. Running rm -f /var/lib/rpm/__db* and then yum update, solved this.

This method did not solve the problem

[lzy@DESKTOP-GLN7DSM ~]$ sudo rm -f /var/lib/rpm/__db*
[sudo] password for lzy:
[lzy@DESKTOP-GLN7DSM ~]$ sudo yum update
Segmentation fault (core dumped)
[lzy@DESKTOP-GLN7DSM ~]$

My fault... dnf update

dnf is also the same error

@antoineco

This comment has been minimized.

Copy link

@antoineco antoineco commented Sep 11, 2019

Can confirm the issue on a fresh installation. The first dnf update runs to completion, but every other update/install will show that error.

dnf update detail
$ sudo dnf history info 6
Transaction ID : 6
Begin time     : Wed 11 Sep 2019 09:58:40 PM DST
Begin rpmdb    : 311:6849d26cc03ace86c76c584cbc516331bee98e60
End time       : Wed 11 Sep 2019 09:59:46 PM DST (66 seconds)
End rpmdb      : 332:6937bb3131d392a6ce2ab6039dac30a71f5da730
User           : root <root>
Return-Code    : Success
Releasever     : 30
Command Line   : update
Packages Altered:
    Install  gnupg2-smime-2.2.17-1.fc30.x86_64                 @updates
    Install  iproute-tc-5.2.0-1.fc30.x86_64                    @updates
    Install  libevent-2.1.8-7.fc30.x86_64                      @updates
    Install  libssh-config-0.9.0-5.fc30.noarch                 @updates
    Install  libxcrypt-compat-4.4.8-1.fc30.x86_64              @updates
    Install  linux-atm-libs-2.5.1-25.fc30.x86_64               @updates
    Install  mkpasswd-5.5.1-1.fc30.x86_64                      @updates
    Install  openssl-1:1.1.1c-6.fc30.x86_64                    @updates
    Install  python3-pip-19.0.3-3.fc30.noarch                  @updates
    Install  rpm-plugin-systemd-inhibit-4.14.2.1-5.fc30.x86_64 @updates
    Install  whois-nls-5.5.1-1.fc30.noarch                     @updates
    Install  xkeyboard-config-2.26-2.fc30.noarch               @updates
    Install  deltarpm-3.6-29.fc30.x86_64                       @fedora
    Install  libsecret-0.18.8-1.fc30.x86_64                    @fedora
    Install  libxkbcommon-0.8.3-1.fc30.x86_64                  @fedora
    Install  openssl-pkcs11-0.4.10-1.fc30.x86_64               @fedora
    Install  pinentry-1.1.0-5.fc30.x86_64                      @fedora
    Install  python3-dbus-1.2.8-5.fc30.x86_64                  @fedora
    Install  python3-setuptools-40.8.0-1.fc30.noarch           @fedora
    Install  python3-unbound-1.8.3-4.fc30.x86_64               @fedora
    Install  unbound-libs-1.8.3-4.fc30.x86_64                  @fedora
    Upgrade  NetworkManager-1:1.16.4-1.fc30.x86_64             @updates
    Upgraded NetworkManager-1:1.16.2-1.fc30.x86_64             @@System
    Upgrade  NetworkManager-libnm-1:1.16.4-1.fc30.x86_64       @updates
    Upgraded NetworkManager-libnm-1:1.16.2-1.fc30.x86_64       @@System
    Upgrade  audit-3.0-0.9.20190507gitf58ec40.fc30.x86_64      @updates
    Upgraded audit-3.0-0.7.20190326git03e7489.fc30.x86_64      @@System
    Upgrade  audit-libs-3.0-0.9.20190507gitf58ec40.fc30.x86_64 @updates
    Upgraded audit-libs-3.0-0.7.20190326git03e7489.fc30.x86_64 @@System
    Upgrade  bind-export-libs-32:9.11.10-1.fc30.x86_64         @updates
    Upgraded bind-export-libs-32:9.11.6-5.P1.fc30.x86_64       @@System
    Upgrade  cryptsetup-libs-2.2.0-1.fc30.x86_64               @updates
    Upgraded cryptsetup-libs-2.1.0-3.fc30.x86_64               @@System
    Upgrade  cups-libs-1:2.2.12-1.fc30.x86_64                  @updates
    Upgraded cups-libs-1:2.2.11-2.fc30.x86_64                  @@System
    Upgrade  curl-7.65.3-3.fc30.x86_64                         @updates
    Upgraded curl-7.64.0-7.fc30.x86_64                         @@System
    Upgrade  dbus-1:1.12.16-1.fc30.x86_64                      @updates
    Upgraded dbus-1:1.12.14-1.fc30.x86_64                      @@System
    Upgrade  dbus-common-1:1.12.16-1.fc30.noarch               @updates
    Upgraded dbus-common-1:1.12.14-1.fc30.noarch               @@System
    Upgrade  dbus-libs-1:1.12.16-1.fc30.x86_64                 @updates
    Upgraded dbus-libs-1:1.12.14-1.fc30.x86_64                 @@System
    Upgrade  dhcp-client-12:4.3.6-37.fc30.x86_64               @updates
    Upgraded dhcp-client-12:4.3.6-34.fc30.x86_64               @@System
    Upgrade  dhcp-common-12:4.3.6-37.fc30.noarch               @updates
    Upgraded dhcp-common-12:4.3.6-34.fc30.noarch               @@System
    Upgrade  dhcp-libs-12:4.3.6-37.fc30.x86_64                 @updates
    Upgraded dhcp-libs-12:4.3.6-34.fc30.x86_64                 @@System
    Upgrade  dnf-4.2.8-1.fc30.noarch                           @updates
    Upgraded dnf-4.2.5-1.fc30.noarch                           @@System
    Upgrade  dnf-data-4.2.8-1.fc30.noarch                      @updates
    Upgraded dnf-data-4.2.5-1.fc30.noarch                      @@System
    Upgrade  dnf-plugins-core-4.0.9-1.fc30.noarch              @updates
    Upgraded dnf-plugins-core-4.0.7-1.fc30.noarch              @@System
    Upgrade  dnf-yum-4.2.8-1.fc30.noarch                       @updates
    Upgraded dnf-yum-4.2.5-1.fc30.noarch                       @@System
    Upgrade  elfutils-0.177-1.fc30.x86_64                      @updates
    Upgraded elfutils-0.176-2.fc30.x86_64                      @@System
    Upgrade  elfutils-default-yama-scope-0.177-1.fc30.noarch   @updates
    Upgraded elfutils-default-yama-scope-0.176-2.fc30.noarch   @@System
    Upgrade  elfutils-libelf-0.177-1.fc30.x86_64               @updates
    Upgraded elfutils-libelf-0.176-2.fc30.x86_64               @@System
    Upgrade  elfutils-libs-0.177-1.fc30.x86_64                 @updates
    Upgraded elfutils-libs-0.176-2.fc30.x86_64                 @@System
    Upgrade  expat-2.2.7-1.fc30.x86_64                         @updates
    Upgraded expat-2.2.6-2.fc30.x86_64                         @@System
    Upgrade  fedora-gpg-keys-30-2.noarch                       @updates
    Upgraded fedora-gpg-keys-30-1.noarch                       @@System
    Upgrade  fedora-repos-30-2.noarch                          @updates
    Upgraded fedora-repos-30-1.noarch                          @@System
    Upgrade  file-5.36-4.fc30.x86_64                           @updates
    Upgraded file-5.36-2.fc30.x86_64                           @@System
    Upgrade  file-libs-5.36-4.fc30.x86_64                      @updates
    Upgraded file-libs-5.36-2.fc30.x86_64                      @@System
    Upgrade  gdb-headless-8.3-6.fc30.x86_64                    @updates
    Upgraded gdb-headless-8.3-3.fc30.x86_64                    @@System
    Upgrade  glib2-2.60.7-1.fc30.x86_64                        @updates
    Upgraded glib2-2.60.3-1.fc30.x86_64                        @@System
    Upgrade  glibc-2.29-22.fc30.x86_64                         @updates
    Upgraded glibc-2.29-15.fc30.x86_64                         @@System
    Upgrade  glibc-common-2.29-22.fc30.x86_64                  @updates
    Upgraded glibc-common-2.29-15.fc30.x86_64                  @@System
    Upgrade  glibc-langpack-en-2.29-22.fc30.x86_64             @updates
    Upgraded glibc-langpack-en-2.29-15.fc30.x86_64             @@System
    Upgrade  glibc-minimal-langpack-2.29-22.fc30.x86_64        @updates
    Upgraded glibc-minimal-langpack-2.29-15.fc30.x86_64        @@System
    Upgrade  gnupg2-2.2.17-1.fc30.x86_64                       @updates
    Upgraded gnupg2-2.2.13-1.fc30.x86_64                       @@System
    Upgrade  graphite2-1.3.13-1.fc30.x86_64                    @updates
    Upgraded graphite2-1.3.10-7.fc30.x86_64                    @@System
    Upgrade  iproute-5.2.0-1.fc30.x86_64                       @updates
    Upgraded iproute-5.0.0-2.fc30.x86_64                       @@System
    Upgrade  iptables-libs-1.8.2-3.fc30.x86_64                 @updates
    Upgraded iptables-libs-1.8.2-1.fc30.x86_64                 @@System
    Upgrade  kmod-libs-26-3.fc30.x86_64                        @updates
    Upgraded kmod-libs-25-5.fc30.x86_64                        @@System
    Upgrade  less-551-1.fc30.x86_64                            @updates
    Upgraded less-550-1.fc30.x86_64                            @@System
    Upgrade  libXi-1.7.10-1.fc30.x86_64                        @updates
    Upgraded libXi-1.7.9-9.fc30.x86_64                         @@System
    Upgrade  libblkid-2.33.2-2.fc30.x86_64                     @updates
    Upgraded libblkid-2.33.2-1.fc30.x86_64                     @@System
    Upgrade  libcurl-7.65.3-3.fc30.x86_64                      @updates
    Upgraded libcurl-7.64.0-7.fc30.x86_64                      @@System
    Upgrade  libdnf-0.35.2-1.fc30.x86_64                       @updates
    Upgraded libdnf-0.31.0-3.fc30.x86_64                       @@System
    Upgrade  libfdisk-2.33.2-2.fc30.x86_64                     @updates
    Upgraded libfdisk-2.33.2-1.fc30.x86_64                     @@System
    Upgrade  libgcc-9.2.1-1.fc30.x86_64                        @updates
    Upgraded libgcc-9.1.1-1.fc30.x86_64                        @@System
    Upgrade  libgcrypt-1.8.5-1.fc30.x86_64                     @updates
    Upgraded libgcrypt-1.8.4-3.fc30.x86_64                     @@System
    Upgrade  libgomp-9.2.1-1.fc30.x86_64                       @updates
    Upgraded libgomp-9.1.1-1.fc30.x86_64                       @@System
    Upgrade  libgs-9.26-5.fc30.x86_64                          @updates
    Upgraded libgs-9.26-4.fc30.x86_64                          @@System
    Upgrade  libmodulemd1-1.8.15-3.fc30.1.x86_64               @updates
    Upgraded libmodulemd1-1.8.11-2.fc30.x86_64                 @@System
    Upgrade  libmount-2.33.2-2.fc30.x86_64                     @updates
    Upgraded libmount-2.33.2-1.fc30.x86_64                     @@System
    Upgrade  libnghttp2-1.39.2-1.fc30.x86_64                   @updates
    Upgraded libnghttp2-1.38.0-1.fc30.x86_64                   @@System
    Upgrade  librepo-1.10.5-1.fc30.x86_64                      @updates
    Upgraded librepo-1.10.2-2.fc30.x86_64                      @@System
    Upgrade  libreport-filesystem-2.10.1-1.fc30.noarch         @updates
    Upgraded libreport-filesystem-2.10.0-3.fc30.noarch         @@System
    Upgrade  librsvg2-2.45.90-1.fc30.x86_64                    @updates
    Upgraded librsvg2-2.45.6-1.fc30.x86_64                     @@System
    Upgrade  libsmartcols-2.33.2-2.fc30.x86_64                 @updates
    Upgraded libsmartcols-2.33.2-1.fc30.x86_64                 @@System
    Upgrade  libsolv-0.7.5-1.fc30.x86_64                       @updates
    Upgraded libsolv-0.7.4-2.fc30.x86_64                       @@System
    Upgrade  libssh-0.9.0-5.fc30.x86_64                        @updates
    Upgraded libssh-0.8.7-1.fc30.x86_64                        @@System
    Upgrade  libstdc++-9.2.1-1.fc30.x86_64                     @updates
    Upgraded libstdc++-9.1.1-1.fc30.x86_64                     @@System
    Upgrade  libtiff-4.0.10-5.fc30.x86_64                      @updates
    Upgraded libtiff-4.0.10-4.fc30.x86_64                      @@System
    Upgrade  libuuid-2.33.2-2.fc30.x86_64                      @updates
    Upgraded libuuid-2.33.2-1.fc30.x86_64                      @@System
    Upgrade  libwebp-1.0.3-1.fc30.x86_64                       @updates
    Upgraded libwebp-1.0.2-2.fc30.x86_64                       @@System
    Upgrade  libxcrypt-4.4.8-1.fc30.x86_64                     @updates
    Upgraded libxcrypt-4.4.6-1.fc30.x86_64                     @@System
    Upgrade  libzstd-1.4.2-1.fc30.x86_64                       @updates
    Upgraded libzstd-1.4.0-1.fc30.x86_64                       @@System
    Upgrade  lz4-libs-1.9.1-1.fc30.x86_64                      @updates
    Upgraded lz4-libs-1.8.3-2.fc30.x86_64                      @@System
    Upgrade  openssh-8.0p1-5.fc30.x86_64                       @updates
    Upgraded openssh-8.0p1-3.fc30.x86_64                       @@System
    Upgrade  openssh-clients-8.0p1-5.fc30.x86_64               @updates
    Upgraded openssh-clients-8.0p1-3.fc30.x86_64               @@System
    Upgrade  openssh-server-8.0p1-5.fc30.x86_64                @updates
    Upgraded openssh-server-8.0p1-3.fc30.x86_64                @@System
    Upgrade  openssl-libs-1:1.1.1c-6.fc30.x86_64               @updates
    Upgraded openssl-libs-1:1.1.1c-2.fc30.x86_64               @@System
    Upgrade  pango-1.43.0-4.fc30.x86_64                        @updates
    Upgraded pango-1.43.0-3.fc30.x86_64                        @@System
    Upgrade  patch-2.7.6-11.fc30.x86_64                        @updates
    Upgraded patch-2.7.6-9.fc30.x86_64                         @@System
    Upgrade  pcre2-10.33-13.fc30.x86_64                        @updates
    Upgraded pcre2-10.33-2.fc30.x86_64                         @@System
    Upgrade  python-pip-wheel-19.0.3-3.fc30.noarch             @updates
    Upgraded python-pip-wheel-19.0.3-1.fc30.noarch             @@System
    Upgrade  python3-3.7.4-1.fc30.x86_64                       @updates
    Upgraded python3-3.7.3-3.fc30.x86_64                       @@System
    Upgrade  python3-dnf-4.2.8-1.fc30.noarch                   @updates
    Upgraded python3-dnf-4.2.5-1.fc30.noarch                   @@System
    Upgrade  python3-dnf-plugins-core-4.0.9-1.fc30.noarch      @updates
    Upgraded python3-dnf-plugins-core-4.0.7-1.fc30.noarch      @@System
    Upgrade  python3-hawkey-0.35.2-1.fc30.x86_64               @updates
    Upgraded python3-hawkey-0.31.0-3.fc30.x86_64               @@System
    Upgrade  python3-libdnf-0.35.2-1.fc30.x86_64               @updates
    Upgraded python3-libdnf-0.31.0-3.fc30.x86_64               @@System
    Upgrade  python3-libs-3.7.4-1.fc30.x86_64                  @updates
    Upgraded python3-libs-3.7.3-3.fc30.x86_64                  @@System
    Upgrade  python3-rpm-4.14.2.1-5.fc30.x86_64                @updates
    Upgraded python3-rpm-4.14.2.1-4.fc30.1.x86_64              @@System
    Upgrade  qt5-srpm-macros-5.12.4-1.fc30.noarch              @updates
    Upgraded qt5-srpm-macros-5.12.1-1.fc30.noarch              @@System
    Upgrade  redhat-rpm-config-130-1.fc30.noarch               @updates
    Upgraded redhat-rpm-config-128-1.fc30.noarch               @@System
    Upgrade  rpm-4.14.2.1-5.fc30.x86_64                        @updates
    Upgraded rpm-4.14.2.1-4.fc30.1.x86_64                      @@System
    Upgrade  rpm-build-4.14.2.1-5.fc30.x86_64                  @updates
    Upgraded rpm-build-4.14.2.1-4.fc30.1.x86_64                @@System
    Upgrade  rpm-build-libs-4.14.2.1-5.fc30.x86_64             @updates
    Upgraded rpm-build-libs-4.14.2.1-4.fc30.1.x86_64           @@System
    Upgrade  rpm-libs-4.14.2.1-5.fc30.x86_64                   @updates
    Upgraded rpm-libs-4.14.2.1-4.fc30.1.x86_64                 @@System
    Upgrade  rpm-sign-libs-4.14.2.1-5.fc30.x86_64              @updates
    Upgraded rpm-sign-libs-4.14.2.1-4.fc30.1.x86_64            @@System
    Upgrade  rust-srpm-macros-10-1.fc30.noarch                 @updates
    Upgraded rust-srpm-macros-9-1.fc30.noarch                  @@System
    Upgrade  sqlite-libs-3.26.0-6.fc30.x86_64                  @updates
    Upgraded sqlite-libs-3.26.0-5.fc30.x86_64                  @@System
    Upgrade  systemd-241-12.git1e19bcd.fc30.x86_64             @updates
    Upgraded systemd-241-8.git9ef65cb.fc30.x86_64              @@System
    Upgrade  systemd-libs-241-12.git1e19bcd.fc30.x86_64        @updates
    Upgraded systemd-libs-241-8.git9ef65cb.fc30.x86_64         @@System
    Upgrade  systemd-pam-241-12.git1e19bcd.fc30.x86_64         @updates
    Upgraded systemd-pam-241-8.git9ef65cb.fc30.x86_64          @@System
    Upgrade  systemd-rpm-macros-241-12.git1e19bcd.fc30.noarch  @updates
    Upgraded systemd-rpm-macros-241-8.git9ef65cb.fc30.noarch   @@System
    Upgrade  tzdata-2019b-1.fc30.noarch                        @updates
    Upgraded tzdata-2019a-1.fc30.noarch                        @@System
    Upgrade  util-linux-2.33.2-2.fc30.x86_64                   @updates
    Upgraded util-linux-2.33.2-1.fc30.x86_64                   @@System
    Upgrade  vim-minimal-2:8.1.1912-1.fc30.x86_64              @updates
    Upgraded vim-minimal-2:8.1.1517-1.fc30.x86_64              @@System
    Upgrade  zlib-1.2.11-18.fc30.x86_64                        @updates
    Upgraded zlib-1.2.11-15.fc30.x86_64                        @@System
    Upgrade  zstd-1.4.2-1.fc30.x86_64                          @updates
    Upgraded zstd-1.4.0-1.fc30.x86_64                          @@System
    Upgrade  wslu-2.3.1-1.noarch                               @whitewaterfoundry_wslu
    Upgraded wslu-2.2.1-1.noarch                               @@System
Scriptlet output:
   1 /var/tmp/rpm-tmp.C7fRNT: line 1: /usr/bin/udevadm: No such file or directory
   2 /var/tmp/rpm-tmp.C7fRNT: line 2: /usr/bin/udevadm: No such file or directory
   3 /var/tmp/rpm-tmp.UiYRJk: line 1: /usr/bin/udevadm: No such file or directory
   4 /var/tmp/rpm-tmp.UiYRJk: line 2: /usr/bin/udevadm: No such file or directory
   5 warning: file /etc/systemd/system/dbus-org.freedesktop.resolve1.service: remove failed: No such file or directory
   6 warning: file /etc/systemd/system/dbus-org.freedesktop.network1.service: remove failed: No such file or directory

No success with rpm --rebuilddb

$ sudo rpm --rebuilddb
error: failed to replace old database with new database!
error: replace files in /var/lib/rpm with files from /var/lib/rpmrebuilddb.464 to recover
@sirredbeard

This comment has been minimized.

Copy link
Member

@sirredbeard sirredbeard commented Sep 11, 2019

What builds of Windows 10 are you on?

I wonder if you are running into this WhitewaterFoundry/Pengwin-Enterprise#20

@antoineco

This comment has been minimized.

Copy link

@antoineco antoineco commented Sep 11, 2019

Oldish, 10.0.17763

It looks like that issue indeed.

@YRTV

This comment has been minimized.

Copy link

@YRTV YRTV commented Sep 11, 2019

~$ sudo dnf install zsh
[sudo] password for yurii: 
Total size: 2.9 M
Installed size: 7.4 M
Is this ok [y/N]: y  
Downloading Packages:
[SKIPPED] zsh-5.7.1-4.fc30.x86_64.rpm: Already downloaded
Running transaction check
Transaction check succeeded.
Running transaction test
Transaction test succeeded.
Running transaction
RPM: error: db5 error(-30969) from dbenv->open: BDB0091 DB_VERSION_MISMATCH: Database environment version mismatch
RPM: error: cannot open Packages index using db5 -  (-30969)
RPM: error: cannot open Packages database in /var/lib/rpm
The downloaded packages were saved in cache until the next successful transaction.
You can remove cached packages by executing 'dnf clean packages'.
Error: Could not run transaction.
~$ sudo rpm --rebuilddb
error: failed to replace old database with new database!
error: replace files in /var/lib/rpm with files from /var/lib/rpmrebuilddb.331 to recover

Both issues are still present on Microsoft Windows [Version 10.0.18362.356]

@ealap

This comment has been minimized.

Copy link

@ealap ealap commented Sep 14, 2019

I could avoid this problem on a new installation by doing the following steps:

sudo dnf upgrade --refresh rpm glibc
sudo rm /var/lib/rpm/.rpm.lock
sudo dnf upgrade dnf

then we can now proceed on upgrading the rest of the packages or installing new ones.

@crramirez

This comment has been minimized.

Copy link
Contributor

@crramirez crramirez commented Sep 14, 2019

Thank you for the solution. If it works in all cases, we can put it in our init scripts

@dkayser

This comment has been minimized.

Copy link

@dkayser dkayser commented Sep 15, 2019

I had struggled with this problem as well, and @ealap's solution worked for me. Thanks!

@YRTV

This comment has been minimized.

Copy link

@YRTV YRTV commented Sep 15, 2019

It works!
Just don't be lazy like me and copy paste into script, typo in last upgrade.

@sirredbeard sirredbeard added the bug label Sep 15, 2019
@YRTV

This comment has been minimized.

Copy link

@YRTV YRTV commented Sep 16, 2019

Marcin Kielar

sudo dnf -v upgrade --refresh rpm glibc

Produces no logs, and does not seem to have any effect

It does on fersh install even without -v.

Installation successful!
[yurii@DESKTOP-T9D1TRO ~]$ sudo dnf upgrade --refresh rpm glibc

We trust you have received the usual lecture from the local System
Administrator. It usually boils down to these three things:

    #1) Respect the privacy of others.
    #2) Think before you type.
    #3) With great power comes great responsibility.

[sudo] password for yurii:
Fedora Modular 30 - x86_64                                                              534 kB/s | 2.7 MB     00:05
Fedora Modular 30 - x86_64 - Updates                                                    715 kB/s | 3.3 MB     00:04
Fedora 30 - x86_64 - Updates                                                            2.4 MB/s |  20 MB     00:08
Fedora 30 - x86_64                                                                      3.6 MB/s |  70 MB     00:19
whitewaterfoundry_wslu                                                                  151  B/s | 833  B     00:05
whitewaterfoundry_wslu                                                                  1.8 kB/s | 3.9 kB     00:02
Importing GPG key 0x10735619:
 Userid     : "https://packagecloud.io/whitewaterfoundry/wslu (https://packagecloud.io/docs#gpg_signing) <support@packagecloud.io>"
 Fingerprint: 90F6 8549 4B52 C0E9 6DA4 B925 0087 4F17 1073 5619
 From       : https://packagecloud.io/whitewaterfoundry/wslu/gpgkey
Is this ok [y/N]: y
whitewaterfoundry_wslu                                                                  280  B/s | 1.8 kB     00:06
Last metadata expiration check: 0:00:01 ago on Mon 16 Sep 2019 01:16:13 PM MSK.
Dependencies resolved.
========================================================================================================================
 Package                              Architecture         Version                          Repository             Size
========================================================================================================================
Upgrading:
 glibc                                x86_64               2.29-22.fc30                     updates               4.0 M
 glibc-common                         x86_64               2.29-22.fc30                     updates               838 k
 glibc-langpack-en                    x86_64               2.29-22.fc30                     updates               818 k
 glibc-minimal-langpack               x86_64               2.29-22.fc30                     updates                47 k
 python3-rpm                          x86_64               4.14.2.1-5.fc30                  updates                65 k
 rpm                                  x86_64               4.14.2.1-5.fc30                  updates               479 k
 rpm-build                            x86_64               4.14.2.1-5.fc30                  updates               106 k
 rpm-build-libs                       x86_64               4.14.2.1-5.fc30                  updates                86 k
 rpm-libs                             x86_64               4.14.2.1-5.fc30                  updates               264 k
 rpm-sign-libs                        x86_64               4.14.2.1-5.fc30                  updates                23 k

Transaction Summary
========================================================================================================================
Upgrade  10 Packages

Total download size: 6.6 M
Is this ok [y/N]: y
Downloading Packages:
(1/10): glibc-langpack-en-2.29-22.fc30.x86_64.rpm                                       394 kB/s | 818 kB     00:02
(2/10): glibc-common-2.29-22.fc30.x86_64.rpm                                            401 kB/s | 838 kB     00:02
(3/10): glibc-minimal-langpack-2.29-22.fc30.x86_64.rpm                                  211 kB/s |  47 kB     00:00
(4/10): python3-rpm-4.14.2.1-5.fc30.x86_64.rpm                                          287 kB/s |  65 kB     00:00
(5/10): rpm-build-4.14.2.1-5.fc30.x86_64.rpm                                            398 kB/s | 106 kB     00:00
(6/10): rpm-build-libs-4.14.2.1-5.fc30.x86_64.rpm                                       342 kB/s |  86 kB     00:00
(7/10): rpm-4.14.2.1-5.fc30.x86_64.rpm                                                  838 kB/s | 479 kB     00:00
(8/10): glibc-2.29-22.fc30.x86_64.rpm                                                   1.4 MB/s | 4.0 MB     00:02
(9/10): rpm-sign-libs-4.14.2.1-5.fc30.x86_64.rpm                                        108 kB/s |  23 kB     00:00
(10/10): rpm-libs-4.14.2.1-5.fc30.x86_64.rpm                                            930 kB/s | 264 kB     00:00
------------------------------------------------------------------------------------------------------------------------
Total                                                                                   1.5 MB/s | 6.6 MB     00:04
Running transaction check
Transaction check succeeded.
Running transaction test
Transaction test succeeded.
Running transaction
  Preparing        :                                                                                                1/1
  Upgrading        : glibc-common-2.29-22.fc30.x86_64                                                              1/20
  Upgrading        : glibc-langpack-en-2.29-22.fc30.x86_64                                                         2/20
  Running scriptlet: glibc-2.29-22.fc30.x86_64                                                                     3/20
  Upgrading        : glibc-2.29-22.fc30.x86_64                                                                     3/20
  Running scriptlet: glibc-2.29-22.fc30.x86_64                                                                     3/20
  Upgrading        : rpm-4.14.2.1-5.fc30.x86_64                                                                    4/20
  Upgrading        : rpm-libs-4.14.2.1-5.fc30.x86_64                                                               5/20
  Upgrading        : rpm-build-libs-4.14.2.1-5.fc30.x86_64                                                         6/20
  Upgrading        : rpm-sign-libs-4.14.2.1-5.fc30.x86_64                                                          7/20
  Upgrading        : python3-rpm-4.14.2.1-5.fc30.x86_64                                                            8/20
  Upgrading        : rpm-build-4.14.2.1-5.fc30.x86_64                                                              9/20
  Upgrading        : glibc-minimal-langpack-2.29-22.fc30.x86_64                                                   10/20
  Cleanup          : glibc-minimal-langpack-2.29-15.fc30.x86_64                                                   11/20
  Cleanup          : rpm-build-4.14.2.1-4.fc30.1.x86_64                                                           12/20
  Cleanup          : python3-rpm-4.14.2.1-4.fc30.1.x86_64                                                         13/20
  Cleanup          : rpm-build-libs-4.14.2.1-4.fc30.1.x86_64                                                      14/20
  Cleanup          : rpm-sign-libs-4.14.2.1-4.fc30.1.x86_64                                                       15/20
  Cleanup          : rpm-4.14.2.1-4.fc30.1.x86_64                                                                 16/20
  Cleanup          : rpm-libs-4.14.2.1-4.fc30.1.x86_64                                                            17/20
  Cleanup          : glibc-2.29-15.fc30.x86_64                                                                    18/20
  Cleanup          : glibc-langpack-en-2.29-15.fc30.x86_64                                                        19/20
  Cleanup          : glibc-common-2.29-15.fc30.x86_64                                                             20/20
  Running scriptlet: glibc-common-2.29-15.fc30.x86_64                                                             20/20
  Running scriptlet: glibc-common-2.29-22.fc30.x86_64                                                             20/20
  Verifying        : glibc-2.29-22.fc30.x86_64                                                                     1/20
  Verifying        : glibc-2.29-15.fc30.x86_64                                                                     2/20
  Verifying        : glibc-common-2.29-22.fc30.x86_64                                                              3/20
  Verifying        : glibc-common-2.29-15.fc30.x86_64                                                              4/20
  Verifying        : glibc-langpack-en-2.29-22.fc30.x86_64                                                         5/20
  Verifying        : glibc-langpack-en-2.29-15.fc30.x86_64                                                         6/20
  Verifying        : glibc-minimal-langpack-2.29-22.fc30.x86_64                                                    7/20
  Verifying        : glibc-minimal-langpack-2.29-15.fc30.x86_64                                                    8/20
  Verifying        : python3-rpm-4.14.2.1-5.fc30.x86_64                                                            9/20
  Verifying        : python3-rpm-4.14.2.1-4.fc30.1.x86_64                                                         10/20
  Verifying        : rpm-4.14.2.1-5.fc30.x86_64                                                                   11/20
  Verifying        : rpm-4.14.2.1-4.fc30.1.x86_64                                                                 12/20
  Verifying        : rpm-build-4.14.2.1-5.fc30.x86_64                                                             13/20
  Verifying        : rpm-build-4.14.2.1-4.fc30.1.x86_64                                                           14/20
  Verifying        : rpm-build-libs-4.14.2.1-5.fc30.x86_64                                                        15/20
  Verifying        : rpm-build-libs-4.14.2.1-4.fc30.1.x86_64                                                      16/20
  Verifying        : rpm-libs-4.14.2.1-5.fc30.x86_64                                                              17/20
  Verifying        : rpm-libs-4.14.2.1-4.fc30.1.x86_64                                                            18/20
  Verifying        : rpm-sign-libs-4.14.2.1-5.fc30.x86_64                                                         19/20
  Verifying        : rpm-sign-libs-4.14.2.1-4.fc30.1.x86_64                                                       20/20

Upgraded:
  glibc-2.29-22.fc30.x86_64                                glibc-common-2.29-22.fc30.x86_64
  glibc-langpack-en-2.29-22.fc30.x86_64                    glibc-minimal-langpack-2.29-22.fc30.x86_64
  python3-rpm-4.14.2.1-5.fc30.x86_64                       rpm-4.14.2.1-5.fc30.x86_64
  rpm-build-4.14.2.1-5.fc30.x86_64                         rpm-build-libs-4.14.2.1-5.fc30.x86_64
  rpm-libs-4.14.2.1-5.fc30.x86_64                          rpm-sign-libs-4.14.2.1-5.fc30.x86_64

Complete!

After removing the __db* and the core dump, calling dnf with anything else than --help causes it to hang indefinitely, and log nothing.

it's sudo rm /var/lib/rpm/.rpm.lock not sudo rm -f /var/lib/rpm/__db*
I call dnf upgrade and dnf install after this to setup build enviroment for https://github.com/godotengine/godot.

@PTrenholme

This comment has been minimized.

Copy link

@PTrenholme PTrenholme commented Oct 5, 2019

I just ran into this, and the key is to remove the rpm lock after you get the problem. Apparently, once the db system barfs, the rpm lock stays on.

sudo rm /var/lib/rpm/.rpm.lock

is the key.

@crramirez crramirez pinned this issue Oct 13, 2019
@crramirez

This comment has been minimized.

Copy link
Contributor

@crramirez crramirez commented Oct 13, 2019

A fix was uploaded to the store with the version 1.30.5.0 if someone can check if the error is gone away.

@YRTV

This comment has been minimized.

Copy link

@YRTV YRTV commented Nov 12, 2019

Unpacking Linux filesystem image, this may take a few minutes... Welcome to Fedora Remix for WSL. Powered by Pengwin Enterprise. Please create a default Linux user account. The username does not need to match your Windows username. Enter new UNIX username: yurii Changing password for user yurii. New password: Retype new password: passwd: all authentication tokens updated successfully. Installation successful! [yurii@DESKTOP-T9D1TRO ~]$ sudo dnf update -y We trust you have received the usual lecture from the local System Administrator. It usually boils down to these three things: #1) Respect the privacy of others. #2) Think before you type. #3) With great power comes great responsibility. [sudo] password for yurii: Fedora Modular 31 - x86_64 2.5 MB/s | 5.2 MB 00:02 Fedora Modular 31 - x86_64 - Updates 1.0 MB/s | 3.1 MB 00:02 Fedora 31 - x86_64 - Updates 2.1 MB/s | 6.7 MB 00:03 Fedora 31 - x86_64 7.4 MB/s | 71 MB 00:09 whitewaterfoundry_wslu 195 B/s | 833 B 00:04 whitewaterfoundry_wslu 3.4 kB/s | 3.9 kB 00:01 Importing GPG key 0x10735619: Userid : "https://packagecloud.io/whitewaterfoundry/wslu (https://packagecloud.io/docs#gpg_signing) <support@packagecloud.io>" Fingerprint: 90F6 8549 4B52 C0E9 6DA4 B925 0087 4F17 1073 5619 From : https://packagecloud.io/whitewaterfoundry/wslu/gpgkey whitewaterfoundry_wslu 349 B/s | 1.4 kB 00:04 Dependencies resolved. ======================================================================================================================== Package Architecture Version Repository Size ========================================================================================================================Upgrading: NetworkManager x86_64 1:1.20.6-1.fc31 updates 2.0 M NetworkManager-libnm x86_64 1:1.20.6-1.fc31 updates 1.6 M crypto-policies noarch 20191002-1.gitc93dc99.fc31 updates 91 k cryptsetup-libs x86_64 2.2.2-1.fc31 updates 428 k glib2 x86_64 2.62.2-1.fc31 updates 2.6 M librsvg2 x86_64 2.46.3-1.fc31 updates 1.3 M pcre2 x86_64 10.33-15.fc31 updates 256 k vim-common x86_64 2:8.1.2234-1.fc31 updates 6.4 M vim-enhanced x86_64 2:8.1.2234-1.fc31 updates 1.4 M vim-filesystem noarch 2:8.1.2234-1.fc31 updates 26 k vim-minimal x86_64 2:8.1.2234-1.fc31 updates 650 k Transaction Summary ========================================================================================================================Upgrade 11 Packages Total download size: 17 M Downloading Packages: (1/11): crypto-policies-20191002-1.gitc93dc99.fc31.noarch.rpm 88 kB/s | 91 kB 00:01 (2/11): NetworkManager-1.20.6-1.fc31.x86_64.rpm 1.5 MB/s | 2.0 MB 00:01 (3/11): NetworkManager-libnm-1.20.6-1.fc31.x86_64.rpm 1.2 MB/s | 1.6 MB 00:01 (4/11): librsvg2-2.46.3-1.fc31.x86_64.rpm 2.8 MB/s | 1.3 MB 00:00 (5/11): pcre2-10.33-15.fc31.x86_64.rpm 1.1 MB/s | 256 kB 00:00 (6/11): glib2-2.62.2-1.fc31.x86_64.rpm 3.6 MB/s | 2.6 MB 00:00 (7/11): cryptsetup-libs-2.2.2-1.fc31.x86_64.rpm 396 kB/s | 428 kB 00:01 (8/11): vim-filesystem-8.1.2234-1.fc31.noarch.rpm 225 kB/s | 26 kB 00:00 (9/11): vim-enhanced-8.1.2234-1.fc31.x86_64.rpm 2.2 MB/s | 1.4 MB 00:00 (10/11): vim-minimal-8.1.2234-1.fc31.x86_64.rpm 891 kB/s | 650 kB 00:00 (11/11): vim-common-8.1.2234-1.fc31.x86_64.rpm 2.8 MB/s | 6.4 MB 00:02 ------------------------------------------------------------------------------------------------------------------------Total 3.2 MB/s | 17 MB 00:05 Running transaction check Transaction check succeeded. Running transaction test Transaction test succeeded. Running transaction Preparing : 1/1 Running scriptlet: glib2-2.62.2-1.fc31.x86_64 1/1 Upgrading : glib2-2.62.2-1.fc31.x86_64 1/22 Upgrading : NetworkManager-libnm-1:1.20.6-1.fc31.x86_64 2/22 Upgrading : vim-filesystem-2:8.1.2234-1.fc31.noarch 3/22 Upgrading : vim-common-2:8.1.2234-1.fc31.x86_64 4/22 Upgrading : vim-enhanced-2:8.1.2234-1.fc31.x86_64 5/22 Running scriptlet: NetworkManager-1:1.20.6-1.fc31.x86_64 6/22 Upgrading : NetworkManager-1:1.20.6-1.fc31.x86_64 6/22 Running scriptlet: NetworkManager-1:1.20.6-1.fc31.x86_64 6/22 /var/tmp/rpm-tmp.Az33GC: line 1: /usr/bin/udevadm: No such file or directory /var/tmp/rpm-tmp.Az33GC: line 2: /usr/bin/udevadm: No such file or directory Upgrading : librsvg2-2.46.3-1.fc31.x86_64 7/22 Upgrading : vim-minimal-2:8.1.2234-1.fc31.x86_64 8/22 Upgrading : pcre2-10.33-15.fc31.x86_64 9/22 Upgrading : cryptsetup-libs-2.2.2-1.fc31.x86_64 10/22 Upgrading : crypto-policies-20191002-1.gitc93dc99.fc31.noarch 11/22 Running scriptlet: NetworkManager-1:1.20.4-1.fc31.x86_64 12/22 Cleanup : NetworkManager-1:1.20.4-1.fc31.x86_64 12/22 Running scriptlet: NetworkManager-1:1.20.4-1.fc31.x86_64 12/22 /var/tmp/rpm-tmp.OsObcG: line 1: /usr/bin/udevadm: No such file or directory /var/tmp/rpm-tmp.OsObcG: line 2: /usr/bin/udevadm: No such file or directory Cleanup : crypto-policies-20190816-4.gitbb9bf99.fc31.noarch 13/22 Cleanup : NetworkManager-libnm-1:1.20.4-1.fc31.x86_64 14/22 Cleanup : librsvg2-2.46.1-1.fc31.x86_64 15/22 Cleanup : vim-enhanced-2:8.1.2198-1.fc31.x86_64 16/22 Cleanup : vim-common-2:8.1.2198-1.fc31.x86_64 17/22 Cleanup : vim-filesystem-2:8.1.2198-1.fc31.noarch 18/22 Cleanup : glib2-2.62.1-1.fc31.x86_64 19/22 Cleanup : vim-minimal-2:8.1.2198-1.fc31.x86_64 20/22 Cleanup : pcre2-10.33-14.fc31.x86_64 21/22 Cleanup : cryptsetup-libs-2.2.1-1.fc31.x86_64 22/22 Running scriptlet: crypto-policies-20191002-1.gitc93dc99.fc31.noarch 22/22 Running scriptlet: cryptsetup-libs-2.2.1-1.fc31.x86_64 22/22 Running scriptlet: glib2-2.62.2-1.fc31.x86_64 22/22 Running scriptlet: vim-common-2:8.1.2234-1.fc31.x86_64 22/22 Verifying : NetworkManager-1:1.20.6-1.fc31.x86_64 1/22 Verifying : NetworkManager-1:1.20.4-1.fc31.x86_64 2/22 Verifying : NetworkManager-libnm-1:1.20.6-1.fc31.x86_64 3/22 Verifying : NetworkManager-libnm-1:1.20.4-1.fc31.x86_64 4/22 Verifying : crypto-policies-20191002-1.gitc93dc99.fc31.noarch 5/22 Verifying : crypto-policies-20190816-4.gitbb9bf99.fc31.noarch 6/22 Verifying : cryptsetup-libs-2.2.2-1.fc31.x86_64 7/22 Verifying : cryptsetup-libs-2.2.1-1.fc31.x86_64 8/22 Verifying : glib2-2.62.2-1.fc31.x86_64 9/22 Verifying : glib2-2.62.1-1.fc31.x86_64 10/22 Verifying : librsvg2-2.46.3-1.fc31.x86_64 11/22 Verifying : librsvg2-2.46.1-1.fc31.x86_64 12/22 Verifying : pcre2-10.33-15.fc31.x86_64 13/22 Verifying : pcre2-10.33-14.fc31.x86_64 14/22 Verifying : vim-common-2:8.1.2234-1.fc31.x86_64 15/22 Verifying : vim-common-2:8.1.2198-1.fc31.x86_64 16/22 Verifying : vim-enhanced-2:8.1.2234-1.fc31.x86_64 17/22 Verifying : vim-enhanced-2:8.1.2198-1.fc31.x86_64 18/22 Verifying : vim-filesystem-2:8.1.2234-1.fc31.noarch 19/22 Verifying : vim-filesystem-2:8.1.2198-1.fc31.noarch 20/22 Verifying : vim-minimal-2:8.1.2234-1.fc31.x86_64 21/22 Verifying : vim-minimal-2:8.1.2198-1.fc31.x86_64 22/22 Upgraded: NetworkManager-1:1.20.6-1.fc31.x86_64 NetworkManager-libnm-1:1.20.6-1.fc31.x86_64 crypto-policies-20191002-1.gitc93dc99.fc31.noarch cryptsetup-libs-2.2.2-1.fc31.x86_64 glib2-2.62.2-1.fc31.x86_64 librsvg2-2.46.3-1.fc31.x86_64 pcre2-10.33-15.fc31.x86_64 vim-common-2:8.1.2234-1.fc31.x86_64 vim-enhanced-2:8.1.2234-1.fc31.x86_64 vim-filesystem-2:8.1.2234-1.fc31.noarch vim-minimal-2:8.1.2234-1.fc31.x86_64 Complete! [yurii@DESKTOP-T9D1TRO ~]$ sudo dnf install bat fd-find Last metadata expiration check: 0:00:53 ago on Tue 12 Nov 2019 09:58:18 AM MSK. Dependencies resolved. ======================================================================================================================== Package Architecture Version Repository Size ========================================================================================================================Installing: bat x86_64 0.11.0-3.module_f31+5338+1c55392b fedora-modular 1.6 M fd-find x86_64 7.3.0-3.module_f31+5369+677905bc fedora-modular 799 k Installing dependencies: libssh2 x86_64 1.9.0-3.fc31 updates 119 k http-parser x86_64 2.9.2-2.fc31 fedora 39 k libgit2 x86_64 0.28.3-1.fc31 fedora 452 k Enabling module streams: bat latest fd-find rolling Transaction Summary ========================================================================================================================Install 5 Packages Total download size: 3.0 M Installed size: 7.5 M Is this ok [y/N]: y Downloading Packages: (1/5): fd-find-7.3.0-3.module_f31+5369+677905bc.x86_64.rpm 2.3 MB/s | 799 kB 00:00 (2/5): bat-0.11.0-3.module_f31+5338+1c55392b.x86_64.rpm 3.9 MB/s | 1.6 MB 00:00 (3/5): http-parser-2.9.2-2.fc31.x86_64.rpm 222 kB/s | 39 kB 00:00 (4/5): libssh2-1.9.0-3.fc31.x86_64.rpm 200 kB/s | 119 kB 00:00 (5/5): libgit2-0.28.3-1.fc31.x86_64.rpm 1.3 MB/s | 452 kB 00:00 ------------------------------------------------------------------------------------------------------------------------Total 1.3 MB/s | 3.0 MB 00:02 Running transaction check Transaction check succeeded. Running transaction test Transaction test succeeded. Running transaction Preparing : 1/1 Installing : http-parser-2.9.2-2.fc31.x86_64 1/5 Installing : libssh2-1.9.0-3.fc31.x86_64 2/5 Installing : libgit2-0.28.3-1.fc31.x86_64 3/5 Installing : bat-0.11.0-3.module_f31+5338+1c55392b.x86_64 4/5 Installing : fd-find-7.3.0-3.module_f31+5369+677905bc.x86_64 5/5 Running scriptlet: fd-find-7.3.0-3.module_f31+5369+677905bc.x86_64 5/5 Verifying : bat-0.11.0-3.module_f31+5338+1c55392b.x86_64 1/5 Verifying : fd-find-7.3.0-3.module_f31+5369+677905bc.x86_64 2/5 Verifying : libssh2-1.9.0-3.fc31.x86_64 3/5 Verifying : http-parser-2.9.2-2.fc31.x86_64 4/5 Verifying : libgit2-0.28.3-1.fc31.x86_64 5/5 Installed: bat-0.11.0-3.module_f31+5338+1c55392b.x86_64 fd-find-7.3.0-3.module_f31+5369+677905bc.x86_64 libssh2-1.9.0-3.fc31.x86_64 http-parser-2.9.2-2.fc31.x86_64 libgit2-0.28.3-1.fc31.x86_64 Complete!

Works fine for me. Full log no edits of actions identical to first post.

@crramirez

This comment has been minimized.

Copy link
Contributor

@crramirez crramirez commented Nov 12, 2019

Excellent thank you for the report. I will close it in a couple of days

@ferrazpedro

This comment has been minimized.

Copy link

@ferrazpedro ferrazpedro commented Nov 21, 2019

I have clean installed the 1.30.5.0 version but still runned into this problem...

@YRTV

This comment has been minimized.

Copy link

@YRTV YRTV commented Dec 1, 2019

Tested it. It break after dnf update, and then multiple dnf installs now.

@crramirez

This comment has been minimized.

Copy link
Contributor

@crramirez crramirez commented Dec 1, 2019

Hello @YRTV,

What version did you test? And which Windows version?

Regards

@YRTV

This comment has been minimized.

Copy link

@YRTV YRTV commented Dec 2, 2019

winver Version 10.0.18362.476
Breaks out of the box again, on fresh install right now.

Full log no edits:
Unpacking Linux filesystem image, this may take a few minutes...
Welcome to Fedora Remix for WSL. Powered by Pengwin Enterprise.
Please create a default Linux user account. The username does not need to match your Windows username.
Enter new UNIX username: yurii
Changing password for user yurii.
New password:
Retype new password:
passwd: all authentication tokens updated successfully.
Installation successful!
[yurii@DESKTOP-T9D1TRO ~]$ sudo dnf update

We trust you have received the usual lecture from the local System
Administrator. It usually boils down to these three things:

    #1) Respect the privacy of others.
    #2) Think before you type.
    #3) With great power comes great responsibility.

[sudo] password for yurii:
Fedora Modular 31 - x86_64                                                              1.1 MB/s | 5.2 MB     00:04
Fedora Modular 31 - x86_64 - Updates                                                    859 kB/s | 3.2 MB     00:03
Fedora 31 - x86_64 - Updates                                                            2.8 MB/s |  13 MB     00:04
Fedora 31 - x86_64                                                                      5.9 MB/s |  71 MB     00:12
whitewaterfoundry_wslu                                                                  131  B/s | 833  B     00:06
whitewaterfoundry_wslu                                                                  1.8 kB/s | 3.9 kB     00:02
Importing GPG key 0x10735619:
 Userid     : "https://packagecloud.io/whitewaterfoundry/wslu (https://packagecloud.io/docs#gpg_signing) <support@packagecloud.io>"
 Fingerprint: 90F6 8549 4B52 C0E9 6DA4 B925 0087 4F17 1073 5619
 From       : https://packagecloud.io/whitewaterfoundry/wslu/gpgkey
Is this ok [y/N]: y
whitewaterfoundry_wslu                                                                  189  B/s | 1.4 kB     00:07
Dependencies resolved.
========================================================================================================================
 Package                             Architecture    Version                                     Repository        Size
========================================================================================================================
Upgrading:
 ImageMagick                         x86_64          1:6.9.10.75-1.fc31                          updates          159 k
 ImageMagick-libs                    x86_64          1:6.9.10.75-1.fc31                          updates          2.3 M
 NetworkManager                      x86_64          1:1.20.8-1.fc31                             updates          2.0 M
 NetworkManager-libnm                x86_64          1:1.20.8-1.fc31                             updates          1.6 M
 audit                               x86_64          3.0-0.15.20191104git1c2f876.fc31            updates          253 k
 audit-libs                          x86_64          3.0-0.15.20191104git1c2f876.fc31            updates          115 k
 binutils                            x86_64          2.32-29.fc31                                updates          5.2 M
 binutils-gold                       x86_64          2.32-29.fc31                                updates          860 k
 crypto-policies                     noarch          20191002-1.gitc93dc99.fc31                  updates           91 k
 cryptsetup-libs                     x86_64          2.2.2-1.fc31                                updates          428 k
 device-mapper                       x86_64          1.02.165-1.fc31                             updates          147 k
 device-mapper-libs                  x86_64          1.02.165-1.fc31                             updates          182 k
 dhcp-client                         x86_64          12:4.4.1-19.fc31                            updates          1.1 M
 dhcp-common                         noarch          12:4.4.1-19.fc31                            updates          129 k
 dnf                                 noarch          4.2.15-2.fc31                               updates          402 k
 dnf-data                            noarch          4.2.15-2.fc31                               updates           47 k
 dnf-plugins-core                    noarch          4.0.11-1.fc31                               updates           32 k
 gd                                  x86_64          2.2.5-10.fc31                               updates          139 k
 gdb-minimal                         x86_64          8.3.50.20190824-25.fc31                     updates          3.4 M
 glib2                               x86_64          2.62.3-1.fc31                               updates          2.6 M
 glibc                               x86_64          2.30-7.fc31                                 updates          3.5 M
 glibc-common                        x86_64          2.30-7.fc31                                 updates          646 k
 glibc-langpack-en                   x86_64          2.30-7.fc31                                 updates          637 k
 glibc-minimal-langpack              x86_64          2.30-7.fc31                                 updates           57 k
 gtk-update-icon-cache               x86_64          3.24.13-1.fc31                              updates           34 k
 gtk2                                x86_64          2.24.32-6.fc31                              updates          3.5 M
 json-c                              x86_64          0.13.1-7.fc31                               updates           38 k
 libdnf                              x86_64          0.37.2-2.fc31                               updates          634 k
 libedit                             x86_64          3.1-29.20191025cvs.fc31                     updates          105 k
 libgs                               x86_64          9.27-2.fc31                                 updates          3.0 M
 libidn2                             x86_64          2.3.0-1.fc31                                updates          104 k
 libjpeg-turbo                       x86_64          2.0.2-5.fc31                                updates          168 k
 libnghttp2                          x86_64          1.39.2-2.fc31                               updates           81 k
 libpwquality                        x86_64          1.4.2-1.fc31                                updates          101 k
 librepo                             x86_64          1.11.0-1.fc31                               updates           96 k
 libreport-filesystem                noarch          2.11.3-1.fc31                               updates           14 k
 librsvg2                            x86_64          2.46.4-1.fc31                               updates          1.4 M
 libseccomp                          x86_64          2.4.2-1.fc31                                updates           76 k
 libsolv                             x86_64          0.7.8-1.fc31                                updates          396 k
 libssh                              x86_64          0.9.2-1.fc31                                updates          211 k
 libssh-config                       noarch          0.9.2-1.fc31                                updates           11 k
 libtiff                             x86_64          4.0.10-7.fc31                               updates          179 k
 libxml2                             x86_64          2.9.10-1.fc31                               updates          693 k
 pcre2                               x86_64          10.33-16.fc31                               updates          255 k
 polkit-libs                         x86_64          0.116-4.fc31.1                              updates           67 k
 python-pip-wheel                    noarch          19.1.1-5.fc31                               updates          1.1 M
 python3-dnf                         noarch          4.2.15-2.fc31                               updates          396 k
 python3-dnf-plugins-core            noarch          4.0.11-1.fc31                               updates          170 k
 python3-hawkey                      x86_64          0.37.2-2.fc31                               updates          100 k
 python3-libdnf                      x86_64          0.37.2-2.fc31                               updates          704 k
 python3-rpm                         x86_64          4.15.1-1.fc31                               updates           95 k
 redhat-rpm-config                   noarch          142-1.fc31                                  updates           65 k
 rpm                                 x86_64          4.15.1-1.fc31                               updates          499 k
 rpm-build                           x86_64          4.15.1-1.fc31                               updates          116 k
 rpm-build-libs                      x86_64          4.15.1-1.fc31                               updates           97 k
 rpm-libs                            x86_64          4.15.1-1.fc31                               updates          300 k
 rpm-sign-libs                       x86_64          4.15.1-1.fc31                               updates           26 k
 shared-mime-info                    x86_64          1.15-1.fc31                                 updates          303 k
 sudo                                x86_64          1.8.29-1.fc31                               updates          908 k
 systemd                             x86_64          243.4-1.fc31                                updates          3.8 M
 systemd-libs                        x86_64          243.4-1.fc31                                updates          525 k
 systemd-pam                         x86_64          243.4-1.fc31                                updates          167 k
 systemd-rpm-macros                  noarch          243.4-1.fc31                                updates           23 k
 vim-common                          x86_64          2:8.1.2352-1.fc31                           updates          6.4 M
 vim-enhanced                        x86_64          2:8.1.2352-1.fc31                           updates          1.4 M
 vim-filesystem                      noarch          2:8.1.2352-1.fc31                           updates           25 k
 vim-minimal                         x86_64          2:8.1.2352-1.fc31                           updates          651 k
 yum                                 noarch          4.2.15-2.fc31                               updates           42 k
 zchunk-libs                         x86_64          1.1.4-1.fc31                                updates           50 k
Installing dependencies:
 unbound-libs                        x86_64          1.9.4-1.fc31                                updates          522 k
 xkeyboard-config                    noarch          2.28-1.fc31                                 updates          753 k
 libevent                            x86_64          2.1.8-7.fc31                                fedora           258 k
Installing weak dependencies:
 python3-unbound                     x86_64          1.9.4-1.fc31                                updates          100 k
 rpm-plugin-systemd-inhibit          x86_64          4.15.1-1.fc31                               updates           22 k
 sqlite                              x86_64          3.30.0-1.fc31                               updates          670 k
 deltarpm                            x86_64          3.6.2-2.fc31                                fedora            87 k
 libxcrypt-compat                    x86_64          4.4.10-1.fc31                               fedora           100 k
 libxkbcommon                        x86_64          0.8.4-2.fc31                                fedora           120 k
 python3-dbus                        x86_64          1.2.8-6.fc31                                fedora           132 k

Transaction Summary
========================================================================================================================
Install  10 Packages
Upgrade  69 Packages

Total download size: 58 M
Is this ok [y/N]: y
Downloading Packages:
(1/79): rpm-plugin-systemd-inhibit-4.15.1-1.fc31.x86_64.rpm                              20 kB/s |  22 kB     00:01
(2/79): python3-unbound-1.9.4-1.fc31.x86_64.rpm                                          81 kB/s | 100 kB     00:01
(3/79): sqlite-3.30.0-1.fc31.x86_64.rpm                                                 415 kB/s | 670 kB     00:01
(4/79): deltarpm-3.6.2-2.fc31.x86_64.rpm                                                485 kB/s |  87 kB     00:00
(5/79): unbound-libs-1.9.4-1.fc31.x86_64.rpm                                            666 kB/s | 522 kB     00:00
(6/79): xkeyboard-config-2.28-1.fc31.noarch.rpm                                         1.2 MB/s | 753 kB     00:00
(7/79): libxkbcommon-0.8.4-2.fc31.x86_64.rpm                                            645 kB/s | 120 kB     00:00
(8/79): libxcrypt-compat-4.4.10-1.fc31.x86_64.rpm                                       504 kB/s | 100 kB     00:00
(9/79): libevent-2.1.8-7.fc31.x86_64.rpm                                                926 kB/s | 258 kB     00:00
(10/79): python3-dbus-1.2.8-6.fc31.x86_64.rpm                                           667 kB/s | 132 kB     00:00
(11/79): ImageMagick-6.9.10.75-1.fc31.x86_64.rpm                                        637 kB/s | 159 kB     00:00
(12/79): ImageMagick-libs-6.9.10.75-1.fc31.x86_64.rpm                                   3.0 MB/s | 2.3 MB     00:00
(13/79): NetworkManager-1.20.8-1.fc31.x86_64.rpm                                        3.3 MB/s | 2.0 MB     00:00
(14/79): NetworkManager-libnm-1.20.8-1.fc31.x86_64.rpm                                  2.5 MB/s | 1.6 MB     00:00
(15/79): audit-3.0-0.15.20191104git1c2f876.fc31.x86_64.rpm                              1.3 MB/s | 253 kB     00:00
(16/79): audit-libs-3.0-0.15.20191104git1c2f876.fc31.x86_64.rpm                         634 kB/s | 115 kB     00:00
(17/79): crypto-policies-20191002-1.gitc93dc99.fc31.noarch.rpm                          461 kB/s |  91 kB     00:00
(18/79): binutils-gold-2.32-29.fc31.x86_64.rpm                                          1.7 MB/s | 860 kB     00:00
(19/79): device-mapper-1.02.165-1.fc31.x86_64.rpm                                       815 kB/s | 147 kB     00:00
(20/79): device-mapper-libs-1.02.165-1.fc31.x86_64.rpm                                  987 kB/s | 182 kB     00:00
(21/79): binutils-2.32-29.fc31.x86_64.rpm                                               5.1 MB/s | 5.2 MB     00:01
(22/79): dhcp-common-4.4.1-19.fc31.noarch.rpm                                           683 kB/s | 129 kB     00:00
(23/79): dhcp-client-4.4.1-19.fc31.x86_64.rpm                                           2.8 MB/s | 1.1 MB     00:00
(24/79): cryptsetup-libs-2.2.2-1.fc31.x86_64.rpm                                        385 kB/s | 428 kB     00:01
(25/79): dnf-4.2.15-2.fc31.noarch.rpm                                                   1.6 MB/s | 402 kB     00:00
(26/79): dnf-data-4.2.15-2.fc31.noarch.rpm                                              273 kB/s |  47 kB     00:00
(27/79): gd-2.2.5-10.fc31.x86_64.rpm                                                    729 kB/s | 139 kB     00:00
(28/79): dnf-plugins-core-4.0.11-1.fc31.noarch.rpm                                      136 kB/s |  32 kB     00:00
(29/79): gdb-minimal-8.3.50.20190824-25.fc31.x86_64.rpm                                 4.0 MB/s | 3.4 MB     00:00
(30/79): glibc-2.30-7.fc31.x86_64.rpm                                                   4.2 MB/s | 3.5 MB     00:00
(31/79): glibc-common-2.30-7.fc31.x86_64.rpm                                            2.6 MB/s | 646 kB     00:00
(32/79): glibc-minimal-langpack-2.30-7.fc31.x86_64.rpm                                  331 kB/s |  57 kB     00:00
(33/79): glibc-langpack-en-2.30-7.fc31.x86_64.rpm                                       1.7 MB/s | 637 kB     00:00
(34/79): gtk-update-icon-cache-3.24.13-1.fc31.x86_64.rpm                                197 kB/s |  34 kB     00:00
(35/79): json-c-0.13.1-7.fc31.x86_64.rpm                                                222 kB/s |  38 kB     00:00
(36/79): libdnf-0.37.2-2.fc31.x86_64.rpm                                                1.7 MB/s | 634 kB     00:00
(37/79): libedit-3.1-29.20191025cvs.fc31.x86_64.rpm                                     595 kB/s | 105 kB     00:00
(38/79): gtk2-2.24.32-6.fc31.x86_64.rpm                                                 4.0 MB/s | 3.5 MB     00:00
(39/79): libidn2-2.3.0-1.fc31.x86_64.rpm                                                508 kB/s | 104 kB     00:00
(40/79): libjpeg-turbo-2.0.2-5.fc31.x86_64.rpm                                          797 kB/s | 168 kB     00:00
(41/79): libnghttp2-1.39.2-2.fc31.x86_64.rpm                                            439 kB/s |  81 kB     00:00
(42/79): libgs-9.27-2.fc31.x86_64.rpm                                                   4.5 MB/s | 3.0 MB     00:00
(43/79): libpwquality-1.4.2-1.fc31.x86_64.rpm                                           540 kB/s | 101 kB     00:00
(44/79): librepo-1.11.0-1.fc31.x86_64.rpm                                               544 kB/s |  96 kB     00:00
(45/79): glib2-2.62.3-1.fc31.x86_64.rpm                                                 912 kB/s | 2.6 MB     00:02
(46/79): libreport-filesystem-2.11.3-1.fc31.noarch.rpm                                   79 kB/s |  14 kB     00:00
(47/79): librsvg2-2.46.4-1.fc31.x86_64.rpm                                              3.8 MB/s | 1.4 MB     00:00
(48/79): libsolv-0.7.8-1.fc31.x86_64.rpm                                                1.5 MB/s | 396 kB     00:00
(49/79): libssh-0.9.2-1.fc31.x86_64.rpm                                                 1.1 MB/s | 211 kB     00:00
(50/79): libssh-config-0.9.2-1.fc31.noarch.rpm                                           62 kB/s |  11 kB     00:00
(51/79): libtiff-4.0.10-7.fc31.x86_64.rpm                                               968 kB/s | 179 kB     00:00
(52/79): libxml2-2.9.10-1.fc31.x86_64.rpm                                               2.2 MB/s | 693 kB     00:00
(53/79): pcre2-10.33-16.fc31.x86_64.rpm                                                 1.3 MB/s | 255 kB     00:00
(54/79): polkit-libs-0.116-4.fc31.1.x86_64.rpm                                          367 kB/s |  67 kB     00:00
(55/79): libseccomp-2.4.2-1.fc31.x86_64.rpm                                              63 kB/s |  76 kB     00:01
(56/79): python-pip-wheel-19.1.1-5.fc31.noarch.rpm                                      2.9 MB/s | 1.1 MB     00:00
(57/79): python3-dnf-4.2.15-2.fc31.noarch.rpm                                           1.6 MB/s | 396 kB     00:00
(58/79): python3-hawkey-0.37.2-2.fc31.x86_64.rpm                                        566 kB/s | 100 kB     00:00
(59/79): python3-libdnf-0.37.2-2.fc31.x86_64.rpm                                        2.5 MB/s | 704 kB     00:00
(60/79): python3-rpm-4.15.1-1.fc31.x86_64.rpm                                           394 kB/s |  95 kB     00:00
(61/79): redhat-rpm-config-142-1.fc31.noarch.rpm                                        344 kB/s |  65 kB     00:00
(62/79): python3-dnf-plugins-core-4.0.11-1.fc31.noarch.rpm                              285 kB/s | 170 kB     00:00
(63/79): rpm-4.15.1-1.fc31.x86_64.rpm                                                   2.0 MB/s | 499 kB     00:00
(64/79): rpm-build-4.15.1-1.fc31.x86_64.rpm                                             613 kB/s | 116 kB     00:00
(65/79): rpm-build-libs-4.15.1-1.fc31.x86_64.rpm                                        374 kB/s |  97 kB     00:00
(66/79): rpm-libs-4.15.1-1.fc31.x86_64.rpm                                              1.5 MB/s | 300 kB     00:00
(67/79): rpm-sign-libs-4.15.1-1.fc31.x86_64.rpm                                         142 kB/s |  26 kB     00:00
(68/79): shared-mime-info-1.15-1.fc31.x86_64.rpm                                        667 kB/s | 303 kB     00:00
(69/79): sudo-1.8.29-1.fc31.x86_64.rpm                                                  1.8 MB/s | 908 kB     00:00
(70/79): systemd-pam-243.4-1.fc31.x86_64.rpm                                            890 kB/s | 167 kB     00:00
(71/79): systemd-243.4-1.fc31.x86_64.rpm                                                5.4 MB/s | 3.8 MB     00:00
(72/79): systemd-rpm-macros-243.4-1.fc31.noarch.rpm                                     135 kB/s |  23 kB     00:00
(73/79): systemd-libs-243.4-1.fc31.x86_64.rpm                                           1.0 MB/s | 525 kB     00:00
(74/79): vim-enhanced-8.1.2352-1.fc31.x86_64.rpm                                        1.8 MB/s | 1.4 MB     00:00
(75/79): vim-common-8.1.2352-1.fc31.x86_64.rpm                                          6.6 MB/s | 6.4 MB     00:00
(76/79): vim-filesystem-8.1.2352-1.fc31.noarch.rpm                                       27 kB/s |  25 kB     00:00
(77/79): yum-4.2.15-2.fc31.noarch.rpm                                                   234 kB/s |  42 kB     00:00
(78/79): vim-minimal-8.1.2352-1.fc31.x86_64.rpm                                         1.6 MB/s | 651 kB     00:00
(79/79): zchunk-libs-1.1.4-1.fc31.x86_64.rpm                                            167 kB/s |  50 kB     00:00
------------------------------------------------------------------------------------------------------------------------
Total                                                                                   4.1 MB/s |  58 MB     00:14
Running transaction check
Transaction check succeeded.
Running transaction test
Transaction test succeeded.
Running transaction
  Preparing        :                                                                                                1/1
  Running scriptlet: glibc-common-2.30-7.fc31.x86_64                                                                1/1
  Upgrading        : glibc-common-2.30-7.fc31.x86_64                                                              1/148
  Upgrading        : glibc-langpack-en-2.30-7.fc31.x86_64                                                         2/148
  Running scriptlet: glibc-2.30-7.fc31.x86_64                                                                     3/148
  Upgrading        : glibc-2.30-7.fc31.x86_64                                                                     3/148
  Running scriptlet: glibc-2.30-7.fc31.x86_64                                                                     3/148
  Upgrading        : audit-libs-3.0-0.15.20191104git1c2f876.fc31.x86_64                                           4/148
  Upgrading        : rpm-4.15.1-1.fc31.x86_64                                                                     5/148
  Upgrading        : rpm-libs-4.15.1-1.fc31.x86_64                                                                6/148
  Upgrading        : libxml2-2.9.10-1.fc31.x86_64                                                                 7/148
  Upgrading        : systemd-libs-243.4-1.fc31.x86_64                                                             8/148
  Running scriptlet: systemd-libs-243.4-1.fc31.x86_64                                                             8/148
  Upgrading        : libjpeg-turbo-2.0.2-5.fc31.x86_64                                                            9/148
  Upgrading        : libtiff-4.0.10-7.fc31.x86_64                                                                10/148
  Upgrading        : rpm-build-libs-4.15.1-1.fc31.x86_64                                                         11/148
  Installing       : libevent-2.1.8-7.fc31.x86_64                                                                12/148
  Upgrading        : binutils-gold-2.32-29.fc31.x86_64                                                           13/148
  Upgrading        : binutils-2.32-29.fc31.x86_64                                                                14/148
  Running scriptlet: binutils-2.32-29.fc31.x86_64                                                                14/148
  Upgrading        : json-c-0.13.1-7.fc31.x86_64                                                                 15/148
  Upgrading        : zchunk-libs-1.1.4-1.fc31.x86_64                                                             16/148
  Upgrading        : libsolv-0.7.8-1.fc31.x86_64                                                                 17/148
  Running scriptlet: unbound-libs-1.9.4-1.fc31.x86_64                                                            18/148
  Installing       : unbound-libs-1.9.4-1.fc31.x86_64                                                            18/148
  Running scriptlet: unbound-libs-1.9.4-1.fc31.x86_64                                                            18/148
Created symlink /etc/systemd/system/timers.target.wants/unbound-anchor.timer → /usr/lib/systemd/system/unbound-anchor.timer.

  Installing       : python3-unbound-1.9.4-1.fc31.x86_64                                                         19/148
  Upgrading        : libgs-9.27-2.fc31.x86_64                                                                    20/148
  Upgrading        : shared-mime-info-1.15-1.fc31.x86_64                                                         21/148
  Running scriptlet: shared-mime-info-1.15-1.fc31.x86_64                                                         21/148
  Upgrading        : glib2-2.62.3-1.fc31.x86_64                                                                  22/148
  Installing       : python3-dbus-1.2.8-6.fc31.x86_64                                                            23/148
  Upgrading        : NetworkManager-libnm-1:1.20.8-1.fc31.x86_64                                                 24/148
  Upgrading        : gtk-update-icon-cache-3.24.13-1.fc31.x86_64                                                 25/148
  Upgrading        : librepo-1.11.0-1.fc31.x86_64                                                                26/148
  Upgrading        : libdnf-0.37.2-2.fc31.x86_64                                                                 27/148
  Upgrading        : python3-libdnf-0.37.2-2.fc31.x86_64                                                         28/148
  Upgrading        : python3-hawkey-0.37.2-2.fc31.x86_64                                                         29/148
  Upgrading        : librsvg2-2.46.4-1.fc31.x86_64                                                               30/148
  Upgrading        : ImageMagick-libs-1:6.9.10.75-1.fc31.x86_64                                                  31/148
  Upgrading        : polkit-libs-0.116-4.fc31.1.x86_64                                                           32/148
  Installing       : rpm-plugin-systemd-inhibit-4.15.1-1.fc31.x86_64                                             33/148
  Installing       : deltarpm-3.6.2-2.fc31.x86_64                                                                34/148
  Upgrading        : rpm-sign-libs-4.15.1-1.fc31.x86_64                                                          35/148
  Upgrading        : python3-rpm-4.15.1-1.fc31.x86_64                                                            36/148
  Upgrading        : redhat-rpm-config-142-1.fc31.noarch                                                         37/148
  Installing       : sqlite-3.30.0-1.fc31.x86_64                                                                 38/148
  Installing       : libxcrypt-compat-4.4.10-1.fc31.x86_64                                                       39/148
  Upgrading        : gdb-minimal-8.3.50.20190824-25.fc31.x86_64                                                  40/148
  Upgrading        : libidn2-2.3.0-1.fc31.x86_64                                                                 41/148
  Upgrading        : libseccomp-2.4.2-1.fc31.x86_64                                                              42/148
  Upgrading        : pcre2-10.33-16.fc31.x86_64                                                                  43/148
  Upgrading        : vim-minimal-2:8.1.2352-1.fc31.x86_64                                                        44/148
  Upgrading        : vim-filesystem-2:8.1.2352-1.fc31.noarch                                                     45/148
  Upgrading        : vim-common-2:8.1.2352-1.fc31.x86_64                                                         46/148
  Upgrading        : systemd-rpm-macros-243.4-1.fc31.noarch                                                      47/148
  Upgrading        : libssh-config-0.9.2-1.fc31.noarch                                                           48/148
  Upgrading        : libreport-filesystem-2.11.3-1.fc31.noarch                                                   49/148
  Upgrading        : dnf-data-4.2.15-2.fc31.noarch                                                               50/148
  Upgrading        : python3-dnf-4.2.15-2.fc31.noarch                                                            51/148
  Upgrading        : dnf-4.2.15-2.fc31.noarch                                                                    52/148
  Running scriptlet: dnf-4.2.15-2.fc31.noarch                                                                    52/148
  Upgrading        : python3-dnf-plugins-core-4.0.11-1.fc31.noarch                                               53/148
  Upgrading        : dhcp-common-12:4.4.1-19.fc31.noarch                                                         54/148
  Upgrading        : crypto-policies-20191002-1.gitc93dc99.fc31.noarch                                           55/148
  Installing       : xkeyboard-config-2.28-1.fc31.noarch                                                         56/148
  Installing       : libxkbcommon-0.8.4-2.fc31.x86_64                                                            57/148
  Upgrading        : cryptsetup-libs-2.2.2-1.fc31.x86_64                                                         58/148
  Upgrading        : device-mapper-libs-1.02.165-1.fc31.x86_64                                                   59/148
  Upgrading        : device-mapper-1.02.165-1.fc31.x86_64                                                        60/148
  Upgrading        : systemd-pam-243.4-1.fc31.x86_64                                                             61/148
  Running scriptlet: systemd-243.4-1.fc31.x86_64                                                                 62/148
  Upgrading        : systemd-243.4-1.fc31.x86_64                                                                 62/148
  Running scriptlet: systemd-243.4-1.fc31.x86_64                                                                 62/148
  Running scriptlet: NetworkManager-1:1.20.8-1.fc31.x86_64                                                       63/148
  Upgrading        : NetworkManager-1:1.20.8-1.fc31.x86_64                                                       63/148
  Running scriptlet: NetworkManager-1:1.20.8-1.fc31.x86_64                                                       63/148
/var/tmp/rpm-tmp.nfqjzE: line 1: /usr/bin/udevadm: No such file or directory
/var/tmp/rpm-tmp.nfqjzE: line 2: /usr/bin/udevadm: No such file or directory

  Upgrading        : audit-3.0-0.15.20191104git1c2f876.fc31.x86_64                                               64/148
  Running scriptlet: audit-3.0-0.15.20191104git1c2f876.fc31.x86_64                                               64/148
  Upgrading        : dhcp-client-12:4.4.1-19.fc31.x86_64                                                         65/148
  Upgrading        : libssh-0.9.2-1.fc31.x86_64                                                                  66/148
  Upgrading        : dnf-plugins-core-4.0.11-1.fc31.noarch                                                       67/148
  Upgrading        : yum-4.2.15-2.fc31.noarch                                                                    68/148
  Upgrading        : vim-enhanced-2:8.1.2352-1.fc31.x86_64                                                       69/148
  Upgrading        : sudo-1.8.29-1.fc31.x86_64                                                                   70/148
  Running scriptlet: sudo-1.8.29-1.fc31.x86_64                                                                   70/148
  Upgrading        : rpm-build-4.15.1-1.fc31.x86_64                                                              71/148
  Upgrading        : python-pip-wheel-19.1.1-5.fc31.noarch                                                       72/148
  Upgrading        : ImageMagick-1:6.9.10.75-1.fc31.x86_64                                                       73/148
  Upgrading        : gtk2-2.24.32-6.fc31.x86_64                                                                  74/148
  Upgrading        : gd-2.2.5-10.fc31.x86_64                                                                     75/148
  Upgrading        : glibc-minimal-langpack-2.30-7.fc31.x86_64                                                   76/148
  Upgrading        : libedit-3.1-29.20191025cvs.fc31.x86_64                                                      77/148
  Upgrading        : libnghttp2-1.39.2-2.fc31.x86_64                                                             78/148
  Upgrading        : libpwquality-1.4.2-1.fc31.x86_64                                                            79/148
  Running scriptlet: NetworkManager-1:1.20.4-1.fc31.x86_64                                                       80/148
  Cleanup          : NetworkManager-1:1.20.4-1.fc31.x86_64                                                       80/148
  Running scriptlet: NetworkManager-1:1.20.4-1.fc31.x86_64                                                       80/148
/var/tmp/rpm-tmp.D7nMZC: line 1: /usr/bin/udevadm: No such file or directory
/var/tmp/rpm-tmp.D7nMZC: line 2: /usr/bin/udevadm: No such file or directory

  Cleanup          : sudo-1.8.28p1-1.fc31.x86_64                                                                 81/148
  Cleanup          : device-mapper-1.02.163-2.fc31.x86_64                                                        82/148
  Running scriptlet: audit-3.0-0.12.20190507gitf58ec40.fc31.x86_64                                               83/148
  Cleanup          : audit-3.0-0.12.20190507gitf58ec40.fc31.x86_64                                               83/148
  Running scriptlet: audit-3.0-0.12.20190507gitf58ec40.fc31.x86_64                                               83/148
  Cleanup          : dhcp-client-12:4.4.1-15.fc31.x86_64                                                         84/148
  Running scriptlet: systemd-243-4.gitef67743.fc31.x86_64                                                        85/148
  Cleanup          : systemd-243-4.gitef67743.fc31.x86_64                                                        85/148
  Cleanup          : gtk2-2.24.32-5.fc31.x86_64                                                                  86/148
  Cleanup          : systemd-pam-243-4.gitef67743.fc31.x86_64                                                    87/148
  Cleanup          : NetworkManager-libnm-1:1.20.4-1.fc31.x86_64                                                 88/148
  Cleanup          : vim-enhanced-2:8.1.2198-1.fc31.x86_64                                                       89/148
  Cleanup          : rpm-build-4.15.0-6.fc31.x86_64                                                              90/148
  Cleanup          : cryptsetup-libs-2.2.1-1.fc31.x86_64                                                         91/148
  Cleanup          : gd-2.2.5-9.fc31.x86_64                                                                      92/148
  Cleanup          : device-mapper-libs-1.02.163-2.fc31.x86_64                                                   93/148
  Running scriptlet: binutils-2.32-24.fc31.x86_64                                                                94/148
  Cleanup          : binutils-2.32-24.fc31.x86_64                                                                94/148
  Running scriptlet: binutils-2.32-24.fc31.x86_64                                                                94/148
  Cleanup          : gdb-minimal-8.3.50.20190824-24.fc31.x86_64                                                  95/148
  Cleanup          : libssh-0.9.0-6.fc31.x86_64                                                                  96/148
  Cleanup          : polkit-libs-0.116-4.fc31.x86_64                                                             97/148
  Cleanup          : systemd-libs-243-4.gitef67743.fc31.x86_64                                                   98/148
  Cleanup          : binutils-gold-2.32-24.fc31.x86_64                                                           99/148
  Cleanup          : vim-minimal-2:8.1.2198-1.fc31.x86_64                                                       100/148
  Cleanup          : vim-common-2:8.1.2198-1.fc31.x86_64                                                        101/148
  Cleanup          : pcre2-10.33-14.fc31.x86_64                                                                 102/148
  Cleanup          : libpwquality-1.4.1-1.fc31.x86_64                                                           103/148
  Cleanup          : libedit-3.1-28.20190324cvs.fc31.x86_64                                                     104/148
  Cleanup          : ImageMagick-1:6.9.10.67-1.fc31.x86_64                                                      105/148
  Cleanup          : glibc-minimal-langpack-2.30-5.fc31.x86_64                                                  106/148
  Cleanup          : redhat-rpm-config-140-2.fc31.noarch                                                        107/148
  Cleanup          : yum-4.2.9-5.fc31.noarch                                                                    108/148
  Running scriptlet: dnf-4.2.9-5.fc31.noarch                                                                    109/148
  Cleanup          : dnf-4.2.9-5.fc31.noarch                                                                    109/148
  Running scriptlet: dnf-4.2.9-5.fc31.noarch                                                                    109/148
System has not been booted with systemd as init system (PID 1). Can't operate.
Failed to connect to bus: Host is down

  Cleanup          : dnf-plugins-core-4.0.9-1.fc31.noarch                                                       110/148
  Cleanup          : ImageMagick-libs-1:6.9.10.67-1.fc31.x86_64                                                 111/148
  Cleanup          : librsvg2-2.46.1-1.fc31.x86_64                                                              112/148
  Cleanup          : libgs-9.27-1.fc31.x86_64                                                                   113/148
  Cleanup          : libtiff-4.0.10-6.fc31.x86_64                                                               114/148
  Cleanup          : libjpeg-turbo-2.0.2-4.fc31.x86_64                                                          115/148
  Cleanup          : libidn2-2.2.0-2.fc31.x86_64                                                                116/148
  Cleanup          : libnghttp2-1.39.2-1.fc31.x86_64                                                            117/148
  Cleanup          : python3-dnf-plugins-core-4.0.9-1.fc31.noarch                                               118/148
  Cleanup          : python3-dnf-4.2.9-5.fc31.noarch                                                            119/148
  Cleanup          : dnf-data-4.2.9-5.fc31.noarch                                                               120/148
  Cleanup          : libreport-filesystem-2.10.1-2.fc31.noarch                                                  121/148
  Cleanup          : vim-filesystem-2:8.1.2198-1.fc31.noarch                                                    122/148
  Cleanup          : libssh-config-0.9.0-6.fc31.noarch                                                          123/148
  Cleanup          : crypto-policies-20190816-4.gitbb9bf99.fc31.noarch                                          124/148
  Cleanup          : systemd-rpm-macros-243-4.gitef67743.fc31.noarch                                            125/148
  Cleanup          : dhcp-common-12:4.4.1-15.fc31.noarch                                                        126/148
  Cleanup          : python-pip-wheel-19.1.1-4.fc31.noarch                                                      127/148
  Cleanup          : python3-rpm-4.15.0-6.fc31.x86_64                                                           128/148
  Cleanup          : rpm-build-libs-4.15.0-6.fc31.x86_64                                                        129/148
  Cleanup          : rpm-sign-libs-4.15.0-6.fc31.x86_64                                                         130/148
  Cleanup          : python3-hawkey-0.35.3-6.fc31.x86_64                                                        131/148
  Cleanup          : python3-libdnf-0.35.3-6.fc31.x86_64                                                        132/148
  Cleanup          : libdnf-0.35.3-6.fc31.x86_64                                                                133/148
  Cleanup          : libsolv-0.7.7-1.fc31.x86_64                                                                134/148
  Cleanup          : rpm-4.15.0-6.fc31.x86_64                                                                   135/148
  Cleanup          : rpm-libs-4.15.0-6.fc31.x86_64                                                              136/148
  Cleanup          : librepo-1.10.5-1.fc31.x86_64                                                               137/148
  Cleanup          : audit-libs-3.0-0.12.20190507gitf58ec40.fc31.x86_64                                         138/148
  Cleanup          : json-c-0.13.1-6.fc31.x86_64                                                                139/148
  Cleanup          : zchunk-libs-1.1.2-3.fc31.x86_64                                                            140/148
  Cleanup          : gtk-update-icon-cache-3.24.12-3.fc31.x86_64                                                141/148
  Cleanup          : glib2-2.62.1-1.fc31.x86_64                                                                 142/148
  Cleanup          : shared-mime-info-1.14-1.fc31.x86_64                                                        143/148
  Cleanup          : libxml2-2.9.9-3.fc31.x86_64                                                                144/148
  Cleanup          : libseccomp-2.4.1-1.fc31.x86_64                                                             145/148
  Cleanup          : glibc-2.30-5.fc31.x86_64                                                                   146/148
  Cleanup          : glibc-langpack-en-2.30-5.fc31.x86_64                                                       147/148
  Cleanup          : glibc-common-2.30-5.fc31.x86_64                                                            148/148
  Running scriptlet: crypto-policies-20191002-1.gitc93dc99.fc31.noarch                                          148/148
  Running scriptlet: glibc-common-2.30-5.fc31.x86_64                                                            148/148
  Running scriptlet: glibc-common-2.30-7.fc31.x86_64                                                            148/148
  Running scriptlet: shared-mime-info-1.15-1.fc31.x86_64                                                        148/148
  Running scriptlet: glib2-2.62.3-1.fc31.x86_64                                                                 148/148
  Running scriptlet: vim-common-2:8.1.2352-1.fc31.x86_64                                                        148/148
  Running scriptlet: systemd-243.4-1.fc31.x86_64                                                                148/148
  Verifying        : python3-unbound-1.9.4-1.fc31.x86_64                                                          1/148
  Verifying        : rpm-plugin-systemd-inhibit-4.15.1-1.fc31.x86_64                                              2/148
  Verifying        : sqlite-3.30.0-1.fc31.x86_64                                                                  3/148
  Verifying        : unbound-libs-1.9.4-1.fc31.x86_64                                                             4/148
  Verifying        : xkeyboard-config-2.28-1.fc31.noarch                                                          5/148
  Verifying        : deltarpm-3.6.2-2.fc31.x86_64                                                                 6/148
  Verifying        : libevent-2.1.8-7.fc31.x86_64                                                                 7/148
  Verifying        : libxcrypt-compat-4.4.10-1.fc31.x86_64                                                        8/148
  Verifying        : libxkbcommon-0.8.4-2.fc31.x86_64                                                             9/148
  Verifying        : python3-dbus-1.2.8-6.fc31.x86_64                                                            10/148
  Verifying        : ImageMagick-1:6.9.10.75-1.fc31.x86_64                                                       11/148
  Verifying        : ImageMagick-1:6.9.10.67-1.fc31.x86_64                                                       12/148
  Verifying        : ImageMagick-libs-1:6.9.10.75-1.fc31.x86_64                                                  13/148
  Verifying        : ImageMagick-libs-1:6.9.10.67-1.fc31.x86_64                                                  14/148
  Verifying        : NetworkManager-1:1.20.8-1.fc31.x86_64                                                       15/148
  Verifying        : NetworkManager-1:1.20.4-1.fc31.x86_64                                                       16/148
  Verifying        : NetworkManager-libnm-1:1.20.8-1.fc31.x86_64                                                 17/148
  Verifying        : NetworkManager-libnm-1:1.20.4-1.fc31.x86_64                                                 18/148
  Verifying        : audit-3.0-0.15.20191104git1c2f876.fc31.x86_64                                               19/148
  Verifying        : audit-3.0-0.12.20190507gitf58ec40.fc31.x86_64                                               20/148
  Verifying        : audit-libs-3.0-0.15.20191104git1c2f876.fc31.x86_64                                          21/148
  Verifying        : audit-libs-3.0-0.12.20190507gitf58ec40.fc31.x86_64                                          22/148
  Verifying        : binutils-2.32-29.fc31.x86_64                                                                23/148
  Verifying        : binutils-2.32-24.fc31.x86_64                                                                24/148
  Verifying        : binutils-gold-2.32-29.fc31.x86_64                                                           25/148
  Verifying        : binutils-gold-2.32-24.fc31.x86_64                                                           26/148
  Verifying        : crypto-policies-20191002-1.gitc93dc99.fc31.noarch                                           27/148
  Verifying        : crypto-policies-20190816-4.gitbb9bf99.fc31.noarch                                           28/148
  Verifying        : cryptsetup-libs-2.2.2-1.fc31.x86_64                                                         29/148
  Verifying        : cryptsetup-libs-2.2.1-1.fc31.x86_64                                                         30/148
  Verifying        : device-mapper-1.02.165-1.fc31.x86_64                                                        31/148
  Verifying        : device-mapper-1.02.163-2.fc31.x86_64                                                        32/148
  Verifying        : device-mapper-libs-1.02.165-1.fc31.x86_64                                                   33/148
  Verifying        : device-mapper-libs-1.02.163-2.fc31.x86_64                                                   34/148
  Verifying        : dhcp-client-12:4.4.1-19.fc31.x86_64                                                         35/148
  Verifying        : dhcp-client-12:4.4.1-15.fc31.x86_64                                                         36/148
  Verifying        : dhcp-common-12:4.4.1-19.fc31.noarch                                                         37/148
  Verifying        : dhcp-common-12:4.4.1-15.fc31.noarch                                                         38/148
  Verifying        : dnf-4.2.15-2.fc31.noarch                                                                    39/148
  Verifying        : dnf-4.2.9-5.fc31.noarch                                                                     40/148
  Verifying        : dnf-data-4.2.15-2.fc31.noarch                                                               41/148
  Verifying        : dnf-data-4.2.9-5.fc31.noarch                                                                42/148
  Verifying        : dnf-plugins-core-4.0.11-1.fc31.noarch                                                       43/148
  Verifying        : dnf-plugins-core-4.0.9-1.fc31.noarch                                                        44/148
  Verifying        : gd-2.2.5-10.fc31.x86_64                                                                     45/148
  Verifying        : gd-2.2.5-9.fc31.x86_64                                                                      46/148
  Verifying        : gdb-minimal-8.3.50.20190824-25.fc31.x86_64                                                  47/148
  Verifying        : gdb-minimal-8.3.50.20190824-24.fc31.x86_64                                                  48/148
  Verifying        : glib2-2.62.3-1.fc31.x86_64                                                                  49/148
  Verifying        : glib2-2.62.1-1.fc31.x86_64                                                                  50/148
  Verifying        : glibc-2.30-7.fc31.x86_64                                                                    51/148
  Verifying        : glibc-2.30-5.fc31.x86_64                                                                    52/148
  Verifying        : glibc-common-2.30-7.fc31.x86_64                                                             53/148
  Verifying        : glibc-common-2.30-5.fc31.x86_64                                                             54/148
  Verifying        : glibc-langpack-en-2.30-7.fc31.x86_64                                                        55/148
  Verifying        : glibc-langpack-en-2.30-5.fc31.x86_64                                                        56/148
  Verifying        : glibc-minimal-langpack-2.30-7.fc31.x86_64                                                   57/148
  Verifying        : glibc-minimal-langpack-2.30-5.fc31.x86_64                                                   58/148
  Verifying        : gtk-update-icon-cache-3.24.13-1.fc31.x86_64                                                 59/148
  Verifying        : gtk-update-icon-cache-3.24.12-3.fc31.x86_64                                                 60/148
  Verifying        : gtk2-2.24.32-6.fc31.x86_64                                                                  61/148
  Verifying        : gtk2-2.24.32-5.fc31.x86_64                                                                  62/148
  Verifying        : json-c-0.13.1-7.fc31.x86_64                                                                 63/148
  Verifying        : json-c-0.13.1-6.fc31.x86_64                                                                 64/148
  Verifying        : libdnf-0.37.2-2.fc31.x86_64                                                                 65/148
  Verifying        : libdnf-0.35.3-6.fc31.x86_64                                                                 66/148
  Verifying        : libedit-3.1-29.20191025cvs.fc31.x86_64                                                      67/148
  Verifying        : libedit-3.1-28.20190324cvs.fc31.x86_64                                                      68/148
  Verifying        : libgs-9.27-2.fc31.x86_64                                                                    69/148
  Verifying        : libgs-9.27-1.fc31.x86_64                                                                    70/148
  Verifying        : libidn2-2.3.0-1.fc31.x86_64                                                                 71/148
  Verifying        : libidn2-2.2.0-2.fc31.x86_64                                                                 72/148
  Verifying        : libjpeg-turbo-2.0.2-5.fc31.x86_64                                                           73/148
  Verifying        : libjpeg-turbo-2.0.2-4.fc31.x86_64                                                           74/148
  Verifying        : libnghttp2-1.39.2-2.fc31.x86_64                                                             75/148
  Verifying        : libnghttp2-1.39.2-1.fc31.x86_64                                                             76/148
  Verifying        : libpwquality-1.4.2-1.fc31.x86_64                                                            77/148
  Verifying        : libpwquality-1.4.1-1.fc31.x86_64                                                            78/148
  Verifying        : librepo-1.11.0-1.fc31.x86_64                                                                79/148
  Verifying        : librepo-1.10.5-1.fc31.x86_64                                                                80/148
  Verifying        : libreport-filesystem-2.11.3-1.fc31.noarch                                                   81/148
  Verifying        : libreport-filesystem-2.10.1-2.fc31.noarch                                                   82/148
  Verifying        : librsvg2-2.46.4-1.fc31.x86_64                                                               83/148
  Verifying        : librsvg2-2.46.1-1.fc31.x86_64                                                               84/148
  Verifying        : libseccomp-2.4.2-1.fc31.x86_64                                                              85/148
  Verifying        : libseccomp-2.4.1-1.fc31.x86_64                                                              86/148
  Verifying        : libsolv-0.7.8-1.fc31.x86_64                                                                 87/148
  Verifying        : libsolv-0.7.7-1.fc31.x86_64                                                                 88/148
  Verifying        : libssh-0.9.2-1.fc31.x86_64                                                                  89/148
  Verifying        : libssh-0.9.0-6.fc31.x86_64                                                                  90/148
  Verifying        : libssh-config-0.9.2-1.fc31.noarch                                                           91/148
  Verifying        : libssh-config-0.9.0-6.fc31.noarch                                                           92/148
  Verifying        : libtiff-4.0.10-7.fc31.x86_64                                                                93/148
  Verifying        : libtiff-4.0.10-6.fc31.x86_64                                                                94/148
  Verifying        : libxml2-2.9.10-1.fc31.x86_64                                                                95/148
  Verifying        : libxml2-2.9.9-3.fc31.x86_64                                                                 96/148
  Verifying        : pcre2-10.33-16.fc31.x86_64                                                                  97/148
  Verifying        : pcre2-10.33-14.fc31.x86_64                                                                  98/148
  Verifying        : polkit-libs-0.116-4.fc31.1.x86_64                                                           99/148
  Verifying        : polkit-libs-0.116-4.fc31.x86_64                                                            100/148
  Verifying        : python-pip-wheel-19.1.1-5.fc31.noarch                                                      101/148
  Verifying        : python-pip-wheel-19.1.1-4.fc31.noarch                                                      102/148
  Verifying        : python3-dnf-4.2.15-2.fc31.noarch                                                           103/148
  Verifying        : python3-dnf-4.2.9-5.fc31.noarch                                                            104/148
  Verifying        : python3-dnf-plugins-core-4.0.11-1.fc31.noarch                                              105/148
  Verifying        : python3-dnf-plugins-core-4.0.9-1.fc31.noarch                                               106/148
  Verifying        : python3-hawkey-0.37.2-2.fc31.x86_64                                                        107/148
  Verifying        : python3-hawkey-0.35.3-6.fc31.x86_64                                                        108/148
  Verifying        : python3-libdnf-0.37.2-2.fc31.x86_64                                                        109/148
  Verifying        : python3-libdnf-0.35.3-6.fc31.x86_64                                                        110/148
  Verifying        : python3-rpm-4.15.1-1.fc31.x86_64                                                           111/148
  Verifying        : python3-rpm-4.15.0-6.fc31.x86_64                                                           112/148
  Verifying        : redhat-rpm-config-142-1.fc31.noarch                                                        113/148
  Verifying        : redhat-rpm-config-140-2.fc31.noarch                                                        114/148
  Verifying        : rpm-4.15.1-1.fc31.x86_64                                                                   115/148
  Verifying        : rpm-4.15.0-6.fc31.x86_64                                                                   116/148
  Verifying        : rpm-build-4.15.1-1.fc31.x86_64                                                             117/148
  Verifying        : rpm-build-4.15.0-6.fc31.x86_64                                                             118/148
  Verifying        : rpm-build-libs-4.15.1-1.fc31.x86_64                                                        119/148
  Verifying        : rpm-build-libs-4.15.0-6.fc31.x86_64                                                        120/148
  Verifying        : rpm-libs-4.15.1-1.fc31.x86_64                                                              121/148
  Verifying        : rpm-libs-4.15.0-6.fc31.x86_64                                                              122/148
  Verifying        : rpm-sign-libs-4.15.1-1.fc31.x86_64                                                         123/148
  Verifying        : rpm-sign-libs-4.15.0-6.fc31.x86_64                                                         124/148
  Verifying        : shared-mime-info-1.15-1.fc31.x86_64                                                        125/148
  Verifying        : shared-mime-info-1.14-1.fc31.x86_64                                                        126/148
  Verifying        : sudo-1.8.29-1.fc31.x86_64                                                                  127/148
  Verifying        : sudo-1.8.28p1-1.fc31.x86_64                                                                128/148
  Verifying        : systemd-243.4-1.fc31.x86_64                                                                129/148
  Verifying        : systemd-243-4.gitef67743.fc31.x86_64                                                       130/148
  Verifying        : systemd-libs-243.4-1.fc31.x86_64                                                           131/148
  Verifying        : systemd-libs-243-4.gitef67743.fc31.x86_64                                                  132/148
  Verifying        : systemd-pam-243.4-1.fc31.x86_64                                                            133/148
  Verifying        : systemd-pam-243-4.gitef67743.fc31.x86_64                                                   134/148
  Verifying        : systemd-rpm-macros-243.4-1.fc31.noarch                                                     135/148
  Verifying        : systemd-rpm-macros-243-4.gitef67743.fc31.noarch                                            136/148
  Verifying        : vim-common-2:8.1.2352-1.fc31.x86_64                                                        137/148
  Verifying        : vim-common-2:8.1.2198-1.fc31.x86_64                                                        138/148
  Verifying        : vim-enhanced-2:8.1.2352-1.fc31.x86_64                                                      139/148
  Verifying        : vim-enhanced-2:8.1.2198-1.fc31.x86_64                                                      140/148
  Verifying        : vim-filesystem-2:8.1.2352-1.fc31.noarch                                                    141/148
  Verifying        : vim-filesystem-2:8.1.2198-1.fc31.noarch                                                    142/148
  Verifying        : vim-minimal-2:8.1.2352-1.fc31.x86_64                                                       143/148
  Verifying        : vim-minimal-2:8.1.2198-1.fc31.x86_64                                                       144/148
  Verifying        : yum-4.2.15-2.fc31.noarch                                                                   145/148
  Verifying        : yum-4.2.9-5.fc31.noarch                                                                    146/148
  Verifying        : zchunk-libs-1.1.4-1.fc31.x86_64                                                            147/148
  Verifying        : zchunk-libs-1.1.2-3.fc31.x86_64                                                            148/148

Upgraded:
  ImageMagick-1:6.9.10.75-1.fc31.x86_64                      ImageMagick-libs-1:6.9.10.75-1.fc31.x86_64
  NetworkManager-1:1.20.8-1.fc31.x86_64                      NetworkManager-libnm-1:1.20.8-1.fc31.x86_64
  audit-3.0-0.15.20191104git1c2f876.fc31.x86_64              audit-libs-3.0-0.15.20191104git1c2f876.fc31.x86_64
  binutils-2.32-29.fc31.x86_64                               binutils-gold-2.32-29.fc31.x86_64
  crypto-policies-20191002-1.gitc93dc99.fc31.noarch          cryptsetup-libs-2.2.2-1.fc31.x86_64
  device-mapper-1.02.165-1.fc31.x86_64                       device-mapper-libs-1.02.165-1.fc31.x86_64
  dhcp-client-12:4.4.1-19.fc31.x86_64                        dhcp-common-12:4.4.1-19.fc31.noarch
  dnf-4.2.15-2.fc31.noarch                                   dnf-data-4.2.15-2.fc31.noarch
  dnf-plugins-core-4.0.11-1.fc31.noarch                      gd-2.2.5-10.fc31.x86_64
  gdb-minimal-8.3.50.20190824-25.fc31.x86_64                 glib2-2.62.3-1.fc31.x86_64
  glibc-2.30-7.fc31.x86_64                                   glibc-common-2.30-7.fc31.x86_64
  glibc-langpack-en-2.30-7.fc31.x86_64                       glibc-minimal-langpack-2.30-7.fc31.x86_64
  gtk-update-icon-cache-3.24.13-1.fc31.x86_64                gtk2-2.24.32-6.fc31.x86_64
  json-c-0.13.1-7.fc31.x86_64                                libdnf-0.37.2-2.fc31.x86_64
  libedit-3.1-29.20191025cvs.fc31.x86_64                     libgs-9.27-2.fc31.x86_64
  libidn2-2.3.0-1.fc31.x86_64                                libjpeg-turbo-2.0.2-5.fc31.x86_64
  libnghttp2-1.39.2-2.fc31.x86_64                            libpwquality-1.4.2-1.fc31.x86_64
  librepo-1.11.0-1.fc31.x86_64                               libreport-filesystem-2.11.3-1.fc31.noarch
  librsvg2-2.46.4-1.fc31.x86_64                              libseccomp-2.4.2-1.fc31.x86_64
  libsolv-0.7.8-1.fc31.x86_64                                libssh-0.9.2-1.fc31.x86_64
  libssh-config-0.9.2-1.fc31.noarch                          libtiff-4.0.10-7.fc31.x86_64
  libxml2-2.9.10-1.fc31.x86_64                               pcre2-10.33-16.fc31.x86_64
  polkit-libs-0.116-4.fc31.1.x86_64                          python-pip-wheel-19.1.1-5.fc31.noarch
  python3-dnf-4.2.15-2.fc31.noarch                           python3-dnf-plugins-core-4.0.11-1.fc31.noarch
  python3-hawkey-0.37.2-2.fc31.x86_64                        python3-libdnf-0.37.2-2.fc31.x86_64
  python3-rpm-4.15.1-1.fc31.x86_64                           redhat-rpm-config-142-1.fc31.noarch
  rpm-4.15.1-1.fc31.x86_64                                   rpm-build-4.15.1-1.fc31.x86_64
  rpm-build-libs-4.15.1-1.fc31.x86_64                        rpm-libs-4.15.1-1.fc31.x86_64
  rpm-sign-libs-4.15.1-1.fc31.x86_64                         shared-mime-info-1.15-1.fc31.x86_64
  sudo-1.8.29-1.fc31.x86_64                                  systemd-243.4-1.fc31.x86_64
  systemd-libs-243.4-1.fc31.x86_64                           systemd-pam-243.4-1.fc31.x86_64
  systemd-rpm-macros-243.4-1.fc31.noarch                     vim-common-2:8.1.2352-1.fc31.x86_64
  vim-enhanced-2:8.1.2352-1.fc31.x86_64                      vim-filesystem-2:8.1.2352-1.fc31.noarch
  vim-minimal-2:8.1.2352-1.fc31.x86_64                       yum-4.2.15-2.fc31.noarch
  zchunk-libs-1.1.4-1.fc31.x86_64

Installed:
  python3-unbound-1.9.4-1.fc31.x86_64                   rpm-plugin-systemd-inhibit-4.15.1-1.fc31.x86_64
  sqlite-3.30.0-1.fc31.x86_64                           deltarpm-3.6.2-2.fc31.x86_64
  libxcrypt-compat-4.4.10-1.fc31.x86_64                 libxkbcommon-0.8.4-2.fc31.x86_64
  python3-dbus-1.2.8-6.fc31.x86_64                      unbound-libs-1.9.4-1.fc31.x86_64
  xkeyboard-config-2.28-1.fc31.noarch                   libevent-2.1.8-7.fc31.x86_64

Complete!
[yurii@DESKTOP-T9D1TRO ~]$ sudo dnf install bat fd-find
Last metadata expiration check: 0:02:25 ago on Mon 02 Dec 2019 09:28:52 AM MSK.
Dependencies resolved.
========================================================================================================================
 Package                Architecture      Version                                       Repository                 Size
========================================================================================================================
Installing:
 bat                    x86_64            0.11.0-3.module_f31+5338+1c55392b             fedora-modular            1.6 M
 fd-find                x86_64            7.3.0-3.module_f31+5369+677905bc              fedora-modular            799 k
Installing dependencies:
 libssh2                x86_64            1.9.0-3.fc31                                  updates                   119 k
 http-parser            x86_64            2.9.2-2.fc31                                  fedora                     39 k
 libgit2                x86_64            0.28.3-1.fc31                                 fedora                    452 k
Enabling module streams:
 bat                                      latest
 fd-find                                  rolling

Transaction Summary
========================================================================================================================
Install  5 Packages

Total download size: 3.0 M
Installed size: 7.5 M
Is this ok [y/N]: y
Downloading Packages:
(1/5): libssh2-1.9.0-3.fc31.x86_64.rpm                                                   90 kB/s | 119 kB     00:01
(2/5): http-parser-2.9.2-2.fc31.x86_64.rpm                                              158 kB/s |  39 kB     00:00
(3/5): fd-find-7.3.0-3.module_f31+5369+677905bc.x86_64.rpm                              444 kB/s | 799 kB     00:01
(4/5): bat-0.11.0-3.module_f31+5338+1c55392b.x86_64.rpm                                 901 kB/s | 1.6 MB     00:01
(5/5): libgit2-0.28.3-1.fc31.x86_64.rpm                                                 782 kB/s | 452 kB     00:00
------------------------------------------------------------------------------------------------------------------------
Total                                                                                   555 kB/s | 3.0 MB     00:05
Running transaction check
Transaction check succeeded.
Running transaction test
Transaction test succeeded.
Running transaction
RPM: error: db5 error(-30969) from dbenv->open: BDB0091 DB_VERSION_MISMATCH: Database environment version mismatch
RPM: error: cannot open Packages index using db5 -  (-30969)
RPM: error: cannot open Packages database in /var/lib/rpm
The downloaded packages were saved in cache until the next successful transaction.
You can remove cached packages by executing 'dnf clean packages'.
Error: Could not run transaction.

@pjhavariotis

This comment has been minimized.

Copy link

@pjhavariotis pjhavariotis commented Dec 9, 2019

I can confirm the issue on a fresh installation (1.31.6.0). The first dnf update runs to completion, but every other update/install will show the following error:

RPM: error: db5 error(-30969) from dbenv->open: BDB0091 DB_VERSION_MISMATCH: Database environment version mismatch
RPM: error: cannot open Packages index using db5 -  (-30969)
RPM: error: cannot open Packages database in /var/lib/rpm

Winver = 1909 (OS Build 18363.476)

@gtirloni

This comment has been minimized.

Copy link

@gtirloni gtirloni commented Dec 10, 2019

Same here. Latest Win 10 Pro version.

Solution was to remove the lock file (rm /var/lib/rpm/.rpm.lock)

@pjhavariotis

This comment has been minimized.

Copy link

@pjhavariotis pjhavariotis commented Dec 11, 2019

Same here. Latest Win 10 Pro version.

Solution was to remove the lock file (rm /var/lib/rpm/.rpm.lock)

Solution confirmed !

@nickboldt

This comment has been minimized.

Copy link

@nickboldt nickboldt commented Feb 7, 2020

Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment
Projects
None yet
Linked pull requests

Successfully merging a pull request may close this issue.

None yet
You can’t perform that action at this time.