New issue

Have a question about this project? Sign up for a free GitHub account to open an issue and contact its maintainers and the community.

By clicking “Sign up for GitHub”, you agree to our terms of service and privacy statement. We’ll occasionally send you account related emails.

Already on GitHub? Sign in to your account

Bug: server rebuild not changed to yes #257

Closed
Lormen opened this Issue Nov 18, 2015 · 5 comments

Comments

Projects
None yet
2 participants
@Lormen

Lormen commented Nov 18, 2015

Again, only a small issue but I know how annoying it is when people update the same ticket for every issue, makes searching impossible!

If I add an option to a view selecting a single server then the server_build_config or server_update_config field is not updated to 'yes' so the new config cannot be built without forcing an update of the necessary servers.

@WillyXJ

This comment has been minimized.

Owner

WillyXJ commented Nov 18, 2015

On a fresh installation, I just added two servers, created a view, added the SOA and NS records for the localhost zone and associated the view to it, and then performed a config build to clear all flags. Then I went to Config->Views, clicked the view, selected server1 from the drop down, and added an option. After clicking OK, I see in the UI server1 needs a config build and server2 does not.

Are there other steps required to reproduce your report?

@Lormen

This comment has been minimized.

Lormen commented Nov 18, 2015

OK, servers were in a group "group1"
In a view called "internal" select "group1
add options for only group1 in internal
This didn't mention reloading
When I removed the option that I added it did however.

@WillyXJ

This comment has been minimized.

Owner

WillyXJ commented Nov 18, 2015

Got it - thanks! This is reproducible by selecting the server group. This should get fixed for the 2.1 release.

@WillyXJ WillyXJ added this to the 2.x release milestone Nov 18, 2015

@Lormen

This comment has been minimized.

Lormen commented Nov 18, 2015

Excellent :-) Thank you!

WillyXJ added a commit that referenced this issue Nov 19, 2015

fmDNS - #257 - Fixed config build flags
When specifying a server or group override for a config parameter the
appropriate servers would not be flagged for a config build.
@WillyXJ

This comment has been minimized.

Owner

WillyXJ commented Nov 19, 2015

Fixed code submitted for the next release.

@WillyXJ WillyXJ closed this Nov 19, 2015

Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment