New issue

Have a question about this project? Sign up for a free GitHub account to open an issue and contact its maintainers and the community.

By clicking “Sign up for GitHub”, you agree to our terms of service and privacy statement. We’ll occasionally send you account related emails.

Already on GitHub? Sign in to your account

Unable to register DNS server #265

Closed
jovimon opened this Issue Dec 6, 2015 · 1 comment

Comments

Projects
None yet
2 participants
@jovimon

jovimon commented Dec 6, 2015

Hello,
After successful install of the server, I tried to register my DNS server into FacileManager, without success. This is the error I encountered:

# php fmDNS/dns.php install
Welcome to the fmDNS installer.

Please answer the following questions and the necessary configurations will be performed
for you.

Please enter the location of the facileManager interface:
    Examples include:
        fm.mydomain.com
        fm.mydomain.com:8443
        mydomain.com/fm
        http://fm.mydomain.com/facileManager

Please enter the location of the facileManager interface: facileManager.local
  --> Testing dnsmanager.vpen via https...ok
  --> Checking account details...Success

Please enter the serial number for MYSERVER (or leave blank to create new):
  --> Generating new serial number: 490227120
  --> Adding MYSERVER to the database...Could not add server to account.
# 

I have Ubuntu 15.04 and bind9 9.9.5-9ubuntu0.3-Ubuntu (Extended Support Version).
Both facileManager client and server are on the same machine.
Doing some client-side debugging I was able to print_r the data variable that is sent to the server in the https://facileManager.local/admin-servers.php?addserial POST request:

Array
(
    [server_client_version] => 2.1
    [server_os] => Linux
    [server_os_distro] => Ubuntu
    [update_from_client] => 1
    [config] => Array
        (
            [0] => Array
                (
                    [0] => FMHOST
                    [1] => facileManager server
                    [2] => facileManager.local/
                )

            [1] => Array
                (
                    [0] => AUTHKEY
                    [1] => Account number
                    [2] => default
                )

        )

    [compress] => 1
    [AUTHKEY] => default
    [server_name] => MYSERVER 
    [server_serial_no] => 490227120
    [server_run_as_predefined] => bind
    [server_config_file] => /etc/bind/named.conf
    [server_root_dir] => /var/cache/bind
    [server_zones_dir] => /etc/bind/zones
    [server_chroot_dir] =>
    [server_type] => bind9
    [server_version] => 9.9.5-9ubuntu0.3-Ubuntu (Extended Support Version)
)

I also tried running the client with "-d", but can't find any additional logging.

What am I doing wrong?

WillyXJ pushed a commit that referenced this issue Dec 6, 2015

@WillyXJ

This comment has been minimized.

Owner

WillyXJ commented Dec 6, 2015

Thanks for the report that has been confirmed a bug. fmDNS 2.1.1 (server side only) has been released with a fix.

@WillyXJ WillyXJ closed this Dec 6, 2015

Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment