New issue

Have a question about this project? Sign up for a free GitHub account to open an issue and contact its maintainers and the community.

By clicking “Sign up for GitHub”, you agree to our terms of service and privacy statement. We’ll occasionally send you account related emails.

Already on GitHub? Sign in to your account

[ISSUE] wrong SOA records in dump.db import - domain is appended on master server and email address fields #377

Closed
mister-wolf opened this Issue May 29, 2017 · 3 comments

Comments

Projects
None yet
2 participants
@mister-wolf

mister-wolf commented May 29, 2017

fM Version : v3.0-beta2
fmDNS Version : Version 3.0-beta2

In raising this issue, I confirm the following (please check boxes, eg [X]):

  • I have read and understood the contributors guide.
  • I have checked that the bug-fix I am reporting can be replicated, or that the feature I am suggesting isn't already present.
  • I have checked that the issue I'm posting isn't already reported.
  • I have checked that the issue I'm posting isn't already solved and no duplicates exist in closed issues and opened issues
  • I have checked the pull requests tab for existing solutions/implementations to my issue/suggestion.

(ISSUE) Expected Behavior:
When importing a named_dump.db file, SOA records should be correctly parsed.

(BUG | ISSUE) Actual Behavior:
SOA records read from dump are written with domain appendix, e.g.:
domainname.com. IN SOA master.ns.com.domainname.com. master.email.com.domainname.com.

(BUG | ISSUE) Steps to reproduce:
Import a bind named_dump.db - tried on different servers.

PS: is there the possibility to bulk add a SOA template to all zones after zone creation?

Thank you

@mister-wolf mister-wolf changed the title from [ISSUE] to [ISSUE] SOA template will always append domain name regardless of that setting May 29, 2017

@mister-wolf mister-wolf changed the title from [ISSUE] SOA template will always append domain name regardless of that setting to [ISSUE] wrong SOA records in dump.db import - domain is appended on master server and email address fields May 29, 2017

@mister-wolf

This comment has been minimized.

mister-wolf commented May 29, 2017

Just checked the database and SOA records are correctly imported with the trailing dot.

The problem is on field soa_append on table fm_dns_soa, as it was set to YES after import for each row.

WillyXJ pushed a commit that referenced this issue May 30, 2017

@WillyXJ

This comment has been minimized.

Owner

WillyXJ commented May 30, 2017

Thanks for the report. This behavior also exists in 3.0-rc1 and a SOA import should always not append the domain. This will be fixed in the next release.

@WillyXJ

This comment has been minimized.

Owner

WillyXJ commented Jun 23, 2017

This is now fixed in 3.0 and later.

@WillyXJ WillyXJ closed this Jun 23, 2017

Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment