New issue

Have a question about this project? Sign up for a free GitHub account to open an issue and contact its maintainers and the community.

By clicking “Sign up for GitHub”, you agree to our terms of service and privacy statement. We’ll occasionally send you account related emails.

Already on GitHub? Sign in to your account

Duplicate Key error when using Views #40

Closed
bagintz opened this Issue Nov 19, 2013 · 6 comments

Comments

Projects
None yet
2 participants
@bagintz

bagintz commented Nov 19, 2013

Your named configuration contains one or more errors:

/etc/bind/zones/views.conf.keys:3: key 'Key1.': already exists previous definition: /etc/bind/named.conf.keys:3

Here are the relevant items from my config

/etc/bind/named.conf.keys:

// This file was built using fmDNS 1.0-rc6 on Tue, 19 Nov 2013 16:07:46 -0600 America/Chicago

key Key1. {
algorithm hmac-md5;
secret "shhhhitsasecret";
};

/etc/bind/zones/views.conf.keys:

// This file was built using fmDNS 1.0-rc6 on Tue, 19 Nov 2013 16:07:46 -0600 America/Chicago

key Key1. {
algorithm hmac-md5;
secret "shhhhitsasecret";
};

@WillyXJ

This comment has been minimized.

Owner

WillyXJ commented Nov 19, 2013

Thanks for the report.

Just to confirm, this only occurs when views are created and a key is created and assigned for "All Views", correct?

@bagintz

This comment has been minimized.

bagintz commented Nov 19, 2013

I really had it happen when I was trying to use views at all. Let me know
if you want me to try certain things and I will.

Thanks,
Bryan

On Tue, Nov 19, 2013 at 5:16 PM, WillyXJ notifications@github.com wrote:

Thanks for the report.

Just to confirm, this only occurs when views are created and a key is
created and assigned for "All Views", correct?


Reply to this email directly or view it on GitHubhttps://github.com//issues/40#issuecomment-28841754
.

WillyXJ pushed a commit that referenced this issue Nov 20, 2013

@WillyXJ

This comment has been minimized.

Owner

WillyXJ commented Nov 20, 2013

Fix has been checked in. You can either manually update class_buildconf.php from the repo (https://github.com/WillyXJ/facileManager/blob/master/server/fm-modules/fmDNS/classes/class_buildconf.php) to verify or you can wait until the next release.

@bagintz

This comment has been minimized.

bagintz commented Nov 20, 2013

Willy,
I will do that tomorrow, thanks! I will be able to see if I get the same
error, and let you know.

On Tue, Nov 19, 2013 at 7:28 PM, WillyXJ notifications@github.com wrote:

Fix has been checked in. You can either manually update
class_buildconf.php from the repo (
https://github.com/WillyXJ/facileManager/blob/master/server/fm-modules/fmDNS/classes/class_buildconf.php)
to verify or you can wait until the next release.


Reply to this email directly or view it on GitHubhttps://github.com//issues/40#issuecomment-28853328
.

@WillyXJ

This comment has been minimized.

Owner

WillyXJ commented Dec 4, 2013

Hi Bryan,

Have you been able to confirm this fix?

@bagintz

This comment has been minimized.

bagintz commented Dec 4, 2013

Yes,
This worked. Thanks!

On Wed, Dec 4, 2013 at 12:49 PM, WillyXJ notifications@github.com wrote:

Hi Bryan,

Have you been able to confirm this fix?


Reply to this email directly or view it on GitHubhttps://github.com//issues/40#issuecomment-29827833
.

@WillyXJ WillyXJ closed this Dec 4, 2013

Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment