New issue

Have a question about this project? Sign up for a free GitHub account to open an issue and contact its maintainers and the community.

By clicking “Sign up for GitHub”, you agree to our terms of service and privacy statement. We’ll occasionally send you account related emails.

Already on GitHub? Sign in to your account

W2KSP4_EN.EXE no longer available #600

Closed
nifgraup opened this Issue Feb 2, 2016 · 25 comments

Comments

Projects
None yet
@nifgraup
Contributor

nifgraup commented Feb 2, 2016

$ winetricks atmlib
------------------------------------------------------
You are using a 64-bit WINEPREFIX. If you encounter problems, please retest in a clean 32-bit WINEPREFIX before reporting a bug.
------------------------------------------------------
Executing w_do_call atmlib
Executing load_atmlib
Downloading http://download.microsoft.com/download/E/6/A/E6A04295-D2A8-40D0-A0C5-241BFECD095E/W2KSP4_EN.EXE to /home/bjorgvin/.cache/winetricks/win2ksp4
--2016-02-02 19:15:54--  http://download.microsoft.com/download/E/6/A/E6A04295-D2A8-40D0-A0C5-241BFECD095E/W2KSP4_EN.EXE
Resolving download.microsoft.com (download.microsoft.com)... 72.247.86.229, 2001:5002:203:19f::e59, 2001:5002:203:186::e59
Connecting to download.microsoft.com (download.microsoft.com)|72.247.86.229|:80... connected.
HTTP request sent, awaiting response... 404 Not Found
2016-02-02 19:15:55 ERROR 404: Not Found.

------------------------------------------------------
Downloading http://download.microsoft.com/download/E/6/A/E6A04295-D2A8-40D0-A0C5-241BFECD095E/W2KSP4_EN.EXE failed
------------------------------------------------------
@qwertychouskie

This comment has been minimized.

nifgraup added a commit to nifgraup/winetricks that referenced this issue Feb 6, 2016

nifgraup added a commit to nifgraup/winetricks that referenced this issue Feb 6, 2016

@austin987

This comment has been minimized.

Contributor

austin987 commented Feb 19, 2016

Fixed by a5e32a8

@austin987 austin987 closed this Feb 19, 2016

@dangowrt

This comment has been minimized.

dangowrt commented Apr 12, 2016

The download from archive.org keeps failing after about 7megs. Maybe add ftp://ftp.fu-berlin.de/pc/security/ms-patches/win2000/Service_Packs/usa/W2KSP4_EN.EXE to the list of download mirrors?

@austin987

This comment has been minimized.

Contributor

austin987 commented Apr 12, 2016

Please file new bugs for new issues, rather than reusing closed bugs.

That said, I can't reproduce. I've never seen this download fail, and I've been running 'make test' a lot the past few weeks.

Also keep in mind that multiple download mirrors aren't supported for a single download. The original URL is tried, then we fall back to archive.org. Are you sure it's not your ISP? You can use --torify if you're behind a censored one.

@rbreaves

This comment has been minimized.

rbreaves commented Apr 24, 2016

It's an issue for me as well, and I am on suddenlink atm, but I can test it later on a few other ISPs for a more thorough response to this later. I am unfamiliar with the torify flag, but I ran it with that and it's all the same (so unless I need to install tor itself, --torify does nothing for me). I am running Ubuntu 16.04 LTS (in case that matters to anyone).

@austin987

This comment has been minimized.

Contributor

austin987 commented Apr 25, 2016

Again, closed issue, don't use this bug, make your own.

You'll need torify installed for --torify to work (winetricks should warn you if it's not installed).

Of course, you'll need a recent winetricks for that, so make sure you're not using Ubuntu's version, which is ridiculously old and broken.

@giocomai

This comment has been minimized.

giocomai commented Apr 25, 2016

Same issue here, using latest winetricks from github. The link above does not currently work. Not sure it would make sense to open a new issue, as this has not been solved, yet marked as closed. As highlighted above, however, W2KSP4_EN.EXE is available on a number of other mirrors
http://www.filewatcher.com/m/W2KSP4_EN.EXE.135477136-0.html

@austin987

This comment has been minimized.

Contributor

austin987 commented Apr 25, 2016

Someone with this issue, please run with:
winetricks -q -v atmlib &> atmlib.txt
then
winetricks -q --torify -v atmlib &> atmlib_torify.txt

(or whatever verb you were having problems with), and either paste the full logs in two comments, or email them to me.

I suspect these are old versions of winetricks, as it should be falling back to archive.org.

For future reference, when reporting bugs (here, or anywhere), saying 'latest version', isn't helpful, because it doesn't tell us any version at all (you may think you have the latest, you may not, and in any case, 6 months later, no one knows what version you have). For winetricks and most programs, you can use --version to get that info.

@austin987

This comment has been minimized.

Contributor

austin987 commented Apr 26, 2016

Note that I released 20160425 today, so make sure you're running that before getting those logs.

@giocomai

This comment has been minimized.

giocomai commented Apr 26, 2016

Thanks for the suggestion about --version, of course you're absolutely right.

To clarify. Winetricks did fall back on archive.org, but archive.org wouldn't respond, either through wget or via the browser (from the browser, it would say to try again). I waited half an hour, tried again multiple times, and still nothing.
To be absolutely clear, the link suggested above in this thread - http://web.archive.org/web/20160129053851/http://download.microsoft.com/download/E/6/A/E6A04295-D2A8-40D0-A0C5-241BFECD095E/W2KSP4_EN.EXE - wouldn't start a download.

As a workaround, I downloaded the file from one of the other mirrors (http://www.filewatcher.com/m/W2KSP4_EN.EXE.135477136-0.html) and copied the .exe file into /home/USER/.cache/winetricks/win2ksp4, then run again the script and all went smoothly.

Tried again now (10 hours later) and all works fine, i.e. the link above on archive.org works just fine from both wget and browser.

In brief, this is an archive.org issue. Perhaps adding a second fallback option may be of help.

@Diogovmm

This comment has been minimized.

Diogovmm commented Jul 29, 2016

I have the exact same problem but when I try to execute the file it says service "pack 4 setup error: Setup cannot update your windows files because the language installed on your system is different from the update language"
What should I do?

@austin987

This comment has been minimized.

Contributor

austin987 commented Jul 29, 2016

Trying to run that exe has nothing at all to do with winetricks. Winetricks only uses it for extracting files from.

Friendly reminder, this is a closed issue.

@Diogovmm

This comment has been minimized.

Diogovmm commented Jul 29, 2016

I know it is closed and sorry if I should not post this here.
I posted because it is the only post I found with the same problem with me and solved it. I have posted on 2 other places and no one helps me I don't know what to do. I started using Linux for about 6-7 days now, trying to get this to work since the beginning...
Can you please help me?

@austin987

This comment has been minimized.

Contributor

austin987 commented Jul 29, 2016

I'm not clear at all what you're trying to do

On Jul 29, 2016 12:55, "Diogovmm" notifications@github.com wrote:

I know it is closed and sorry if I should not post this here.
I posted because it is the only post I found with the same problem with me
and solved it. I have posted on 2 other places and no one helps me I don't
know what to do. I started using Linux for about 6-7 days now, trying to
get this to work since the beginning...
Can you please help me?


You are receiving this because you modified the open/close state.
Reply to this email directly, view it on GitHub
#600 (comment),
or mute the thread
https://github.com/notifications/unsubscribe-auth/AAcXCOp05pWhxZBo4EDOOk5lB6mO5h8Cks5qaj57gaJpZM4HRrJf
.

@Diogovmm

This comment has been minimized.

Diogovmm commented Jul 29, 2016

I'm trying to get playonlinux and wine to work with blizzard games- hearthstone and heroes of the storm (Hots). when I try to run Hots I get this:
[07/29/16 17:43:37] - Running wine-1.9.10 wineboot (Working directory : /usr/share/playonlinux/python)
err:module:import_dll Library dbghelp.dll (which is needed by L"C:\windows\system32\mscoree.dll") not found
fixme:dwmapi:DwmIsCompositionEnabled 0x6d2ed8b8
fixme:iphlpapi:NotifyIpInterfaceChange (family 0, callback 0x6a0a6836, context 0x82dea8, init_notify 0, handle 0x113e7d4): stub
wine: configuration in '/home/xut/.PlayOnLinux/wineprefix/heroes_of_the_storm' has been updated.
[07/29/16 17:44:03] - Running wine-1.9.10 wineboot (Working directory : /usr/share/playonlinux/python)
[07/29/16 17:44:21] - Running wine-1.9.10 Battle.net Launcher.exe (Working directory : /home/xut/.PlayOnLinux/wineprefix/heroes_of_the_storm/drive_c/Program Files/Battle.net)
fixme:heap:RtlSetHeapInformation (nil) 1 (nil) 0 stub
fixme:winhttp:get_system_proxy_autoconfig_url no support on this platform
fixme:winhttp:WinHttpDetectAutoProxyConfigUrl discovery via DHCP not supported
fixme:winhttp:get_system_proxy_autoconfig_url no support on this platform
fixme:wininet:InternetSetOptionW Option 77 STUB
err:wininet:open_http_connection create_netconn failed: 12029
fixme:ver:GetCurrentPackageId (0x456ea08 (nil)): stub
fixme:wininet:InternetSetOptionW Option 77 STUB
err:wininet:open_http_connection create_netconn failed: 12029
fixme:wininet:InternetSetOptionW Option 77 STUB
err:wininet:open_http_connection create_netconn failed: 12029
fixme:winhttp:get_system_proxy_autoconfig_url no support on this platform
fixme:wininet:InternetSetOptionW Option 77 STUB
err:wininet:open_http_connection create_netconn failed: 12029
fixme:ver:GetCurrentPackageId (0x49bea08 (nil)): stub
fixme:wininet:InternetSetOptionW Option 77 STUB
err:wininet:open_http_connection create_netconn failed: 12029
fixme:wininet:InternetSetOptionW Option 77 STUB
err:wininet:open_http_connection create_netconn failed: 12029
fixme:win:EnumDisplayDevicesW ((null),0,0x33f578,0x00000000), stub!
fixme:wbemprox:wbem_locator_ConnectServer unsupported flags
fixme:wbemprox:client_security_SetBlanket 0x7dbffba8, 0x171f88, 10, 0, (null), 3, 3, (nil), 0x00000000
fixme:wbemprox:client_security_Release 0x7dbffba8
fixme:wininet:InternetSetOptionW Option 77 STUB
fixme:winhttp:get_system_proxy_autoconfig_url no support on this platform
fixme:winhttp:WinHttpDetectAutoProxyConfigUrl discovery via DHCP not supported
fixme:wbemprox:enum_class_object_Next timeout not supported
fixme:winhttp:get_system_proxy_autoconfig_url no support on this platform
fixme:ver:GetCurrentPackageId (0x456ea08 (nil)): stub
fixme:winhttp:get_system_proxy_autoconfig_url no support on this platform
fixme:module:load_library unsupported flag(s) used (flags: 0x00000800)
fixme:module:load_library unsupported flag(s) used (flags: 0x00000800)
fixme:module:load_library unsupported flag(s) used (flags: 0x00000800)
fixme:module:load_library unsupported flag(s) used (flags: 0x00000800)
fixme:module:load_library unsupported flag(s) used (flags: 0x00000800)
fixme:winhttp:get_system_proxy_autoconfig_url no support on this platform
fixme:module:load_library unsupported flag(s) used (flags: 0x00000800)
fixme:module:load_library unsupported flag(s) used (flags: 0x00000800)
wine: Call from 0x7b43fb52 to unimplemented function api-ms-win-crt-locale-l1-1-0.dll._lock_locales, aborting
err:module:attach_process_dlls "MSVCP140.dll" failed to initialize, aborting
err:module:LdrInitializeThunk Main exe initialization for L"C:\Program Files\Battle.net\Battle.net.7730\Battle.net.exe" failed, status 80000100
fixme:winhttp:get_system_proxy_autoconfig_url no support on this platform

<title>Object moved</title>

Object moved to here.

<title>Object moved</title>

Object moved to here.

<title>Object moved</title>

Object moved to here.

fixme:winhttp:get_system_proxy_autoconfig_url no support on this platform
fixme:winhttp:get_system_proxy_autoconfig_url no support on this platform
fixme:winhttp:get_system_proxy_autoconfig_url no support on this platform
fixme:winhttp:get_system_proxy_autoconfig_url no support on this platform
fixme:winhttp:get_system_proxy_autoconfig_url no support on this platform
fixme:winhttp:get_system_proxy_autoconfig_url no support on this platform
fixme:winhttp:get_system_proxy_autoconfig_url no support on this platform
fixme:winhttp:get_system_proxy_autoconfig_url no support on this platform
fixme:winhttp:get_system_proxy_autoconfig_url no support on this platform
fixme:winhttp:get_system_proxy_autoconfig_url no support on this platform
fixme:winhttp:get_system_proxy_autoconfig_url no support on this platform
[07/29/16 17:49:06] - ----- Starting function POL_Install_wininet -----
[07/29/16 18:58:50] - Running wine-1.9.10 Battle.net Launcher.exe (Working directory : /home/xut/.PlayOnLinux/wineprefix/heroes_of_the_storm/drive_c/Program Files/Battle.net)
fixme:heap:RtlSetHeapInformation (nil) 1 (nil) 0 stub
fixme:winhttp:get_system_proxy_autoconfig_url no support on this platform
fixme:winhttp:WinHttpDetectAutoProxyConfigUrl discovery via DHCP not supported
fixme:winhttp:get_system_proxy_autoconfig_url no support on this platform
fixme:wininet:InternetSetOptionW Option 77 STUB
err:wininet:open_http_connection create_netconn failed: 12029
fixme:ver:GetCurrentPackageId (0x456ea08 (nil)): stub
fixme:wininet:InternetSetOptionW Option 77 STUB
err:wininet:open_http_connection create_netconn failed: 12029
fixme:wininet:InternetSetOptionW Option 77 STUB
err:wininet:open_http_connection create_netconn failed: 12029
fixme:winhttp:get_system_proxy_autoconfig_url no support on this platform
fixme:wininet:InternetSetOptionW Option 77 STUB
err:wininet:open_http_connection create_netconn failed: 12029
fixme:ver:GetCurrentPackageId (0x49bea08 (nil)): stub
fixme:wininet:InternetSetOptionW Option 77 STUB
err:wininet:open_http_connection create_netconn failed: 12029
fixme:wininet:InternetSetOptionW Option 77 STUB
err:wininet:open_http_connection create_netconn failed: 12029
fixme:win:EnumDisplayDevicesW ((null),0,0x33f578,0x00000000), stub!
fixme:wbemprox:wbem_locator_ConnectServer unsupported flags
fixme:wbemprox:client_security_SetBlanket 0x7dbffba8, 0x172008, 10, 0, (null), 3, 3, (nil), 0x00000000
fixme:wbemprox:client_security_Release 0x7dbffba8
fixme:wininet:InternetSetOptionW Option 77 STUB
fixme:winhttp:get_system_proxy_autoconfig_url no support on this platform
fixme:winhttp:WinHttpDetectAutoProxyConfigUrl discovery via DHCP not supported
fixme:wbemprox:enum_class_object_Next timeout not supported
fixme:winhttp:get_system_proxy_autoconfig_url no support on this platform
fixme:winhttp:get_system_proxy_autoconfig_url no support on this platform
fixme:ver:GetCurrentPackageId (0x456ea08 (nil)): stub
fixme:module:load_library unsupported flag(s) used (flags: 0x00000800)
fixme:module:load_library unsupported flag(s) used (flags: 0x00000800)
fixme:module:load_library unsupported flag(s) used (flags: 0x00000800)
fixme:module:load_library unsupported flag(s) used (flags: 0x00000800)
fixme:module:load_library unsupported flag(s) used (flags: 0x00000800)
fixme:winhttp:get_system_proxy_autoconfig_url no support on this platform
fixme:module:load_library unsupported flag(s) used (flags: 0x00000800)
fixme:module:load_library unsupported flag(s) used (flags: 0x00000800)
wine: Call from 0x7b43fb52 to unimplemented function api-ms-win-crt-locale-l1-1-0.dll._lock_locales, aborting
err:module:attach_process_dlls "MSVCP140.dll" failed to initialize, aborting
err:module:LdrInitializeThunk Main exe initialization for L"C:\Program Files\Battle.net\Battle.net.7730\Battle.net.exe" failed, status 80000100

<title>Object moved</title>

Object moved to here.

<title>Object moved</title>

Object moved to here.

<title>Object moved</title>

Object moved to here.

fixme:winhttp:get_system_proxy_autoconfig_url no support on this platform
fixme:winhttp:get_system_proxy_autoconfig_url no support on this platform
fixme:winhttp:get_system_proxy_autoconfig_url no support on this platform
fixme:winhttp:get_system_proxy_autoconfig_url no support on this platform
fixme:winhttp:get_system_proxy_autoconfig_url no support on this platform
fixme:winhttp:get_system_proxy_autoconfig_url no support on this platform
fixme:winhttp:get_system_proxy_autoconfig_url no support on this platform
fixme:winhttp:get_system_proxy_autoconfig_url no support on this platform
fixme:winhttp:get_system_proxy_autoconfig_url no support on this platform
fixme:winhttp:get_system_proxy_autoconfig_url no support on this platform
fixme:winhttp:get_system_proxy_autoconfig_url no support on this platform
fixme:winhttp:get_system_proxy_autoconfig_url no support on this platform

So I think it is because of wininet and winhttp. Now when I try to install them on POL it says "Error ! Files mismatch" "Error in POL_Download_Resource
MD5 sum mismatch ! (1 attempt)".

Following this post I though I should download W2KSP4.exe mannually and execute at home/USER/.cache/winetricks/win2ksp4 ; this because I used to get an error in wine when I tried to install wininet and winhttp (instead of at POL). I have installed and reistalled many times now both wine and POL. I have POL version 4.2.10; wine 1.8; Ubunto 16.04.1 LTS Xenial

@Diogovmm

This comment has been minimized.

Diogovmm commented Jul 30, 2016

Fixed by a5e32a8

I copied the script mentioned there to my desktop and tried to run it but can't, even with sudo ./name
Is it supposed to fix the issue? if so, how should I run it?

@austin987

This comment has been minimized.

Contributor

austin987 commented Jul 30, 2016

On Jul 29, 2016 10:51 PM, "Diogovmm" notifications@github.com wrote:

Fixed by a5e32a8

I copied the script mentioned there to my desktop and tried to run it but
can't, even with sudo ./name
Is it supposed to fix the issue? if so, how should I run it?

See https://bugs.winehq.org/show_bug.cgi?id=39663#c5

PlayOnLinux's forum may be able to provide more help. A couple more notes:

  • don't run winetricks, or wine, as root/sudo
  • windows service packs aren't meant to be used under wine
  • ./winetricks should work, but you probably need to chmod +x if you
    downloaded from the Internet

It sounds like there is a legit big in that winetricks should set more
overrides for vcrun2015, but that needs its own bug if anyone wants it
fixed.

@samrocketman

This comment has been minimized.

samrocketman commented Nov 5, 2016

I have checked out the latest master of winetricks and installed it. d1c3d3f

I still get this exact error. Why was this closed as resolved?

@makefile

This comment has been minimized.

makefile commented Nov 18, 2016

find a good download url:http://x3270.bgp.nu/download/specials/W2KSP4_EN.EXE

@MetaiR

This comment has been minimized.

MetaiR commented Apr 2, 2017

has a problem on wine 2.4
image

@austin987

This comment has been minimized.

Contributor

austin987 commented Apr 3, 2017

@MetaiR the wine version is irrelevant, your winetricks is very outdated.

@MetaiR

This comment has been minimized.

MetaiR commented Apr 3, 2017

@austin987
how should I update it?

@austin987

This comment has been minimized.

Contributor

austin987 commented Apr 3, 2017

https://wiki.winehq.org/Winetricks#Installing_winetricks

You could use --self-update, but your version may be too old for that.

If you got winetricks from your distribution, ask them to update it.

@ritviksharma24

This comment has been minimized.

ritviksharma24 commented Aug 15, 2017

Hi, I've noticed the difficulty in downloading W2KSP4_EN.EXE , so I downloaded one painfully after 4 hours of troubles, and uploaded it to Google drive, download from here:

https://drive.google.com/open?id=0B-q4OkYnpl0XMW5FMjRPd2ZFVlE

@Nic30

This comment has been minimized.

Nic30 commented Sep 2, 2017

same for me

Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment