Browse files

Base.java: remove initRequirements().

Unused, and incorrect for JDK 1.7.

Signed-off-by: Marti Bolivar <mbolivar@leaflabs.com>
  • Loading branch information...
1 parent 28fa308 commit 7585e6b6b6458b14f7d22607f58fee7210b11fe8 @mbolivar mbolivar committed Nov 9, 2011
Showing with 0 additions and 17 deletions.
  1. +0 −17 IDE/processing/app/Base.java
View
17 IDE/processing/app/Base.java
@@ -141,9 +141,6 @@ static private void createAndShowGUI(String[] args) {
// Don't put anything above this line that might make GUI,
// because the platform has to be inited properly first.
- // Make sure a full JDK is installed
- //initRequirements();
-
// run static initialization that grabs all the prefs
Preferences.init(null);
@@ -198,20 +195,6 @@ static public void initPlatform() {
}
}
-
- static protected void initRequirements() {
- try {
- Class.forName("com.sun.jdi.VirtualMachine");
- } catch (ClassNotFoundException cnfe) {
- Base.showPlatforms();
- Base.showError("Please install JRE 1.5 or later",
- "Wiring requires a JRE\n" +
- "to run. Please install JRE 1.5 or later.\n" +
- "More information can be found in the reference.", cnfe);
- }
- }
-
-
public Base(String[] args) {
// Get paths for the libraries and examples in the Processing folder
//String workingDirectory = System.getProperty("user.dir");

0 comments on commit 7585e6b

Please sign in to comment.