Skip to content

HTTPS clone URL

Subversion checkout URL

You can clone with HTTPS or Subversion.

Download ZIP

Loading…

Internal references depend on external setup #3

Closed
OrangeDog opened this Issue · 2 comments

2 participants

@OrangeDog

For example, bunzipstream.js has require('gzbz2') instead of the portable require('./build/default/gzbz2').

@Woodya
Owner

not sure what you mean here. you have to install the module for those files to work.
i may be missing something or misunderstanding 'require', but the require statement you've suggested doesn't work once you have installed the module..?

@Woodya Woodya closed this
@OrangeDog

Some people don't use npm, or install using NODE_PATH or node_modules.

All other modules I've used would also allow you to require them thus: var gzbz2 = require('../lib/gzbz2'). That is, their package layout provides a clean and stand-alone abstraction..

Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment
Something went wrong with that request. Please try again.