Skip to content
New issue

Have a question about this project? Sign up for a free GitHub account to open an issue and contact its maintainers and the community.

By clicking “Sign up for GitHub”, you agree to our terms of service and privacy statement. We’ll occasionally send you account related emails.

Already on GitHub? Sign in to your account

When use IME, The conversion of the first character is automatically determined. #11813

Closed
torounit opened this issue Nov 13, 2018 · 9 comments
Closed

Comments

@torounit
Copy link
Member

torounit commented Nov 13, 2018

Describe the bug
Related #11795
When use IME, The conversion of the first character is automatically determined.

This problem occurs in the component using <RichText> .

To Reproduce
Steps to reproduce the behavior:

  1. Create new post.
  2. Input text.
  3. Delete text.
  4. Re-Input Text.

Screenshots

output

Desktop (please complete the following information):

  • OS: OS X 10.14.1
  • Browser Chrome
  • Version 70
@designsimply designsimply added [Type] Bug An existing feature is broken. Internationalization (i18n) [Feature] Rich Text Needs Testing Issues that need to be confirmed. labels Nov 13, 2018
@torounit
Copy link
Member Author

torounit commented Nov 14, 2018

This issue occur after 4741104

@miminari
Copy link
Member

miminari commented Nov 14, 2018

I'm afraid that it may be quite troublesome in Japanese and the other non-latin languages.
It occurs in my environment.

  • OS: OS X 10.12.6
  • Browser: Chrome ( Version 70.0.3538.77 )
  • IME: Google IME or OS Default

@atachibana
Copy link
Contributor

atachibana commented Nov 14, 2018

I verified it on Windows 10, and Chrome caused the same issue for both Google IME and MS IME.
Edge was OK for both IMEs.

Windows 10 Pro Japanese
Google IME and/or MS-IME
Chrome 70.0.3538.77
Edge 42.17134.1.0

@waviaei
Copy link
Contributor

waviaei commented Nov 15, 2018

I find it unstable -- I was able to reproduce yesterday, but not today. But #11795 , I can always reproduce, and I guess it is related.

  • OS: macOS High Sierra
  • Browser Firefox
  • Version 63.0.1

I use 5.0-beta4-43896.
Only plugin activated is the Beta Tester.

@ellatrix
Copy link
Member

ellatrix commented Nov 15, 2018

@torounit Would you be able to test #11908 to see if the issue still occurs? It's just an attempt, but maybe it works. Thanks a lot!

@ellatrix
Copy link
Member

ellatrix commented Nov 15, 2018

@torounit Updated the branch. The first commit only wouldn't work properly.

@ellatrix
Copy link
Member

ellatrix commented Nov 15, 2018

gutenberg.zip

The plugin zip if it makes testing easier.

@mongonta0716
Copy link

mongonta0716 commented Nov 15, 2018

I am testing it easily on Windows 10.

Japanese can now be entered, but after fixing the sentence, pressing BS-Key will cause the block to disappear.

Blocks disappear only in Firefox and Chrome.
Edge has no problem.
In Edge, pressing BS-Key will only delete one character.

@mtias mtias added this to the WordPress 5.0 RC milestone Nov 15, 2018
@ellatrix
Copy link
Member

ellatrix commented Nov 15, 2018

Fixed by #11908.

Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment
Projects
None yet
Development

No branches or pull requests

8 participants