New issue

Have a question about this project? Sign up for a free GitHub account to open an issue and contact its maintainers and the community.

By clicking “Sign up for GitHub”, you agree to our terms of service and privacy statement. We’ll occasionally send you account related emails.

Already on GitHub? Sign in to your account

Gallery: add missing options to inspector #1448

Closed
mtias opened this Issue Jun 26, 2017 · 10 comments

Comments

Projects
5 participants
@mtias
Contributor

mtias commented Jun 26, 2017

There are a few items we should preserve on the inspector, like linking to the attachment view of an image. Not sure how many of these we want to consider.

@jasmussen

This comment has been minimized.

Show comment
Hide comment
@jasmussen

jasmussen Jun 26, 2017

Contributor

Also, we want to find a way to improve the cropping of thumbnails somehow. The current arbitrary height images isn't the most visually pleasing. Perhaps a soft-crop using object-fit.

Edit: Ah, I see you have #1449 for that.

Contributor

jasmussen commented Jun 26, 2017

Also, we want to find a way to improve the cropping of thumbnails somehow. The current arbitrary height images isn't the most visually pleasing. Perhaps a soft-crop using object-fit.

Edit: Ah, I see you have #1449 for that.

@mtias mtias added the Media label Jun 29, 2017

@westonruter

This comment has been minimized.

Show comment
Hide comment
@westonruter

westonruter Jul 9, 2017

Member

Whatever options are chosen, they should align with the Gallery widget that is now in development (and vice versa): xwp/wp-core-media-widgets#120

Member

westonruter commented Jul 9, 2017

Whatever options are chosen, they should align with the Gallery widget that is now in development (and vice versa): xwp/wp-core-media-widgets#120

@jasmussen

This comment has been minimized.

Show comment
Hide comment
@jasmussen

jasmussen Jul 26, 2017

Contributor

For reference, these are the options in the current gallery:

screen shot 2017-07-26 at 11 32 22

By the way @mkaz it looks like in master, this button...

screen shot 2017-07-26 at 11 33 45

is broken ...

screen shot 2017-07-26 at 11 33 57

... but only on the demo content. Is that because it's demo content, or is there a deeper underlying issue?

Contributor

jasmussen commented Jul 26, 2017

For reference, these are the options in the current gallery:

screen shot 2017-07-26 at 11 32 22

By the way @mkaz it looks like in master, this button...

screen shot 2017-07-26 at 11 33 45

is broken ...

screen shot 2017-07-26 at 11 33 57

... but only on the demo content. Is that because it's demo content, or is there a deeper underlying issue?

@westonruter

This comment has been minimized.

Show comment
Hide comment
@westonruter

westonruter Jul 28, 2017

Member

AFAIK, the edit button doesn't work in the demo gallery because the demo content doesn't refer to any attachments in the media library. The images are just hard-coded. So since there are no attachment IDs, there is nothing to find in the Edit Gallery frame. A way to fix this would be to construct the gallery dynamically out of a couple random images in the media library, but that would depend on there being images to begin with and also to hope they would look good in a gallery.

Member

westonruter commented Jul 28, 2017

AFAIK, the edit button doesn't work in the demo gallery because the demo content doesn't refer to any attachments in the media library. The images are just hard-coded. So since there are no attachment IDs, there is nothing to find in the Edit Gallery frame. A way to fix this would be to construct the gallery dynamically out of a couple random images in the media library, but that would depend on there being images to begin with and also to hope they would look good in a gallery.

@mkaz

This comment has been minimized.

Show comment
Hide comment
@mkaz

mkaz Jul 31, 2017

Member

As of right now the gallery modals require a fair amount of data to be stored, including the thumbnail images to display properly on edit. There is issue #1986 to address the but then will require an attachment id # for it to work properly, which I'm not sure will work with demo content since it probably can't be hard-coded

Member

mkaz commented Jul 31, 2017

As of right now the gallery modals require a fair amount of data to be stored, including the thumbnail images to display properly on edit. There is issue #1986 to address the but then will require an attachment id # for it to work properly, which I'm not sure will work with demo content since it probably can't be hard-coded

@jasmussen

This comment has been minimized.

Show comment
Hide comment
@jasmussen

jasmussen Aug 1, 2017

Contributor

Since we know for a fact that the demo content will go away at some point, it doesn't seem worth it to jump through hoops to make sure it works perfectly in every situation. In fact you could argue that a "fix" would be to not show the gallery at all — perhaps we could show a placeholder instead?

Contributor

jasmussen commented Aug 1, 2017

Since we know for a fact that the demo content will go away at some point, it doesn't seem worth it to jump through hoops to make sure it works perfectly in every situation. In fact you could argue that a "fix" would be to not show the gallery at all — perhaps we could show a placeholder instead?

@mtias

This comment has been minimized.

Show comment
Hide comment
@mtias

mtias Aug 1, 2017

Contributor

In fact you could argue that a "fix" would be to not show the gallery at all — perhaps we could show a placeholder instead?

I think being able to have galleries with media that is not in your library is still a good thing.

Contributor

mtias commented Aug 1, 2017

In fact you could argue that a "fix" would be to not show the gallery at all — perhaps we could show a placeholder instead?

I think being able to have galleries with media that is not in your library is still a good thing.

@jasmussen

This comment has been minimized.

Show comment
Hide comment
@jasmussen

jasmussen Aug 1, 2017

Contributor

I think being able to have galleries with media that is not in your library is still a good thing.

Ah, I missed that bit. Yeah absolutely.

Contributor

jasmussen commented Aug 1, 2017

I think being able to have galleries with media that is not in your library is still a good thing.

Ah, I missed that bit. Yeah absolutely.

@mtias

This comment has been minimized.

Show comment
Hide comment
@mtias

mtias Aug 3, 2017

Contributor

That said, definitely not something to prioritize.

Contributor

mtias commented Aug 3, 2017

That said, definitely not something to prioritize.

@mtias

This comment has been minimized.

Show comment
Hide comment
@mtias

mtias Aug 4, 2017

Contributor

Let's close this one as we have issues for adding the "link to" option and the thumbnail size: #1450

Contributor

mtias commented Aug 4, 2017

Let's close this one as we have issues for adding the "link to" option and the thumbnail size: #1450

@mtias mtias closed this Aug 4, 2017

@kopepasah kopepasah moved this from Backlog to Done in Blocks Aug 9, 2017

Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment