New issue

Have a question about this project? Sign up for a free GitHub account to open an issue and contact its maintainers and the community.

By clicking “Sign up for GitHub”, you agree to our terms of service and privacy statement. We’ll occasionally send you account related emails.

Already on GitHub? Sign in to your account

Tests: add e2e test for invalid blocks #11814

Merged
merged 1 commit into from Nov 14, 2018

Conversation

Projects
None yet
2 participants
@johngodley
Contributor

johngodley commented Nov 13, 2018

Adds an e2e test for invalid blocks.

Tests that the invalid block warning appears and that buttons are clickable. This should cover the issue fixed in #11768

How has this been tested?

The automated tests in this PR show the test works.

To show the test detects the problem in #11768 you will need to do a bit of juggling:

  1. Run test against c206d07 (the last commit before the fix in #11768)
  2. Verify that the test fails

1__john_imac____sites_personal_wp_plugins_gutenberg__zsh_

Add e2e test for invalid blocks
Test that the invalid block warning appears and that buttons are clickable. Should cover the issue fixed in #11768
@johngodley

This comment has been minimized.

Contributor

johngodley commented Nov 13, 2018

This is my first e2e test and there's a lot of copy/pasting going on. It seems... fiddly. Appreciate any tips for improvements

@tofumatt

This is my first e2e test and there's a lot of copy/pasting going on. It seems... fiddly. Appreciate any tips for improvements

That's generally how I write them too 😉; this looks solid to me.

Very nice, thanks!

@johngodley johngodley added this to the 4.4 milestone Nov 14, 2018

@johngodley johngodley merged commit d63ed47 into master Nov 14, 2018

1 check passed

continuous-integration/travis-ci/pr The Travis CI build passed
Details

@johngodley johngodley deleted the add/invalid-block-e2e-test branch Nov 14, 2018

grey-rsi pushed a commit to OnTheGoSystems/gutenberg that referenced this pull request Nov 22, 2018

Add e2e test for invalid blocks (WordPress#11814)
Test that the invalid block warning appears and that buttons are clickable. Should cover the issue fixed in WordPress#11768
Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment