New issue

Have a question about this project? Sign up for a free GitHub account to open an issue and contact its maintainers and the community.

By clicking “Sign up for GitHub”, you agree to our terms of service and privacy statement. We’ll occasionally send you account related emails.

Already on GitHub? Sign in to your account

Plugin: Bump minimum required WordPress version to 5.x #13370

Merged
merged 1 commit into from Jan 23, 2019

Conversation

Projects
3 participants
@aduth
Copy link
Member

aduth commented Jan 18, 2019

Related: #11015

This pull request seeks to change the minimum required WordPress version from 4.9.8 to 5.0.0 . This is a prerequisite to subsequent pull requests which will remove redundant PHP code to fall back to that which is provided by core itself, in an effort to (a) keep the code of the plugin focused, (b) reduce inconsistencies between the plugin and core, and (c) validate core extensibility through plugin use. See also #11015.

Maintainer Note: This will require a corresponding update to the plugin SVN repository in the plugin release following this merge. Specifically, the "Requires at least" field of readme.txt should be changed to 5.0.0.

Testing instructions:

You could use a downgrading plugin such as WP Downgrade to verify that Gutenberg deactivates itself with a WordPress 4.9.x installation.

@youknowriad
Copy link
Contributor

youknowriad left a comment

LGTM

I think you need to rebase to make the unit tests pass.

@aduth aduth force-pushed the update/minimum-version-5-0 branch from c3d961c to f17207c Jan 22, 2019

@aduth aduth merged commit 60bd2a5 into master Jan 23, 2019

1 check passed

continuous-integration/travis-ci/pr The Travis CI build passed
Details

@aduth aduth deleted the update/minimum-version-5-0 branch Jan 23, 2019

@aduth aduth added this to Done in Remove PHP Jan 23, 2019

@swissspidy

This comment has been minimized.

Copy link
Member

swissspidy commented Jan 24, 2019

FWIW: If we make the version number a %s placeholder translators wouldn't have to update translations for that string every time.

@aduth

This comment has been minimized.

Copy link
Member Author

aduth commented Jan 24, 2019

Sounds like a good idea, @swissspidy !

daniloercoli added a commit that referenced this pull request Jan 24, 2019

Merge branch 'master' of https://github.com/WordPress/gutenberg into …
…rnmobile/372-add-title-to-gutenberg-mobile

* 'master' of https://github.com/WordPress/gutenberg: (56 commits)
  Save package-lock.json file changes (#13481)
  Plugin: Deprecate gutenberg_add_responsive_body_class (#13461)
  Add speak messages to the feature toggle component. (#13385)
  Plugin: Deprecate gutenberg_kses_allowedtags (#13460)
  Plugin: Deprecate gutenberg_bulk_post_updated_messages (#13472)
  Plugin: Avoid calling deprecated gutenberg_silence_rest_errors (#13446)
  Plugin: Deprecate gutenberg_remove_wpcom_markdown_support (#13473)
  Fix: Categories block: add custom classes only to wrapper (#13439)
  is-shallow-equal: Use ES5 ruleset from eslint-plugin module (#13428)
  Update and Organize Contributors Guide per #12916 (#13352)
  Dismissible-notices: fix text overlapping icon (X) (#13371)
  Framework: Remove 5.0-merged REST API integrations (#13408)
  Plugin: Remove 5.0-merged block registration functions, integrations (#13412)
  Framework: Bump minimum required WP to 5.x (#13370)
  [Mobile] Improve keyboard hide button (#13415)
  Improve castError handling of non strings (#13315)
  Fix: File block add custom class (#13432)
  Consider making Fullscreen Mode effects visible only on larger screens (#13425)
  Update plugin version to 4.9.0 (#13436)
  DateTimePicker: fix prop warning for (#12933)
  ...

@youknowriad youknowriad added this to the 5.0 (Gutenberg) milestone Feb 4, 2019

Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment