Skip to content
New issue

Have a question about this project? Sign up for a free GitHub account to open an issue and contact its maintainers and the community.

By clicking “Sign up for GitHub”, you agree to our terms of service and privacy statement. We’ll occasionally send you account related emails.

Already on GitHub? Sign in to your account

Increase WordPress minimum to 5.2.0 #15809

Merged
merged 3 commits into from Nov 12, 2019
Merged

Increase WordPress minimum to 5.2.0 #15809

merged 3 commits into from Nov 12, 2019

Conversation

@Soean
Copy link
Member

Soean commented May 24, 2019

Description

In WordPress 5.2 the PHP minimum was updated to PHP 5.6.20.

Gutenberg is a feature Plugin for WordPress development. We should set WordPress 5.2 as minimum, so we can remove old PHP compatibility code and tests for old versions.

Related #15796 and #15806

@youknowriad

This comment has been minimized.

Copy link
Contributor

youknowriad commented May 24, 2019

We discussed this a little bit here #15565 and there seemed to be an agreement to use 5.1 as a minimum for the moment. What do everyone thinks about moving directly to 5.2. It probably doesn't hurt to wait a few more weeks.

cc @jeremyfelt @aduth @WordPress/gutenberg-core

@nerrad

This comment has been minimized.

Copy link
Contributor

nerrad commented May 24, 2019

Having usage stats on what wp versions people are using would be helpful here.

With that said, I think its a reasonable assumption that most folks using the plugin understand what it is and are more likely to be on the latest WordPress (or wouldn't have to much issue with getting on the latest WordPress).

@Soean

This comment has been minimized.

Copy link
Member Author

Soean commented May 24, 2019

Thanks for your feedback.

I understand that we should not increase the minimum too early. But it should also be a goal that users update their WordPress version promptly and don't remain on the same version. If users update their plugins, they are also able to update their WordPress Core.

Yoast recently released a blog post about this topic, in the future they only support the current and the previous major WP version.

This is a feature plugin, so I think we can update the minimum supported version maybe even faster.

Gutenberg 5.9 would be June 12th. (More than a month after WordPress 5.2) or we wait for Gutenberg 6.0 after WordCamp Europe?

@aduth

This comment has been minimized.

Copy link
Member

aduth commented May 24, 2019

Yoast recently released a blog post about this topic, in the future they only support the current and the previous major WP version.

A takeaway I like from this is to have a policy about it, so it's known and predictable.

It's unclear what benefit there is in waiting? Or in supporting older versions at all? Conversely, there is some benefit in not waiting, as noted by referenced issues of the original comment (removing "baggage").

@youknowriad

This comment has been minimized.

Copy link
Contributor

youknowriad commented May 24, 2019

Yes, documenting this process would be great. It's not the first time we have a discussion about this. Let's have it once and make it a no brainer for the future.

@gziolo

This comment has been minimized.

Copy link
Member

gziolo commented Nov 12, 2019

In #18414, I also see a change in the config file for PHPUnit:

<config name="testVersion" value="5.6-"/>

I think Travis file doesn't run PHP 5.2 and 5.3 anymore:
https://github.com/WordPress/gutenberg/blob/master/.travis.yml

@Soean

This comment has been minimized.

Copy link
Member Author

Soean commented Nov 12, 2019

@gziolo Thanks, I added the change to this PR.

Copy link
Contributor

youknowriad left a comment

Let's do that in the next plugin release and maybe even consider 5.3 soon.

@Soean Soean merged commit dc6e470 into master Nov 12, 2019
2 checks passed
2 checks passed
pull-request-automation
Details
Travis CI - Pull Request Build Passed
Details
@Soean Soean deleted the update/bump-wp-minimum branch Nov 12, 2019
CreativeDive added a commit to CreativeDive/gutenberg that referenced this pull request Nov 12, 2019
* Increase WordPress minimum to 5.2

* Increase PHPCompatibility to PHP 5.6
@youknowriad youknowriad added this to the Gutenberg 7.0 milestone Nov 25, 2019
Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment
Projects
None yet
6 participants
You can’t perform that action at this time.