Skip to content
New issue

Have a question about this project? Sign up for a free GitHub account to open an issue and contact its maintainers and the community.

By clicking “Sign up for GitHub”, you agree to our terms of service and privacy statement. We’ll occasionally send you account related emails.

Already on GitHub? Sign in to your account

Fix: wrong link to attachment page when replacing image. #18731

Conversation

@jorgefilipecosta
Copy link
Member

jorgefilipecosta commented Nov 25, 2019

Description

Related: #18231

When we replaced the image, we were replacing the media file link, but we were not replacing the link to the attachment page. This caused a bug on images with attachment page link after an image is replaced the link still points to the previous image.

How has this been tested?

I added an image block.
I went to the link settings I selected the "Attachment Page" link setting.
I replaced the image with a new one from the media gallery.
I opened the link settings. I clicked on "Attachment Page" and verified the link points to the new image, on master, it points to the previous image.

@jorgefilipecosta jorgefilipecosta force-pushed the fix/wrong-link-to-attachment-page-when-replacing-image branch from 985f69f to dd77b4f Dec 5, 2019
@jorgefilipecosta jorgefilipecosta merged commit 96d00ef into master Dec 5, 2019
2 checks passed
2 checks passed
pull-request-automation
Details
Travis CI - Pull Request Build Passed
Details
@jorgefilipecosta jorgefilipecosta deleted the fix/wrong-link-to-attachment-page-when-replacing-image branch Dec 5, 2019
@youknowriad youknowriad added this to the Gutenberg 7.1 milestone Dec 9, 2019
scruffian added a commit to scruffian/gutenberg that referenced this pull request Dec 10, 2019
Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment
Projects
None yet
2 participants
You can’t perform that action at this time.