New issue

Have a question about this project? Sign up for a free GitHub account to open an issue and contact its maintainers and the community.

By clicking “Sign up for GitHub”, you agree to our terms of service and privacy statement. We’ll occasionally send you account related emails.

Already on GitHub? Sign in to your account

Framework: Bump Webpack dependency versions #2841

Merged
merged 1 commit into from Oct 2, 2017

Conversation

Projects
None yet
2 participants
@aduth
Member

aduth commented Sep 30, 2017

This pull request seeks to bump Webpack-related dependencies to their latest versions.

Relevant changelogs for versions introducing breaking changes:

Testing instructions:

Verify that npm run dev and npm run build complete with no errors.

Ensure that PostCSS configuration is still applied as expected, specifically in applying prefixes automatically. An example is to confirm that -webpack and -ms prefixes are applied to box-align properties on .editor-saved-state.

Ensure there are otherwise no regressions in the editor display.

@aduth aduth added the Framework label Sep 30, 2017

@youknowriad

Works great 👍

@aduth aduth merged commit d420547 into master Oct 2, 2017

3 checks passed

codecov/project 33.74% remains the same compared to a596ceb
Details
continuous-integration/travis-ci/pr The Travis CI build passed
Details
continuous-integration/travis-ci/push The Travis CI build passed
Details

@aduth aduth deleted the update/webpack-3-x branch Oct 2, 2017

@aduth

This comment has been minimized.

Show comment
Hide comment
@aduth

aduth Oct 3, 2017

Member

Seems to be working happily enough, but I should have bumped the babel-loader dependency as well. It's currently warning on npm install.

Member

aduth commented Oct 3, 2017

Seems to be working happily enough, but I should have bumped the babel-loader dependency as well. It's currently warning on npm install.

Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment