Skip to content
Permalink
Browse files

jQuery: bring `jquery.js` back into the WordPress SVN repo and backpo…

…rt the patch from 3.4.0.

Merges [45342] to the 5.2 branch.

Props MikeNGarrett, peterwilsoncc, azaozz.
Fixes #47020.

git-svn-id: https://develop.svn.wordpress.org/branches/5.2@45354 602fd350-edb4-49c9-b593-d223f7449a82
  • Loading branch information...
desrosj committed May 17, 2019
1 parent fe2b4ee commit 7a7219524c53fa6d040290302ef4ec52a2b63918
Showing with 10 additions and 7 deletions.
  1. +0 −1 Gruntfile.js
  2. +3 −3 package-lock.json
  3. +0 −1 package.json
  4. +5 −0 src/js/_enqueues/vendor/jquery/jquery.js
  5. +2 −2 src/wp-includes/script-loader.php
@@ -172,7 +172,6 @@ module.exports = function(grunt) {
[ WORKING_DIR + 'wp-includes/js/jquery/jquery-migrate.js' ]: [ './node_modules/jquery-migrate/dist/jquery-migrate.js' ],
[ WORKING_DIR + 'wp-includes/js/jquery/jquery-migrate.min.js' ]: [ './node_modules/jquery-migrate/dist/jquery-migrate.min.js' ],
[ WORKING_DIR + 'wp-includes/js/jquery/jquery.form.js' ]: [ './node_modules/jquery-form/src/jquery.form.js' ],
[ WORKING_DIR + 'wp-includes/js/jquery/jquery.js' ]: [ './node_modules/jquery/dist/jquery.min.js' ],
[ WORKING_DIR + 'wp-includes/js/masonry.min.js' ]: [ './node_modules/masonry-layout/dist/masonry.pkgd.min.js' ],
[ WORKING_DIR + 'wp-includes/js/twemoji.js' ]: [ './node_modules/twemoji/2/twemoji.js' ],
[ WORKING_DIR + 'wp-includes/js/underscore.js' ]: [ './node_modules/underscore/underscore.js' ],

Some generated files are not rendered by default. Learn more.

@@ -98,7 +98,6 @@
"element-closest": "^2.0.2",
"formdata-polyfill": "3.0.13",
"imagesloaded": "3.2.0",
"jquery": "1.12.4",
"jquery-color": "github:jquery/jquery-color#2.1.1",
"jquery-form": "4.2.1",
"jquery-hoverintent": "1.8.3",

Large diffs are not rendered by default.

@@ -1012,8 +1012,8 @@ function wp_default_scripts( &$scripts ) {
$scripts->add( 'cropper', '/wp-includes/js/crop/cropper.js', array( 'scriptaculous-dragdrop' ) );
// jQuery
$scripts->add( 'jquery', false, array( 'jquery-core', 'jquery-migrate' ), '1.12.4' );
$scripts->add( 'jquery-core', '/wp-includes/js/jquery/jquery.js', array(), '1.12.4' );
$scripts->add( 'jquery', false, array( 'jquery-core', 'jquery-migrate' ), '1.12.4-wp' );
$scripts->add( 'jquery-core', '/wp-includes/js/jquery/jquery.js', array(), '1.12.4-wp' );
$scripts->add( 'jquery-migrate', "/wp-includes/js/jquery/jquery-migrate$suffix.js", array(), '1.4.1' );
// full jQuery UI

0 comments on commit 7a72195

Please sign in to comment.
You can’t perform that action at this time.