Skip to content
New issue

Have a question about this project? Sign up for a free GitHub account to open an issue and contact its maintainers and the community.

By clicking “Sign up for GitHub”, you agree to our terms of service and privacy statement. We’ll occasionally send you account related emails.

Already on GitHub? Sign in to your account

Finishing delete mode in a Route causes all raid markers to be removed #188

Closed
Wotuu opened this issue Jun 18, 2019 · 1 comment

Comments

Projects
None yet
1 participant
@Wotuu
Copy link
Owner

commented Jun 18, 2019

I have no idea either, I just noticed this.

@Wotuu Wotuu added the bug label Jun 18, 2019

@Wotuu Wotuu self-assigned this Jun 18, 2019

@Wotuu Wotuu changed the title Finishing editing mode in a Route causes all raid markers to be removed Finishing delete mode in a Route causes all raid markers to be removed Jun 18, 2019

@Wotuu

This comment has been minimized.

Copy link
Owner Author

commented Jun 18, 2019

This was caused by a hacky fix:

// Fix an issue where it'd remove all layers just because it got removed from the editable layers. Strange.

I didn't investigate it further and just added another patch to fix what was broken. Recalling the above was quite strange and trying to fix it would be time I don't have at this time. Yay introducing technical debt?

@Wotuu Wotuu closed this Jun 18, 2019

Wotuu added a commit that referenced this issue Jun 18, 2019

Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment
You can’t perform that action at this time.