New issue

Have a question about this project? Sign up for a free GitHub account to open an issue and contact its maintainers and the community.

By clicking “Sign up for GitHub”, you agree to our terms of service and privacy statement. We’ll occasionally send you account related emails.

Already on GitHub? Sign in to your account

Hey if got a Problem with my monk and Spartan Ui #102

Open
kokosnuss77 opened this Issue Sep 14, 2018 · 1 comment

Comments

Projects
None yet
2 participants
@kokosnuss77

kokosnuss77 commented Sep 14, 2018

This is the error. This is only on my Monk i play.
Message: ...ce\AddOns\SpartanUI\libs\oUF\elements\classpower.lua:128: attempt to index field '?' (a nil value)
Time: Fri Sep 14 20:50:15 2018
Count: 31
Stack: ...ce\AddOns\SpartanUI\libs\oUF\elements\classpower.lua:128: attempt to index field '?' (a nil value)

Locals:

@dgrenner

This comment has been minimized.

Show comment
Hide comment
@dgrenner

dgrenner Sep 18, 2018

I had the same issue on my monk.

A workaround to get rid of the error is to change in the file classpower.lua, from line 127 to:

			if(i > numActive) then
				if (element[i] ~= nil) then
					element[i]:Hide()
					element[i]:SetValue(0)
				end
			else
				if (element[i] ~= nil) then
					element[i]:Show()
					element[i]:SetValue(cur - i + 1)
				end
			end

I had a similar issue later, and had to do the same change at line 144 in the same file.

dgrenner commented Sep 18, 2018

I had the same issue on my monk.

A workaround to get rid of the error is to change in the file classpower.lua, from line 127 to:

			if(i > numActive) then
				if (element[i] ~= nil) then
					element[i]:Hide()
					element[i]:SetValue(0)
				end
			else
				if (element[i] ~= nil) then
					element[i]:Show()
					element[i]:SetValue(cur - i + 1)
				end
			end

I had a similar issue later, and had to do the same change at line 144 in the same file.

Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment