Skip to content
This repository has been archived by the owner. It is now read-only.
Permalink
master
Switch branches/tags
Go to file
 
 
Cannot retrieve contributors at this time
original_url created_at updated_at closed_at status type resolution reporter owner priority milestone component version keywords
2010-04-02 09:33:06 -0700
2015-09-01 21:49:55 -0700
2010-04-09 16:33:22 -0700
closed
usability
Fixed
doh123@…
jeremyhu@…
Nice to Have
2.5.1
xserver
2.5.0 (xserver-1.7.6)
alt button xkb wine

Alt key mapping, in Wine games

this is a reopen of ticket #⁠349. I tried to just reopen it, but it said i did not have permission.

Alt key is still not working right in Wine games under 2.5.0. No game that uses Alt has a functioning alt key, they are mapped to the wrong thing.... last ticket was closed saying it should be fixed in 2.5.0-rc1.

Macports install as of today (4/2/2010)... Macports devel version as of today, and the Xquartz 2.5.0 release download and install from the .dmg for Snow Leopard .... all still have the same problem. The Alt keys do not map correctly to function as alt.... no change from previous ticket. I didn't expect the 2.5.0 release to work since it was Xorg 1.7.6 ... but even the latest devel 1.7.99.... doesn't work.


jeremyhu@… commented on Apr 2, 2010

  • Status changed from new to assigned
  • Milestone set to 2.5.1

Please run 'xev'

What is printed to the console when you press alt while the white xev window is in focus?


doh123@… commented on Apr 2, 2010

pressing left Alt then Right Alt...

KeyPress event, serial 26, synthetic NO, window 0xa00001,

root 0x681, subw 0x0, time 3217202526, (105,-42), root:(125,0), state 0x0, keycode 66 (keysym 0xff7e, Mode_switch), same_screen YES, XLookupString gives 0 bytes: XmbLookupString gives 0 bytes: XFilterEvent returns: False

KeyRelease event, serial 29, synthetic NO, window 0xa00001,

root 0x681, subw 0x0, time 3217202565, (105,-42), root:(125,0), state 0x2000, keycode 66 (keysym 0xff7e, Mode_switch), same_screen YES, XLookupString gives 0 bytes: XFilterEvent returns: False

KeyPress event, serial 29, synthetic NO, window 0xa00001,

root 0x681, subw 0x0, time 3217211773, (105,-42), root:(125,0), state 0x0, keycode 69 (keysym 0xff7e, Mode_switch), same_screen YES, XKeysymToKeycode returns keycode: 66 XLookupString gives 0 bytes: XmbLookupString gives 0 bytes: XFilterEvent returns: False

KeyRelease event, serial 29, synthetic NO, window 0xa00001,

root 0x681, subw 0x0, time 3217211861, (105,-42), root:(125,0), state 0x2000, keycode 69 (keysym 0xff7e, Mode_switch), same_screen YES, XKeysymToKeycode returns keycode: 66 XLookupString gives 0 bytes: XFilterEvent returns: False


jeremyhu@… commented on Apr 2, 2010

Did you not make a ~/.Xmodmap ?


jeremyhu@… commented on Apr 2, 2010

http://xquartz.macosforge.org/trac/wiki/KeyboardMapping


doh123@… commented on Apr 2, 2010

Replying to jeremyhu@…:

http://xquartz.macosforge.org/trac/wiki/KeyboardMapping

i had not seen that exact posting.. I tried editing xkb configs, and making a xmodmap on my own... neither which seemed to work. I'll try again with the exact syntax off that link.... I wasn't aware it was ever supposed to be like that though, so thats probably it. I'll test it shortly and post back.


jeremyhu@… commented on Apr 2, 2010

  • Status changed from assigned to closed
  • Resolution changed from to worksforme

It was like that except for the versions shipped with OSX 10.5.0 and 10.5.1


doh123@… commented on Apr 2, 2010

adding a ~/.Xmodmap does seem to fix the problem... not with my old Xquartz build of 2.5.0 with xorg server 1.7.2... but with 2.5.0 release and the 1.7.99.xxx. server.

Is there any way to make it change without ~/.Xmodmap ... or set a different location to load .Xmodmap from? If not, it still works ok.


jeremyhu@… commented on Apr 2, 2010

2.5.0 contains the 1.7.6 server which has this change. I'm guessing your 1.7.2 server was from the alphas or betas.

~/.Xmodmap is where these changes go. I may add a UI option for that to the preferences. If you think that is something useful, please open a new bug for that issue.

Thanks.


jeremyhu@… commented on Apr 9, 2010

  • Status changed from closed to reopened
  • Resolution worksforme deleted

jeremyhu@… commented on Apr 9, 2010

  • Status changed from reopened to closed
  • Resolution set to fixed

I have added a preference option for this which you can use instead of ~/.Xmodmap in the next release.