Skip to content
This repository has been archived by the owner. It is now read-only.
Permalink
master
Switch branches/tags
Go to file
 
 
Cannot retrieve contributors at this time
original_url created_at updated_at closed_at status type resolution reporter owner priority milestone component version cc
2010-05-18 11:03:13 -0700
2015-11-03 18:45:53 -0800
2015-11-03 18:45:53 -0800
closed
usability
Duplicate
n8gray@…
jeremyhu@…
Nice to Have
2.8.0
pbproxy
2.5.0 (xserver-1.7.6)
suv-sf@…

Copy/Paste in Inkscape pastes bitmaps

If the "Update Pasteboard when CLIPBOARD changes" option is checked then copy/pasting a vector graphical item in Inkscape will paste a bitmap representation of that item instead of a vector copy. To be precise, this is using Edit->Copy and Edit->Paste in the Inkscape menu.

The desired behavior is that it pastes a vector graphics object, which is what happens when the "Update Pasteboard..." option is unchecked.


jeremyhu@… commented on May 18, 2010

  • Status changed from new to assigned

<rdar://problem/6883022>


suv-sf@… commented on May 22, 2010

  • Cc suv-sf@… added

suv-sf@… commented on Oct 14, 2010

Priority: Nice to Have

This is the most often reported issue for the Mac OS X port of Inkscape: Bug #⁠307005 in Inkscape: “osx: copy & paste inserts a bitmap copy instead of the vector object”

While disabling "Update Pasteboard when CLIPBOARD changes" does enable the expected behavior, it is a troubling default setting - especially for new Inkscape users: a) the difference between pasting the vector objects or a bitmap copy is not obvious or noticeable at first sight, b) more advanced commands that depend on vector content in the clipboard fail (because they need to extract object attributes from the SVG definition in the clipboard, like 'id', 'width/height' or 'style') c) For Inkscape users it is difficult to figure out what causes the unexpected behavior of 'Paste', why 'Paste Style|Size' fails or path effects can't paste or link to pattern sources and bend paths: the connection to the pasteboard settings of X11/Xquartz is not obvious

A solution for this problem would be highly appreciated by Inkscape users on Mac OS X.


jeremyhu@… commented on Oct 14, 2010

I understand the issues involved here, and it is an issue beyond loosing vectorized data in images. However, there is an easy workaround, and it is not a regression when that workaround is enabled. It is on the list of issues to tackle, but unfortunately that list is quite large (and extends far beyond just XQuartz in my case).

The code that handles this is all open source and available in hw/xquartz/pbproxy. If it's something that you want to tackle, I'd gladly discuss options on xquartz-dev and accept patches.


jeremyhu@… commented on Oct 16, 2010

  • Milestone changed from 2.6.0 to 2.6.1

jeremyhu@… commented on Feb 28, 2011

  • Milestone changed from 2.6.1 to 2.6.2

jeremyhu@… commented on Apr 12, 2011

  • Milestone changed from 2.6.2 to 2.6.3

jeremyhu@… commented on Oct 20, 2011

  • Milestone changed from 2.7.0 to 2.7.1

jeremyhu@… commented on Dec 17, 2011

  • Milestone changed from 2.7.1 to 2.8.0

jeremyhu@… commented on Oct 23, 2015

Mass Edit

As you may have noticed, we have had issues with spam in trac for the past couple years. We've decided to migrate to using freedesktop.org's bugzilla for our bug tracker (more details will be coming on the mailing lists in the next couple weeks).

I don't want us to loose valuable bug reports in the transition, so I want to make sure that any relevant open issues in this MacOSForge trac are migrated over to the new system. If you are interested in this issue, please take a few minutes to file a new bug for this issue in bugzilla. Please make sure to do the following:

  • Copy over all relevant information into that report, just in case we loose this one.
  • Set the URL field of the bugzilla report to this trac ticket's URL.
  • Paste the URL of the new bugzilla report as a comment in this ticket, and I'll close it out.

suv-sf@… commented on Nov 3, 2015

Bug migrated to freedesktop.org's bugzilla: https://bugs.freedesktop.org/show_bug.cgi?id=92801


jeremyhu@… commented on Nov 3, 2015

  • Status changed from assigned to closed
  • Resolution set to Duplicate

Thanks.