Skip to content
This repository has been archived by the owner. It is now read-only.
Permalink
master
Switch branches/tags
Go to file
 
 
Cannot retrieve contributors at this time
original_url created_at updated_at closed_at status type resolution reporter owner priority milestone component keywords cc
2011-10-29 18:00:52 -0700
2016-05-31 00:47:53 -0700
2016-05-31 00:47:53 -0700
closed
usability
Cannot Reproduce
thedaniel@…
jeremyhu@…
Important
2.8.0
pbproxy
clipboard
thedaniel@…

Clipboard Syncing Not Working Properly

Tested both on Mac OS 10.6.7. and Mac OS 10.7.1 using XQ 2.7.0 rc1 and all previous versions

Clipboard contents from X11 to Mac aqua does not work until the "Enable syncing" in the Clipboard tab of the XQuartz Preferences panel is toggled.

I don't know what component it is, maybe the server or maybe the window manager, but please fix.

Example app that I know it happens with: theWord http://www.theword.net/ . I don't use theWord, but I was just testing it for a friend, but it does happen using theWord. Please note, this is a Windows application in a WINE wrapper.

Download from this page, http://forum.theword.net/viewtopic.php?f=11&t=2921

1.) Restart your Mac
2.) Launch theWord
3.) Select a word or phrase
4.) Use either keyboard shortcut or from the Edit menu "Copy" from the X11/WINE app
5.) When you find paste not working in a Native Mac aqua app, try toggling the "Enable syncing" off/on from the Pasteboard tab of XQuartz Preferences panel. You can also try copying from a Native Mac application first. (Suggestion:Before and after, check your Mac's clipboard by going to the Finder and selecting Edit -> Show Clipboard.) 

Hope this helps you replicate the disease.


thedaniel@… commented on Oct 29, 2011

  • Cc thedaniel@… added

jeremyhu@… commented on Oct 29, 2011

  • Description modified

jeremyhu@… commented on Oct 29, 2011

  • Priority changed from Expected to Important
  • Component changed from quartz-wm to pbproxy
  • Milestone set to 2.7.1

jeremyhu@… commented on Dec 17, 2011

  • Status changed from new to assigned

jeremyhu@… commented on Dec 17, 2011

  • Milestone changed from 2.7.1 to 2.8.0

jeremyhu@… commented on Aug 16, 2012

Has dupe #⁠558


jeremyhu@… commented on Oct 23, 2015

Mass Edit

As you may have noticed, we have had issues with spam in trac for the past couple years. We've decided to migrate to using freedesktop.org's bugzilla for our bug tracker (more details will be coming on the mailing lists in the next couple weeks).

I don't want us to loose valuable bug reports in the transition, so I want to make sure that any relevant open issues in this MacOSForge trac are migrated over to the new system. If you are interested in this issue, please take a few minutes to file a new bug for this issue in bugzilla. Please make sure to do the following:

  • Copy over all relevant information into that report, just in case we loose this one.
  • Set the URL field of the bugzilla report to this trac ticket's URL.
  • Paste the URL of the new bugzilla report as a comment in this ticket, and I'll close it out.

jeremyhu@… commented on May 31, 2016

  • Status changed from assigned to closed
  • Resolution set to Cannot Reproduce