Skip to content
This repository has been archived by the owner. It is now read-only.
Permalink
master
Switch branches/tags
Go to file
 
 
Cannot retrieve contributors at this time
original_url created_at updated_at closed_at status type resolution reporter owner priority milestone component version keywords cc
2012-01-12 03:44:43 -0800
2016-05-31 00:42:14 -0700
2016-05-31 00:42:14 -0700
closed
crash
Fixed
dgoodyear@…
jeremyhu@…
Expected
2.7.4
GLX
2.7.0 (xserver-1.11.2)
open gl wine child window render
motumbo@…
jonas.maebe@…

Opengl invalid drawable using wine.

When trying to execute Cut2D from OS X lion using wine the program starts fine but when it tries to render 3D in a "child window" the program exits with the error:

X Error of failed request: 0

Major opcode of failed request: 149 (GLX) Minor opcode of failed request: 26 (X_GLXMakeContextCurrent) Serial number of failed request: 80015 Current serial number in output stream: 80015

The wine trace is in the file below. The bug was reported as a wine bug however several people with the same problem have verified that this is not a wine issue (http://wine.1045685.n5.nabble.com/Re-OpenGL-issues-on-OSX-wine-1-3-21-tt5108944.html#a5136947) as the child window rendering works under linux. The software developer of Moi3D has since changed his software so it can be run on Mac OS X using XQuartz by changing the child window rendering. So this appears to be an XQuartz issue.


dgoodyear@… commented on Jan 12, 2012

wine output trace


dgoodyear@… commented on Jan 12, 2012

I am not sure if this was the right mileston to place this topic in...please advise.


jeremyhu@… commented on Jan 12, 2012

  • Priority changed from Not Set to Expected
  • Milestone changed from OSX to later

jeremyhu@… commented on Jan 12, 2012

  • Status changed from new to assigned

qvantvm@… commented on Mar 27, 2012

several applications based on opengl drawing in a child are influenced by this issue. Please can you tell me in which version do you think this ticket will be solved? Thank you.


jeremyhu@… commented on Mar 27, 2012

This has never worked and is thus not a regression. I have no intention of working on this particular issue for the forseeable future. Maybe it will be fixed in 3.0 ... maybe it won't ... if nobody steps up to work on this, it probably won't be fixed.


motumbo@… commented on Apr 14, 2012

I was having a similar error with Wine 1.5.2, XQuartz (2.7.1 and 2.7.2 beta 4) and GPU Caps Viewer benchmarks

X Error of failed request:  0
  Major opcode of failed request:  149 (GLX)
  Minor opcode of failed request:  26 (X_GLXMakeContextCurrent)
  Serial number of failed request:  18356
  Current serial number in output stream:  18356

Disabling in winecfg "Allow window manager control windows" and "Allow the window manager to decorate the windows" solved the problem, maybe is quartz-wm related (Also Wine doesn't integrate very well with quartz-wm).

I will try installing Gnome using MacPorts and see how it works with Metacity


motumbo@… commented on Apr 14, 2012

  • Cc motumbo@… added

motumbo@… commented on Apr 14, 2012

The workaround I posted works sometimes only, and it works better if you launch wine from a xterm, but when I launched from Terminal.app and started any benchmark, it crashed.

Disabling the window manager integration reduces the posibilites of crashing XQuartz.


jeremyhu@… commented on May 22, 2012

  • Status changed from assigned to closed
  • Milestone changed from later to 2.7.2
  • Resolution changed from to duplicate

This is likely the same issue fixed for #⁠512 and #⁠575 ... please verify with XQuartz 2.7.2


qvantvm@… commented on May 23, 2012

I still have the same issue on the OpenGL context when created on a child window. I am using the XQuartz version 2.7.2_rc2.


jeremyhu@… commented on May 24, 2012

Yes, I expect the issue to be present in 2.7.2_rc2. There were still latent issues in that release. Please try 2.7.2_rc3 when I release it later today or tomorrow.


qvantvm@… commented on May 26, 2012

Thank you jeremy for your effort,

but I have tried the version 2.7.2_rc3 and still I have the same issue:

Can't Activate The GL Rendering Context.

As a result of a call to wglMakeCurrent on child window .


jeremyhu@… commented on May 26, 2012

  • Status changed from closed to reopened
  • Milestone changed from 2.7.2 to 2.7.3
  • Resolution duplicate deleted

Darn. Reopening then.

Can you please run your application with LIBGL_DIAGNOSTIC=1 set in your environment. This will dump a log (to the console) of activity which should be helpful in understanding what is going on. Please attach that log.


qvantvm@… commented on May 28, 2012

I have a Window .exe that starts in Wine. I have tried to set LIBGL_DIAGNOSTIC=1 within xterm but I could not find any debug information in the console. Please can you give me detailed instructions on how to generate that log?


jeremyhu@… commented on May 28, 2012

It just needs to be in the environment of the process that is using libGL, so:

export LIBGL_DIAGNOSTIC=1
wine path/to/the/windows/executable

qvantvm@… commented on May 29, 2012

Strange... exactly what I did. Nevertheless here is what I get:

org.macosforge.xquartz.startx[2769]: xauth: file /Users/qvantvm/.serverauth.2770 does not exist org.macosforge.xquartz.startx[2769]: org.macosforge.xquartz.X11.stub[2912]: Xquartz: Unable to locate waiting server: org.macosforge.xquartz.X11 org.macosforge.xquartz.X11.stub[2913]: Xquartz: Starting X server: /Applications/Utilities/XQuartz.app/Contents/MacOS/X11 --listenonly org.macosforge.xquartz.startx[2769]: /opt/X11/bin/xinit: XFree86_VT property unexpectedly has 0 items instead of 1

... and in the Wine's log:

path: 2913_0x60004b set off screen: invalid drawable X Error of failed request: GLXBadCurrentWindow

Major opcode of failed request: 0 () Serial number of failed request: 955 Current serial number in output stream: 955

I didn't find other informations. Please tell me if I can do anything else.


jeremyhu@… commented on May 29, 2012

That is not the relevant information. The first hunk looks like info printed to syslog, that's not what we want. We want information printed to stderr by libGL. If I run this:

$ export LIBGL_DIAGNOSTIC=1
$ wine .wine/drive_c/Games/Quake2/quake2.exe 

I see a ton of information printed to stderr which is very relevant. eg:

Debug             ../applegl_glx.c:89   applegl_unbind_context(1083727872): applegl_unbind_context: error NO
Debug          apple_glx_context.c:218  apple_glx_destroy_context(1083727872): apple_glx_destroy_context: ac 0x4029b650 ac->context_obj 0x411b1c00
Debug                  apple_glx.c:74   surface_notify_handler(1083727872): surface notify updated 0
Debug                  apple_glx.c:74   surface_notify_handler(1083727872): surface notify updated 0
Debug                  apple_glx.c:65   surface_notify_handler(1083727872): surface_notify_handler: surface destroyed 57
Debug         apple_glx_drawable.c:206  destroy_drawable_callback(1083727872): destroy_drawable_callback: 0x411fcc00 ->ref

jeremyhu@… commented on May 29, 2012

Are you sure you are using XQuartz's or MacPorts' libGL?


qvantvm@… commented on May 31, 2012

Replying to jeremyhu@…:

Are you sure you are using XQuartz's or MacPorts' libGL?

Ok, I had to recompile Wine, here is what I get:

err:seh:raise_exception Unhandled exception code c0000005 flags 0 addr 0x7bc6168e
err:seh:raise_exception Unhandled exception code c0000005 flags 0 addr 0x7bc6168e
wine: Unhandled page fault on read access to 0xffffffff at address 0x7bc6168e (thread 0009), starting debugger...
err:seh:raise_exception Unhandled exception code c0000005 flags 0 addr 0x7b824157
err:seh:raise_exception Unhandled exception code c0000005 flags 0 addr 0x7bc60bb9
Qvantvm-MBP:bin qvantvm$ export LIBGL_DIAGNOSTIC=1
Qvantvm-MBP:bin qvantvm$ ./wine /Users/qvantvm/Documents/TestWine/glWin/src/bin/glWin.exe
err:seh:raise_exception Unhandled exception code c0000005 flags 0 addr 0x7bc6168e
err:seh:raise_exception Unhandled exception code c0000005 flags 0 addr 0x7bc6168e
Info                   apple_glx.c:116  apple_init_glx(1109370880): Initializing libGL.Debug                  apple_cgl.c:92   apple_cgl_init(1109370880): CGL major 1 minor 2
WARNING: unknown GLX tag from server: tag 0x20d0 value 0x0
WARNING: unknown GLX tag from server: tag 0x20d1 value 0x0
WARNING: unknown GLX tag from server: tag 0x20d2 value 0x0
WARNING: unknown GLX tag from server: tag 0x20d3 value 0x0
WARNING: unknown GLX tag from server: tag 0x20d0 value 0x0
WARNING: unknown GLX tag from server: tag 0x20d1 value 0x0
WARNING: unknown GLX tag from server: tag 0x20d2 value 0x0
WARNING: unknown GLX tag from server: tag 0x20d3 value 0x0
WARNING: unknown GLX tag from server: tag 0x20d0 value 0x0
WARNING: unknown GLX tag from server: tag 0x20d1 value 0x0
WARNING: unknown GLX tag from server: tag 0x20d2 value 0x0
WARNING: unknown GLX tag from server: tag 0x20d3 value 0x0
WARNING: unknown GLX tag from server: tag 0x20d0 value 0x0
WARNING: unknown GLX tag from server: tag 0x20d1 value 0x0
WARNING: unknown GLX tag from server: tag 0x20d2 value 0x0
WARNING: unknown GLX tag from server: tag 0x20d3 value 0x0
WARNING: unknown GLX tag from server: tag 0x20d0 value 0x0
WARNING: unknown GLX tag from server: tag 0x20d1 value 0x0
WARNING: unknown GLX tag from server: tag 0x20d2 value 0x0
WARNING: unknown GLX tag from server: tag 0x20d3 value 0x0
WARNING: unknown GLX tag from server: tag 0x20d0 value 0x0
WARNING: unknown GLX tag from server: tag 0x20d1 value 0x0
WARNING: unknown GLX tag from server: tag 0x20d2 value 0x0
WARNING: unknown GLX tag from server: tag 0x20d3 value 0x0
WARNING: unknown GLX tag from server: tag 0x20d0 value 0x0
WARNING: unknown GLX tag from server: tag 0x20d1 value 0x0
WARNING: unknown GLX tag from server: tag 0x20d2 value 0x0
WARNING: unknown GLX tag from server: tag 0x20d3 value 0x0
WARNING: unknown GLX tag from server: tag 0x20d0 value 0x0
WARNING: unknown GLX tag from server: tag 0x20d1 value 0x0
WARNING: unknown GLX tag from server: tag 0x20d2 value 0x0
WARNING: unknown GLX tag from server: tag 0x20d3 value 0x0
WARNING: unknown GLX tag from server: tag 0x20d0 value 0x0
WARNING: unknown GLX tag from server: tag 0x20d1 value 0x0
WARNING: unknown GLX tag from server: tag 0x20d2 value 0x0
WARNING: unknown GLX tag from server: tag 0x20d3 value 0x0
WARNING: unknown GLX tag from server: tag 0x20d0 value 0x0
WARNING: unknown GLX tag from server: tag 0x20d1 value 0x0
WARNING: unknown GLX tag from server: tag 0x20d2 value 0x0
WARNING: unknown GLX tag from server: tag 0x20d3 value 0x0
WARNING: unknown GLX tag from server: tag 0x20d0 value 0x0
WARNING: unknown GLX tag from server: tag 0x20d1 value 0x0
WARNING: unknown GLX tag from server: tag 0x20d2 value 0x0
WARNING: unknown GLX tag from server: tag 0x20d3 value 0x0
WARNING: unknown GLX tag from server: tag 0x20d0 value 0x0
WARNING: unknown GLX tag from server: tag 0x20d1 value 0x0
WARNING: unknown GLX tag from server: tag 0x20d2 value 0x0
WARNING: unknown GLX tag from server: tag 0x20d3 value 0x0
WARNING: unknown GLX tag from server: tag 0x20d0 value 0x0
WARNING: unknown GLX tag from server: tag 0x20d1 value 0x0
WARNING: unknown GLX tag from server: tag 0x20d2 value 0x0
WARNING: unknown GLX tag from server: tag 0x20d3 value 0x0
WARNING: unknown GLX tag from server: tag 0x20d0 value 0x0
WARNING: unknown GLX tag from server: tag 0x20d1 value 0x0
WARNING: unknown GLX tag from server: tag 0x20d2 value 0x0
WARNING: unknown GLX tag from server: tag 0x20d3 value 0x0
WARNING: unknown GLX tag from server: tag 0x20d0 value 0x0
WARNING: unknown GLX tag from server: tag 0x20d1 value 0x0
WARNING: unknown GLX tag from server: tag 0x20d2 value 0x0
WARNING: unknown GLX tag from server: tag 0x20d3 value 0x0
WARNING: unknown GLX tag from server: tag 0x20d0 value 0x0
WARNING: unknown GLX tag from server: tag 0x20d1 value 0x0
WARNING: unknown GLX tag from server: tag 0x20d2 value 0x0
WARNING: unknown GLX tag from server: tag 0x20d3 value 0x0
WARNING: unknown GLX tag from server: tag 0x20d0 value 0x0
WARNING: unknown GLX tag from server: tag 0x20d1 value 0x0
WARNING: unknown GLX tag from server: tag 0x20d2 value 0x0
WARNING: unknown GLX tag from server: tag 0x20d3 value 0x0
WARNING: unknown GLX tag from server: tag 0x20d0 value 0x0
WARNING: unknown GLX tag from server: tag 0x20d1 value 0x0
WARNING: unknown GLX tag from server: tag 0x20d2 value 0x0
WARNING: unknown GLX tag from server: tag 0x20d3 value 0x0
WARNING: unknown GLX tag from server: tag 0x20d0 value 0x0
WARNING: unknown GLX tag from server: tag 0x20d1 value 0x0
WARNING: unknown GLX tag from server: tag 0x20d2 value 0x0
WARNING: unknown GLX tag from server: tag 0x20d3 value 0x0
WARNING: unknown GLX tag from server: tag 0x20d0 value 0x0
WARNING: unknown GLX tag from server: tag 0x20d1 value 0x0
WARNING: unknown GLX tag from server: tag 0x20d2 value 0x0
WARNING: unknown GLX tag from server: tag 0x20d3 value 0x0
WARNING: unknown GLX tag from server: tag 0x20d0 value 0x0
WARNING: unknown GLX tag from server: tag 0x20d1 value 0x0
WARNING: unknown GLX tag from server: tag 0x20d2 value 0x0
WARNING: unknown GLX tag from server: tag 0x20d3 value 0x0
WARNING: unknown GLX tag from server: tag 0x20d0 value 0x0
WARNING: unknown GLX tag from server: tag 0x20d1 value 0x0
WARNING: unknown GLX tag from server: tag 0x20d2 value 0x0
WARNING: unknown GLX tag from server: tag 0x20d3 value 0x0
WARNING: unknown GLX tag from server: tag 0x20d0 value 0x0
WARNING: unknown GLX tag from server: tag 0x20d1 value 0x0
WARNING: unknown GLX tag from server: tag 0x20d2 value 0x0
WARNING: unknown GLX tag from server: tag 0x20d3 value 0x0
WARNING: unknown GLX tag from server: tag 0x20d0 value 0x0
WARNING: unknown GLX tag from server: tag 0x20d1 value 0x0
WARNING: unknown GLX tag from server: tag 0x20d2 value 0x0
WARNING: unknown GLX tag from server: tag 0x20d3 value 0x0
WARNING: unknown GLX tag from server: tag 0x20d0 value 0x0
WARNING: unknown GLX tag from server: tag 0x20d1 value 0x0
WARNING: unknown GLX tag from server: tag 0x20d2 value 0x0
WARNING: unknown GLX tag from server: tag 0x20d3 value 0x0
WARNING: unknown GLX tag from server: tag 0x20d0 value 0x0
WARNING: unknown GLX tag from server: tag 0x20d1 value 0x0
WARNING: unknown GLX tag from server: tag 0x20d2 value 0x0
WARNING: unknown GLX tag from server: tag 0x20d3 value 0x0
WARNING: unknown GLX tag from server: tag 0x20d0 value 0x0
WARNING: unknown GLX tag from server: tag 0x20d1 value 0x0
WARNING: unknown GLX tag from server: tag 0x20d2 value 0x0
WARNING: unknown GLX tag from server: tag 0x20d3 value 0x0
WARNING: unknown GLX tag from server: tag 0x20d0 value 0x0
WARNING: unknown GLX tag from server: tag 0x20d1 value 0x0
WARNING: unknown GLX tag from server: tag 0x20d2 value 0x0
WARNING: unknown GLX tag from server: tag 0x20d3 value 0x0
WARNING: unknown GLX tag from server: tag 0x20d0 value 0x0
WARNING: unknown GLX tag from server: tag 0x20d1 value 0x0
WARNING: unknown GLX tag from server: tag 0x20d2 value 0x0
WARNING: unknown GLX tag from server: tag 0x20d3 value 0x0
WARNING: unknown GLX tag from server: tag 0x20d0 value 0x0
WARNING: unknown GLX tag from server: tag 0x20d1 value 0x0
WARNING: unknown GLX tag from server: tag 0x20d2 value 0x0
WARNING: unknown GLX tag from server: tag 0x20d3 value 0x0
WARNING: unknown GLX tag from server: tag 0x20d0 value 0x0
WARNING: unknown GLX tag from server: tag 0x20d1 value 0x0
WARNING: unknown GLX tag from server: tag 0x20d2 value 0x0
WARNING: unknown GLX tag from server: tag 0x20d3 value 0x0
WARNING: unknown GLX tag from server: tag 0x20d0 value 0x0
WARNING: unknown GLX tag from server: tag 0x20d1 value 0x0
WARNING: unknown GLX tag from server: tag 0x20d2 value 0x0
WARNING: unknown GLX tag from server: tag 0x20d3 value 0x0
WARNING: unknown GLX tag from server: tag 0x20d0 value 0x0
WARNING: unknown GLX tag from server: tag 0x20d1 value 0x0
WARNING: unknown GLX tag from server: tag 0x20d2 value 0x0
WARNING: unknown GLX tag from server: tag 0x20d3 value 0x0
WARNING: unknown GLX tag from server: tag 0x20d0 value 0x0
WARNING: unknown GLX tag from server: tag 0x20d1 value 0x0
WARNING: unknown GLX tag from server: tag 0x20d2 value 0x0
WARNING: unknown GLX tag from server: tag 0x20d3 value 0x0
WARNING: unknown GLX tag from server: tag 0x20d0 value 0x0
WARNING: unknown GLX tag from server: tag 0x20d1 value 0x0
WARNING: unknown GLX tag from server: tag 0x20d2 value 0x0
WARNING: unknown GLX tag from server: tag 0x20d3 value 0x0
WARNING: unknown GLX tag from server: tag 0x20d0 value 0x0
WARNING: unknown GLX tag from server: tag 0x20d1 value 0x0
WARNING: unknown GLX tag from server: tag 0x20d2 value 0x0
WARNING: unknown GLX tag from server: tag 0x20d3 value 0x0
WARNING: unknown GLX tag from server: tag 0x20d0 value 0x0
WARNING: unknown GLX tag from server: tag 0x20d1 value 0x0
WARNING: unknown GLX tag from server: tag 0x20d2 value 0x0
WARNING: unknown GLX tag from server: tag 0x20d3 value 0x0
WARNING: unknown GLX tag from server: tag 0x20d0 value 0x0
WARNING: unknown GLX tag from server: tag 0x20d1 value 0x0
WARNING: unknown GLX tag from server: tag 0x20d2 value 0x0
WARNING: unknown GLX tag from server: tag 0x20d3 value 0x0
WARNING: unknown GLX tag from server: tag 0x20d0 value 0x0
WARNING: unknown GLX tag from server: tag 0x20d1 value 0x0
WARNING: unknown GLX tag from server: tag 0x20d2 value 0x0
WARNING: unknown GLX tag from server: tag 0x20d3 value 0x0
WARNING: unknown GLX tag from server: tag 0x20d0 value 0x0
WARNING: unknown GLX tag from server: tag 0x20d1 value 0x0
WARNING: unknown GLX tag from server: tag 0x20d2 value 0x0
WARNING: unknown GLX tag from server: tag 0x20d3 value 0x0
WARNING: unknown GLX tag from server: tag 0x20d0 value 0x0
WARNING: unknown GLX tag from server: tag 0x20d1 value 0x0
WARNING: unknown GLX tag from server: tag 0x20d2 value 0x0
WARNING: unknown GLX tag from server: tag 0x20d3 value 0x0
WARNING: unknown GLX tag from server: tag 0x20d0 value 0x0
WARNING: unknown GLX tag from server: tag 0x20d1 value 0x0
WARNING: unknown GLX tag from server: tag 0x20d2 value 0x0
WARNING: unknown GLX tag from server: tag 0x20d3 value 0x0
WARNING: unknown GLX tag from server: tag 0x20d0 value 0x0
WARNING: unknown GLX tag from server: tag 0x20d1 value 0x0
WARNING: unknown GLX tag from server: tag 0x20d2 value 0x0
WARNING: unknown GLX tag from server: tag 0x20d3 value 0x0
WARNING: unknown GLX tag from server: tag 0x20d0 value 0x0
WARNING: unknown GLX tag from server: tag 0x20d1 value 0x0
WARNING: unknown GLX tag from server: tag 0x20d2 value 0x0
WARNING: unknown GLX tag from server: tag 0x20d3 value 0x0
WARNING: unknown GLX tag from server: tag 0x20d0 value 0x0
WARNING: unknown GLX tag from server: tag 0x20d1 value 0x0
WARNING: unknown GLX tag from server: tag 0x20d2 value 0x0
WARNING: unknown GLX tag from server: tag 0x20d3 value 0x0
WARNING: unknown GLX tag from server: tag 0x20d0 value 0x0
WARNING: unknown GLX tag from server: tag 0x20d1 value 0x0
WARNING: unknown GLX tag from server: tag 0x20d2 value 0x0
WARNING: unknown GLX tag from server: tag 0x20d3 value 0x0
WARNING: unknown GLX tag from server: tag 0x20d0 value 0x0
WARNING: unknown GLX tag from server: tag 0x20d1 value 0x0
WARNING: unknown GLX tag from server: tag 0x20d2 value 0x0
WARNING: unknown GLX tag from server: tag 0x20d3 value 0x0
WARNING: unknown GLX tag from server: tag 0x20d0 value 0x0
WARNING: unknown GLX tag from server: tag 0x20d1 value 0x0
WARNING: unknown GLX tag from server: tag 0x20d2 value 0x0
WARNING: unknown GLX tag from server: tag 0x20d3 value 0x0
WARNING: unknown GLX tag from server: tag 0x20d0 value 0x0
WARNING: unknown GLX tag from server: tag 0x20d1 value 0x0
WARNING: unknown GLX tag from server: tag 0x20d2 value 0x0
WARNING: unknown GLX tag from server: tag 0x20d3 value 0x0
WARNING: unknown GLX tag from server: tag 0x20d0 value 0x0
WARNING: unknown GLX tag from server: tag 0x20d1 value 0x0
WARNING: unknown GLX tag from server: tag 0x20d2 value 0x0
WARNING: unknown GLX tag from server: tag 0x20d3 value 0x0
WARNING: unknown GLX tag from server: tag 0x20d0 value 0x0
WARNING: unknown GLX tag from server: tag 0x20d1 value 0x0
WARNING: unknown GLX tag from server: tag 0x20d2 value 0x0
WARNING: unknown GLX tag from server: tag 0x20d3 value 0x0
WARNING: unknown GLX tag from server: tag 0x20d0 value 0x0
WARNING: unknown GLX tag from server: tag 0x20d1 value 0x0
WARNING: unknown GLX tag from server: tag 0x20d2 value 0x0
WARNING: unknown GLX tag from server: tag 0x20d3 value 0x0
WARNING: unknown GLX tag from server: tag 0x20d0 value 0x0
WARNING: unknown GLX tag from server: tag 0x20d1 value 0x0
WARNING: unknown GLX tag from server: tag 0x20d2 value 0x0
WARNING: unknown GLX tag from server: tag 0x20d3 value 0x0
WARNING: unknown GLX tag from server: tag 0x20d0 value 0x0
WARNING: unknown GLX tag from server: tag 0x20d1 value 0x0
WARNING: unknown GLX tag from server: tag 0x20d2 value 0x0
WARNING: unknown GLX tag from server: tag 0x20d3 value 0x0
WARNING: unknown GLX tag from server: tag 0x20d0 value 0x0
WARNING: unknown GLX tag from server: tag 0x20d1 value 0x0
WARNING: unknown GLX tag from server: tag 0x20d2 value 0x0
WARNING: unknown GLX tag from server: tag 0x20d3 value 0x0
WARNING: unknown GLX tag from server: tag 0x20d0 value 0x0
WARNING: unknown GLX tag from server: tag 0x20d1 value 0x0
WARNING: unknown GLX tag from server: tag 0x20d2 value 0x0
WARNING: unknown GLX tag from server: tag 0x20d3 value 0x0
WARNING: unknown GLX tag from server: tag 0x20d0 value 0x0
WARNING: unknown GLX tag from server: tag 0x20d1 value 0x0
WARNING: unknown GLX tag from server: tag 0x20d2 value 0x0
WARNING: unknown GLX tag from server: tag 0x20d3 value 0x0
WARNING: unknown GLX tag from server: tag 0x20d0 value 0x0
WARNING: unknown GLX tag from server: tag 0x20d1 value 0x0
WARNING: unknown GLX tag from server: tag 0x20d2 value 0x0
WARNING: unknown GLX tag from server: tag 0x20d3 value 0x0
WARNING: unknown GLX tag from server: tag 0x20d0 value 0x0
WARNING: unknown GLX tag from server: tag 0x20d1 value 0x0
WARNING: unknown GLX tag from server: tag 0x20d2 value 0x0
WARNING: unknown GLX tag from server: tag 0x20d3 value 0x0
WARNING: unknown GLX tag from server: tag 0x20d0 value 0x0
WARNING: unknown GLX tag from server: tag 0x20d1 value 0x0
WARNING: unknown GLX tag from server: tag 0x20d2 value 0x0
WARNING: unknown GLX tag from server: tag 0x20d3 value 0x0
WARNING: unknown GLX tag from server: tag 0x20d0 value 0x0
WARNING: unknown GLX tag from server: tag 0x20d1 value 0x0
WARNING: unknown GLX tag from server: tag 0x20d2 value 0x0
WARNING: unknown GLX tag from server: tag 0x20d3 value 0x0
WARNING: unknown GLX tag from server: tag 0x20d0 value 0x0
WARNING: unknown GLX tag from server: tag 0x20d1 value 0x0
WARNING: unknown GLX tag from server: tag 0x20d2 value 0x0
WARNING: unknown GLX tag from server: tag 0x20d3 value 0x0
WARNING: unknown GLX tag from server: tag 0x20d0 value 0x0
WARNING: unknown GLX tag from server: tag 0x20d1 value 0x0
WARNING: unknown GLX tag from server: tag 0x20d2 value 0x0
WARNING: unknown GLX tag from server: tag 0x20d3 value 0x0
WARNING: unknown GLX tag from server: tag 0x20d0 value 0x0
WARNING: unknown GLX tag from server: tag 0x20d1 value 0x0
WARNING: unknown GLX tag from server: tag 0x20d2 value 0x0
WARNING: unknown GLX tag from server: tag 0x20d3 value 0x0
WARNING: unknown GLX tag from server: tag 0x20d0 value 0x0
WARNING: unknown GLX tag from server: tag 0x20d1 value 0x0
WARNING: unknown GLX tag from server: tag 0x20d2 value 0x0
WARNING: unknown GLX tag from server: tag 0x20d3 value 0x0
WARNING: unknown GLX tag from server: tag 0x20d0 value 0x0
WARNING: unknown GLX tag from server: tag 0x20d1 value 0x0
WARNING: unknown GLX tag from server: tag 0x20d2 value 0x0
WARNING: unknown GLX tag from server: tag 0x20d3 value 0x0
WARNING: unknown GLX tag from server: tag 0x20d0 value 0x0
WARNING: unknown GLX tag from server: tag 0x20d1 value 0x0
WARNING: unknown GLX tag from server: tag 0x20d2 value 0x0
WARNING: unknown GLX tag from server: tag 0x20d3 value 0x0
WARNING: unknown GLX tag from server: tag 0x20d0 value 0x0
WARNING: unknown GLX tag from server: tag 0x20d1 value 0x0
WARNING: unknown GLX tag from server: tag 0x20d2 value 0x0
WARNING: unknown GLX tag from server: tag 0x20d3 value 0x0
WARNING: unknown GLX tag from server: tag 0x20d0 value 0x0
WARNING: unknown GLX tag from server: tag 0x20d1 value 0x0
WARNING: unknown GLX tag from server: tag 0x20d2 value 0x0
WARNING: unknown GLX tag from server: tag 0x20d3 value 0x0
WARNING: unknown GLX tag from server: tag 0x20d0 value 0x0
WARNING: unknown GLX tag from server: tag 0x20d1 value 0x0
WARNING: unknown GLX tag from server: tag 0x20d2 value 0x0
WARNING: unknown GLX tag from server: tag 0x20d3 value 0x0
WARNING: unknown GLX tag from server: tag 0x20d0 value 0x0
WARNING: unknown GLX tag from server: tag 0x20d1 value 0x0
WARNING: unknown GLX tag from server: tag 0x20d2 value 0x0
WARNING: unknown GLX tag from server: tag 0x20d3 value 0x0
WARNING: unknown GLX tag from server: tag 0x20d0 value 0x0
WARNING: unknown GLX tag from server: tag 0x20d1 value 0x0
WARNING: unknown GLX tag from server: tag 0x20d2 value 0x0
WARNING: unknown GLX tag from server: tag 0x20d3 value 0x0
WARNING: unknown GLX tag from server: tag 0x20d0 value 0x0
WARNING: unknown GLX tag from server: tag 0x20d1 value 0x0
WARNING: unknown GLX tag from server: tag 0x20d2 value 0x0
WARNING: unknown GLX tag from server: tag 0x20d3 value 0x0
WARNING: unknown GLX tag from server: tag 0x20d0 value 0x0
WARNING: unknown GLX tag from server: tag 0x20d1 value 0x0
WARNING: unknown GLX tag from server: tag 0x20d2 value 0x0
WARNING: unknown GLX tag from server: tag 0x20d3 value 0x0
WARNING: unknown GLX tag from server: tag 0x20d0 value 0x0
WARNING: unknown GLX tag from server: tag 0x20d1 value 0x0
WARNING: unknown GLX tag from server: tag 0x20d2 value 0x0
WARNING: unknown GLX tag from server: tag 0x20d3 value 0x0
WARNING: unknown GLX tag from server: tag 0x20d0 value 0x0
WARNING: unknown GLX tag from server: tag 0x20d1 value 0x0
WARNING: unknown GLX tag from server: tag 0x20d2 value 0x0
WARNING: unknown GLX tag from server: tag 0x20d3 value 0x0
WARNING: unknown GLX tag from server: tag 0x20d0 value 0x0
WARNING: unknown GLX tag from server: tag 0x20d1 value 0x0
WARNING: unknown GLX tag from server: tag 0x20d2 value 0x0
WARNING: unknown GLX tag from server: tag 0x20d3 value 0x0
WARNING: unknown GLX tag from server: tag 0x20d0 value 0x0
WARNING: unknown GLX tag from server: tag 0x20d1 value 0x0
WARNING: unknown GLX tag from server: tag 0x20d2 value 0x0
WARNING: unknown GLX tag from server: tag 0x20d3 value 0x0
WARNING: unknown GLX tag from server: tag 0x20d0 value 0x0
WARNING: unknown GLX tag from server: tag 0x20d1 value 0x0
WARNING: unknown GLX tag from server: tag 0x20d2 value 0x0
WARNING: unknown GLX tag from server: tag 0x20d3 value 0x0
WARNING: unknown GLX tag from server: tag 0x20d0 value 0x0
WARNING: unknown GLX tag from server: tag 0x20d1 value 0x0
WARNING: unknown GLX tag from server: tag 0x20d2 value 0x0
WARNING: unknown GLX tag from server: tag 0x20d3 value 0x0
WARNING: unknown GLX tag from server: tag 0x20d0 value 0x0
WARNING: unknown GLX tag from server: tag 0x20d1 value 0x0
WARNING: unknown GLX tag from server: tag 0x20d2 value 0x0
WARNING: unknown GLX tag from server: tag 0x20d3 value 0x0
WARNING: unknown GLX tag from server: tag 0x20d0 value 0x0
WARNING: unknown GLX tag from server: tag 0x20d1 value 0x0
WARNING: unknown GLX tag from server: tag 0x20d2 value 0x0
WARNING: unknown GLX tag from server: tag 0x20d3 value 0x0
WARNING: unknown GLX tag from server: tag 0x20d0 value 0x0
WARNING: unknown GLX tag from server: tag 0x20d1 value 0x0
WARNING: unknown GLX tag from server: tag 0x20d2 value 0x0
WARNING: unknown GLX tag from server: tag 0x20d3 value 0x0
WARNING: unknown GLX tag from server: tag 0x20d0 value 0x0
WARNING: unknown GLX tag from server: tag 0x20d1 value 0x0
WARNING: unknown GLX tag from server: tag 0x20d2 value 0x0
WARNING: unknown GLX tag from server: tag 0x20d3 value 0x0
WARNING: unknown GLX tag from server: tag 0x20d0 value 0x0
WARNING: unknown GLX tag from server: tag 0x20d1 value 0x0
WARNING: unknown GLX tag from server: tag 0x20d2 value 0x0
WARNING: unknown GLX tag from server: tag 0x20d3 value 0x0
WARNING: unknown GLX tag from server: tag 0x20d0 value 0x0
WARNING: unknown GLX tag from server: tag 0x20d1 value 0x0
WARNING: unknown GLX tag from server: tag 0x20d2 value 0x0
WARNING: unknown GLX tag from server: tag 0x20d3 value 0x0
WARNING: unknown GLX tag from server: tag 0x20d0 value 0x0
WARNING: unknown GLX tag from server: tag 0x20d1 value 0x0
WARNING: unknown GLX tag from server: tag 0x20d2 value 0x0
WARNING: unknown GLX tag from server: tag 0x20d3 value 0x0
WARNING: unknown GLX tag from server: tag 0x20d0 value 0x0
WARNING: unknown GLX tag from server: tag 0x20d1 value 0x0
WARNING: unknown GLX tag from server: tag 0x20d2 value 0x0
WARNING: unknown GLX tag from server: tag 0x20d3 value 0x0
WARNING: unknown GLX tag from server: tag 0x20d0 value 0x0
WARNING: unknown GLX tag from server: tag 0x20d1 value 0x0
WARNING: unknown GLX tag from server: tag 0x20d2 value 0x0
WARNING: unknown GLX tag from server: tag 0x20d3 value 0x0
WARNING: unknown GLX tag from server: tag 0x20d0 value 0x0
WARNING: unknown GLX tag from server: tag 0x20d1 value 0x0
WARNING: unknown GLX tag from server: tag 0x20d2 value 0x0
WARNING: unknown GLX tag from server: tag 0x20d3 value 0x0
WARNING: unknown GLX tag from server: tag 0x20d0 value 0x0
WARNING: unknown GLX tag from server: tag 0x20d1 value 0x0
WARNING: unknown GLX tag from server: tag 0x20d2 value 0x0
WARNING: unknown GLX tag from server: tag 0x20d3 value 0x0
WARNING: unknown GLX tag from server: tag 0x20d0 value 0x0
WARNING: unknown GLX tag from server: tag 0x20d1 value 0x0
WARNING: unknown GLX tag from server: tag 0x20d2 value 0x0
WARNING: unknown GLX tag from server: tag 0x20d3 value 0x0
WARNING: unknown GLX tag from server: tag 0x20d0 value 0x0
WARNING: unknown GLX tag from server: tag 0x20d1 value 0x0
WARNING: unknown GLX tag from server: tag 0x20d2 value 0x0
WARNING: unknown GLX tag from server: tag 0x20d3 value 0x0
WARNING: unknown GLX tag from server: tag 0x20d0 value 0x0
WARNING: unknown GLX tag from server: tag 0x20d1 value 0x0
WARNING: unknown GLX tag from server: tag 0x20d2 value 0x0
WARNING: unknown GLX tag from server: tag 0x20d3 value 0x0
WARNING: unknown GLX tag from server: tag 0x20d0 value 0x0
WARNING: unknown GLX tag from server: tag 0x20d1 value 0x0
WARNING: unknown GLX tag from server: tag 0x20d2 value 0x0
WARNING: unknown GLX tag from server: tag 0x20d3 value 0x0
WARNING: unknown GLX tag from server: tag 0x20d0 value 0x0
WARNING: unknown GLX tag from server: tag 0x20d1 value 0x0
WARNING: unknown GLX tag from server: tag 0x20d2 value 0x0
WARNING: unknown GLX tag from server: tag 0x20d3 value 0x0
WARNING: unknown GLX tag from server: tag 0x20d0 value 0x0
WARNING: unknown GLX tag from server: tag 0x20d1 value 0x0
WARNING: unknown GLX tag from server: tag 0x20d2 value 0x0
WARNING: unknown GLX tag from server: tag 0x20d3 value 0x0
WARNING: unknown GLX tag from server: tag 0x20d0 value 0x0
WARNING: unknown GLX tag from server: tag 0x20d1 value 0x0
WARNING: unknown GLX tag from server: tag 0x20d2 value 0x0
WARNING: unknown GLX tag from server: tag 0x20d3 value 0x0
WARNING: unknown GLX tag from server: tag 0x20d0 value 0x0
WARNING: unknown GLX tag from server: tag 0x20d1 value 0x0
WARNING: unknown GLX tag from server: tag 0x20d2 value 0x0
WARNING: unknown GLX tag from server: tag 0x20d3 value 0x0
WARNING: unknown GLX tag from server: tag 0x20d0 value 0x0
WARNING: unknown GLX tag from server: tag 0x20d1 value 0x0
WARNING: unknown GLX tag from server: tag 0x20d2 value 0x0
WARNING: unknown GLX tag from server: tag 0x20d3 value 0x0
WARNING: unknown GLX tag from server: tag 0x20d0 value 0x0
WARNING: unknown GLX tag from server: tag 0x20d1 value 0x0
WARNING: unknown GLX tag from server: tag 0x20d2 value 0x0
WARNING: unknown GLX tag from server: tag 0x20d3 value 0x0
WARNING: unknown GLX tag from server: tag 0x20d0 value 0x0
WARNING: unknown GLX tag from server: tag 0x20d1 value 0x0
WARNING: unknown GLX tag from server: tag 0x20d2 value 0x0
WARNING: unknown GLX tag from server: tag 0x20d3 value 0x0
WARNING: unknown GLX tag from server: tag 0x20d0 value 0x0
WARNING: unknown GLX tag from server: tag 0x20d1 value 0x0
WARNING: unknown GLX tag from server: tag 0x20d2 value 0x0
WARNING: unknown GLX tag from server: tag 0x20d3 value 0x0
WARNING: unknown GLX tag from server: tag 0x20d0 value 0x0
WARNING: unknown GLX tag from server: tag 0x20d1 value 0x0
WARNING: unknown GLX tag from server: tag 0x20d2 value 0x0
WARNING: unknown GLX tag from server: tag 0x20d3 value 0x0
WARNING: unknown GLX tag from server: tag 0x20d0 value 0x0
WARNING: unknown GLX tag from server: tag 0x20d1 value 0x0
WARNING: unknown GLX tag from server: tag 0x20d2 value 0x0
WARNING: unknown GLX tag from server: tag 0x20d3 value 0x0
WARNING: unknown GLX tag from server: tag 0x20d0 value 0x0
WARNING: unknown GLX tag from server: tag 0x20d1 value 0x0
WARNING: unknown GLX tag from server: tag 0x20d2 value 0x0
WARNING: unknown GLX tag from server: tag 0x20d3 value 0x0
WARNING: unknown GLX tag from server: tag 0x20d0 value 0x0
WARNING: unknown GLX tag from server: tag 0x20d1 value 0x0
WARNING: unknown GLX tag from server: tag 0x20d2 value 0x0
WARNING: unknown GLX tag from server: tag 0x20d3 value 0x0
WARNING: unknown GLX tag from server: tag 0x20d0 value 0x0
WARNING: unknown GLX tag from server: tag 0x20d1 value 0x0
WARNING: unknown GLX tag from server: tag 0x20d2 value 0x0
WARNING: unknown GLX tag from server: tag 0x20d3 value 0x0
WARNING: unknown GLX tag from server: tag 0x20d0 value 0x0
WARNING: unknown GLX tag from server: tag 0x20d1 value 0x0
WARNING: unknown GLX tag from server: tag 0x20d2 value 0x0
WARNING: unknown GLX tag from server: tag 0x20d3 value 0x0
WARNING: unknown GLX tag from server: tag 0x20d0 value 0x0
WARNING: unknown GLX tag from server: tag 0x20d1 value 0x0
WARNING: unknown GLX tag from server: tag 0x20d2 value 0x0
WARNING: unknown GLX tag from server: tag 0x20d3 value 0x0
WARNING: unknown GLX tag from server: tag 0x20d0 value 0x0
WARNING: unknown GLX tag from server: tag 0x20d1 value 0x0
WARNING: unknown GLX tag from server: tag 0x20d2 value 0x0
WARNING: unknown GLX tag from server: tag 0x20d3 value 0x0
WARNING: unknown GLX tag from server: tag 0x20d0 value 0x0
WARNING: unknown GLX tag from server: tag 0x20d1 value 0x0
WARNING: unknown GLX tag from server: tag 0x20d2 value 0x0
WARNING: unknown GLX tag from server: tag 0x20d3 value 0x0
WARNING: unknown GLX tag from server: tag 0x20d0 value 0x0
WARNING: unknown GLX tag from server: tag 0x20d1 value 0x0
WARNING: unknown GLX tag from server: tag 0x20d2 value 0x0
WARNING: unknown GLX tag from server: tag 0x20d3 value 0x0
WARNING: unknown GLX tag from server: tag 0x20d0 value 0x0
WARNING: unknown GLX tag from server: tag 0x20d1 value 0x0
WARNING: unknown GLX tag from server: tag 0x20d2 value 0x0
WARNING: unknown GLX tag from server: tag 0x20d3 value 0x0
WARNING: unknown GLX tag from server: tag 0x20d0 value 0x0
WARNING: unknown GLX tag from server: tag 0x20d1 value 0x0
WARNING: unknown GLX tag from server: tag 0x20d2 value 0x0
WARNING: unknown GLX tag from server: tag 0x20d3 value 0x0
WARNING: unknown GLX tag from server: tag 0x20d0 value 0x0
WARNING: unknown GLX tag from server: tag 0x20d1 value 0x0
WARNING: unknown GLX tag from server: tag 0x20d2 value 0x0
WARNING: unknown GLX tag from server: tag 0x20d3 value 0x0
WARNING: unknown GLX tag from server: tag 0x20d0 value 0x0
WARNING: unknown GLX tag from server: tag 0x20d1 value 0x0
WARNING: unknown GLX tag from server: tag 0x20d2 value 0x0
WARNING: unknown GLX tag from server: tag 0x20d3 value 0x0
WARNING: unknown GLX tag from server: tag 0x20d0 value 0x0
WARNING: unknown GLX tag from server: tag 0x20d1 value 0x0
WARNING: unknown GLX tag from server: tag 0x20d2 value 0x0
WARNING: unknown GLX tag from server: tag 0x20d3 value 0x0
WARNING: unknown GLX tag from server: tag 0x20d0 value 0x0
WARNING: unknown GLX tag from server: tag 0x20d1 value 0x0
WARNING: unknown GLX tag from server: tag 0x20d2 value 0x0
WARNING: unknown GLX tag from server: tag 0x20d3 value 0x0
WARNING: unknown GLX tag from server: tag 0x20d0 value 0x0
WARNING: unknown GLX tag from server: tag 0x20d1 value 0x0
WARNING: unknown GLX tag from server: tag 0x20d2 value 0x0
WARNING: unknown GLX tag from server: tag 0x20d3 value 0x0
WARNING: unknown GLX tag from server: tag 0x20d0 value 0x0
WARNING: unknown GLX tag from server: tag 0x20d1 value 0x0
WARNING: unknown GLX tag from server: tag 0x20d2 value 0x0
WARNING: unknown GLX tag from server: tag 0x20d3 value 0x0
WARNING: unknown GLX tag from server: tag 0x20d0 value 0x0
WARNING: unknown GLX tag from server: tag 0x20d1 value 0x0
WARNING: unknown GLX tag from server: tag 0x20d2 value 0x0
WARNING: unknown GLX tag from server: tag 0x20d3 value 0x0
WARNING: unknown GLX tag from server: tag 0x20d0 value 0x0
WARNING: unknown GLX tag from server: tag 0x20d1 value 0x0
WARNING: unknown GLX tag from server: tag 0x20d2 value 0x0
WARNING: unknown GLX tag from server: tag 0x20d3 value 0x0
WARNING: unknown GLX tag from server: tag 0x20d0 value 0x0
WARNING: unknown GLX tag from server: tag 0x20d1 value 0x0
WARNING: unknown GLX tag from server: tag 0x20d2 value 0x0
WARNING: unknown GLX tag from server: tag 0x20d3 value 0x0
WARNING: unknown GLX tag from server: tag 0x20d0 value 0x0
WARNING: unknown GLX tag from server: tag 0x20d1 value 0x0
WARNING: unknown GLX tag from server: tag 0x20d2 value 0x0
WARNING: unknown GLX tag from server: tag 0x20d3 value 0x0
WARNING: unknown GLX tag from server: tag 0x20d0 value 0x0
WARNING: unknown GLX tag from server: tag 0x20d1 value 0x0
WARNING: unknown GLX tag from server: tag 0x20d2 value 0x0
WARNING: unknown GLX tag from server: tag 0x20d3 value 0x0
WARNING: unknown GLX tag from server: tag 0x20d0 value 0x0
WARNING: unknown GLX tag from server: tag 0x20d1 value 0x0
WARNING: unknown GLX tag from server: tag 0x20d2 value 0x0
WARNING: unknown GLX tag from server: tag 0x20d3 value 0x0
WARNING: unknown GLX tag from server: tag 0x20d0 value 0x0
WARNING: unknown GLX tag from server: tag 0x20d1 value 0x0
WARNING: unknown GLX tag from server: tag 0x20d2 value 0x0
WARNING: unknown GLX tag from server: tag 0x20d3 value 0x0
Debug          apple_glx_context.c:202  apple_glx_create_context(1109370880): apple_glx_create_context: ac 0x40486af0 ac->context_obj 0x40a13200
Debug         apple_glx_drawable.c:342  apple_glx_drawable_create(1109370880): apple_glx_drawable_create: new drawable 0x40a8c800
Debug          apple_glx_surface.c:154  create_surface(1109370880): create_surface: created a surface for drawable 0x600016 with uid 17
Debug          apple_glx_surface.c:69   surface_make_current(1109370880): surface_make_current: ac->context_obj 0x40a13200 s->surface_id 5
Debug          apple_glx_surface.c:89   surface_make_current(1109370880): surface_make_current: drawable 0x600016
Debug             ../applegl_glx.c:60   applegl_bind_context(1109370880): applegl_bind_context: error NO
Debug          apple_glx_context.c:540  apple_glx_context_surface_changed(1109370880): caller is the same thread for uid 17
Debug                  apple_glx.c:74   surface_notify_handler(1109370880): surface notify updated 0
Debug         apple_glx_drawable.c:206  destroy_drawable_callback(1109370880): destroy_drawable_callback: 0x40a8c800 ->reference_count before -- 2
Debug             ../applegl_glx.c:89   applegl_unbind_context(1109370880): applegl_unbind_context: error NO
Debug          apple_glx_context.c:218  apple_glx_destroy_context(1109370880): apple_glx_destroy_context: ac 0x40486af0 ac->context_obj 0x40a13200
Debug                  apple_glx.c:65   surface_notify_handler(1109370880): surface_notify_handler: surface destroyed 17
Debug         apple_glx_drawable.c:206  destroy_drawable_callback(1109370880): destroy_drawable_callback: 0x40a8c800 ->reference_count before -- 1
Debug          apple_glx_surface.c:99   surface_destroy(1109370880): surface_destroy: s->surface_id 5
Debug         apple_glx_drawable.c:175  destroy_drawable(1109370880): destroy_drawable: freeing 0x40a8c800
wine: Unhandled page fault on read access to 0xffffffff at address 0x7bc6168e (thread 0009), starting debugger...
err:seh:raise_exception Unhandled exception code c0000005 flags 0 addr 0x7b824157
err:seh:raise_exception Unhandled exception code c0000005 flags 0 addr 0x7bc60bb9

jeremyhu@… commented on Jun 1, 2012

  • Status changed from reopened to closed
  • Milestone changed from 2.7.3 to 2.7.2
  • Resolution set to fixed

What you are reporting now does not seem to be the original report. The original report was about GLXMakeContextCurrent returning an error, but your latest comment shows a crash, which may or may not be related to GLX. You may be seeing this crash *because* the reported issue is now fixed (and thus you are progressing past the error). I don't see anything here which actually indicates that the GLXMakeContextCurrent issue is still present.

I am closing this issue, since it seems the originally reported issue is actually addressed.

@qvantvm: Have you tested your windows binary on Linux with the same version of wine? Are you sure that it is a bug in our libGL? If so, please reopen with a new bug report with information specific to your case.


qvantvm@… commented on Jun 2, 2012

  • Status changed from closed to reopened
  • Resolution fixed deleted

Hi Jeremy, after some effort eventually I succeeded to compile a fully functional copy of the latest wine for os lion! I tested it with several windows app (using OpenGL in main windows) and it worked. Nevertheless I still have problem when OpenGL draws on a child and here is the log obtained:

wine "/Users/qvantvm/Documents/xTAStudio/Tools/Visualizer/Debug/ChartDlg.exe"
Info                   apple_glx.c:116  apple_init_glx(1092603392): Initializing libGL.Debug                  apple_cgl.c:92   apple_cgl_init(1092603392): CGL major 1 minor 2
WARNING: unknown GLX tag from server: tag 0x20d0 value 0x0
WARNING: unknown GLX tag from server: tag 0x20d1 value 0x0
                         ....
WARNING: unknown GLX tag from server: tag 0x20d2 value 0x0
Debug          apple_glx_context.c:202  apple_glx_create_context(1092603392): apple_glx_create_context: ac 0x418775e0 ac->context_obj 0x40a14800
Debug         apple_glx_drawable.c:342  apple_glx_drawable_create(1092603392): apple_glx_drawable_create: new drawable 0x40a8e200
Debug          apple_glx_surface.c:154  create_surface(1092603392): create_surface: created a surface for drawable 0x100007f with uid 13
Debug          apple_glx_surface.c:69   surface_make_current(1092603392): surface_make_current: ac->context_obj 0x40a14800 s->surface_id 5
Debug          apple_glx_surface.c:89   surface_make_current(1092603392): surface_make_current: drawable 0x100007f
Debug             ../applegl_glx.c:60   applegl_bind_context(1092603392): applegl_bind_context: error NO
Debug          apple_glx_context.c:540  apple_glx_context_surface_changed(1092603392): caller is the same thread for uid 13
Debug                  apple_glx.c:74   surface_notify_handler(1092603392): surface notify updated 0
Debug         apple_glx_drawable.c:206  destroy_drawable_callback(1092603392): destroy_drawable_callback: 0x40a8e200 ->reference_count before -- 2
Debug             ../applegl_glx.c:89   applegl_unbind_context(1092603392): applegl_unbind_context: error NO
Debug          apple_glx_context.c:218  apple_glx_destroy_context(1092603392): apple_glx_destroy_context: ac 0x418775e0 ac->context_obj 0x40a14800
Debug                  apple_glx.c:65   surface_notify_handler(1092603392): surface_notify_handler: surface destroyed 13
Debug         apple_glx_drawable.c:206  destroy_drawable_callback(1092603392): destroy_drawable_callback: 0x40a8e200 ->reference_count before -- 1
Debug          apple_glx_surface.c:99   surface_destroy(1092603392): surface_destroy: s->surface_id 5
Debug         apple_glx_drawable.c:175  destroy_drawable(1092603392): destroy_drawable: freeing 0x40a8e200
Debug         apple_glx_drawable.c:342  apple_glx_drawable_create(1092603392): apple_glx_drawable_create: new drawable 0x41220000
Debug               apple_visual.c:84   apple_visual_create_pfobj(1092603392): offscreen rendering enabled.  Using kCGLPFAOffScreen
Debug           apple_glx_pixmap.c:182  apple_glx_pixmap_create(1092603392): created: pixmap buffer for 0x1000096
Debug          apple_glx_context.c:202  apple_glx_create_context(1092603392): apple_glx_create_context: ac 0x4187e1c0 ac->context_obj 0x41220a00
set off screen: invalid drawable
Debug             ../applegl_glx.c:60   applegl_bind_context(1092603392): applegl_bind_context: error YES
X Error of failed request:  0
  Major opcode of failed request:  149 (GLX)
  Minor opcode of failed request:  26 (X_GLXMakeContextCurrent)
  Serial number of failed request:  594
  Current serial number in output stream:  594

I have also tested the same windows app with Wine on Ubuntu and it worked. Regards.


jeremyhu@… commented on Jun 2, 2012

"set off screen: invalid drawable" corresponds to GLXPixmap being used. That is an error message from CGLSetOffscreen


qvantvm@… commented on Jun 3, 2012

I see, is there any workaround or do you have any solution for that?


jeremyhu@… commented on Jun 4, 2012

  • Status changed from reopened to new
  • Milestone changed from 2.7.2 to 2.7.3

There is no workaround. The above were just notes to myself based on my investigation.

Also, this looks to be the same issue Ken Thomases reported in <rdar://problem/6833288>. I'm able to use the mfcfog.exe provided in that radar to reproduce the issue.


jeremyhu@… commented on Jun 4, 2012

  • Status changed from new to assigned

jeremyhu@… commented on Jul 12, 2012

  • Milestone changed from 2.7.3 to 2.7.4

jonas.maebe@… commented on Sep 9, 2012

  • Cc jonas.maebe@… added

jonas.maebe@… commented on Sep 9, 2012

Here are some things I found out. Everything pertains to apple_visual_create_pfobj() in mesa/src/glx/apple/apple_visual.c

  • when offscreen rendering is requested, the kCGLPFAColorSize is specified twice: once together with kCGLPFAOffScreen as a hardcoded 32, and then again later on as the sum "mode->redBits + mode->greenBits + mode->blueBits". Disabling either the former or the latter in case offscreen is true does not solve the problem.

And now, what fixes the problem for me with the glWin.exe program: apparently, OpenGL doesn't like you asking for a double-buffered offscreen pixel format. All things considered, it does sound like a bit wasteful to do so :) I'll attach the patch.


jonas.maebe@… commented on Sep 9, 2012

Mesa patch to not create double-buffered offscreen pixel formats


jeremyhu@… commented on Sep 9, 2012

X11 has an exception regarding kCGLPFAOffScreen.

I'm a bit taxed at the moment, but I'll take a look at your patch and respond to the rest later this week.


jeremyhu@… commented on Sep 9, 2012

If I forget, please pester me ;)


jeremyhu@… commented on Sep 9, 2012

  • Milestone changed from 2.7.5 to 2.7.4

jonas.maebe@… commented on Sep 14, 2012

Replying to jeremyhu@…:

If I forget, please pester me ;)

Ping :)


jonas.maebe@… commented on Sep 17, 2012

I also just noticed that I erroneously referred to ticket 512 instead of 536 in the commit message.


jeremyhu@… commented on Sep 20, 2012

  • Milestone changed from 2.7.4 to 2.7.5

I need to get 2.7.4 out to address a critical issue seen in OS X 10.8.2 and 10.7.5, so deferring everything that is not a regression.


jeremyhu@… commented on Sep 24, 2012

  • Status changed from assigned to closed
  • Milestone changed from 2.7.5 to 2.7.4
  • Resolution set to fixed

http://cgit.freedesktop.org/mesa/mesa/commit/?id=5fdf1f784bf449d7ce9839506fa23c5357696c4c

This will be in either 2.7.4_rc2 or 2.7.4 depending on whether or not I decide to do another rc.


jeremyhu@… commented on Sep 24, 2012

Also now fixed in MacPorts.


jonas.maebe@… commented on Sep 25, 2012

Thanks! When you have a bit more time, could you perhaps also comment on the double kCGLPFAColorSize usage for offscreens?


jeremyhu@… commented on Sep 25, 2012

So looking through svn history shows that the double-specified kCGLPFAColorSize for offscreen has been there since before I inherited the code ... it certainly looks wrong, so I'll look into it (would you mind opening another ticket)


jonas.maebe@… commented on Sep 25, 2012

Ok, done!


qvantvm@… commented on Sep 29, 2012

Thank you jeremy and jonas for your effort in solving this ticket. I have a last question for Jonas: With regards to the glWin.exe program which you mentioned some post ago now it does not crash anymore but it has a lot of flickering is this an effect of the solution? You too found a similar behaviour? And just in case Have you found a workaround for flickering?


jonas.maebe@… commented on Sep 30, 2012

Yes, I also see the flickering. I have no idea what it is caused by, and have not looked for a workaround. Does it not happen under Linux?


qvantvm@… commented on Sep 30, 2012

No it doesn't happen on Linux. Maybe I found a possible answer: the thread that draws into the OpenGL child window is too fast. (Some sort of synchronisation issue). If you change the Sleep time into the thread running function from 1 to let's say 50 the flicker disappears, indeed.

I think this is not related to this ticket.


jeremyhu@… commented on Sep 30, 2012

Yeah, that's an issue with the application. It should synchronize rendering to and reading from that buffer


jonas.maebe@… commented on Oct 1, 2012

It's also sort of a wine bug. MSDN says that sleep always suspends the application's current time slice. Linux' glibc also always calls the kernel when a program calls nanosleep, which is probably what's used to implement sleep. On Mac OS X, very small wait intervals are however handled by spinning in user space. As a result, the program will loop much faster under Mac OS X than under Windows and Linux/wine.

Wine should probably be changed to force a call to sched_yield() or so on Mac OS X in case of very small sleep intervals. I can't think of a way to ensure in a robust way that this will only happen nanosleep won't call the kernel though (since the boundary conditions in the C library can change at any time).


sparr0@… commented on Apr 22, 2016

  • Status changed from closed to reopened
  • Resolution Fixed deleted

This bug may be back, in OSX 10.9 or 10.10. I hope I'm not overstepping by reopening this ticket.

I am seeing behavior that appears to be this bug while running VCarve 8 Pro Trial (http://www.vectric.com/products/vcarve/trial.html) in Wine, with this output in the X11 logs:

set off screen: invalid drawable X Error of failed request: 0

Major opcode of failed request: 148 (GLX) Minor opcode of failed request: 26 (X_GLXMakeContextCurrent) Serial number of failed request: 7858 Current serial number in output stream: 7858

Someone also posted about this elsewhere about a year ago, for a non-wine process: https://www.nitrc.org/forum/forum.php?thread_id=5397&forum_id=166


jeremyhu@… commented on May 31, 2016

  • Status changed from reopened to closed
  • Resolution set to Fixed

sparr0, if you are having issues, please file a bug in the current bug tracker discussing your issue rather than opening ancient bugs in a tracker that we don't use any more.

See https://www.xquartz.org/Bug-Reporting.html