Skip to content
This repository has been archived by the owner. It is now read-only.
Permalink
master
Switch branches/tags
Go to file
 
 
Cannot retrieve contributors at this time
original_url created_at updated_at closed_at status type resolution reporter owner priority milestone component keywords
2012-03-11 14:54:18 -0700
2015-08-13 02:03:08 -0700
2012-03-26 20:34:16 -0700
closed
usability
Fixed
e.g.marklund@…
jeremyhu@…
Blocker
2.7.2
xserver
Input device, mouse pointer

Mouse pointer is not aligned with the point where the click occurs in 2.7.2 beta1/2

The mouse pointer is be positioned higher than the point where the click occurs. I noticed this when launching Gimp after the upgrade to 2.7.2 beta and thought my Wacom Intuos 3 was misbehaving. It means for instance that I have to click above the menus to open them. It works fine again when downgrading to 2.7.1.


jeremyhu@… commented on Mar 12, 2012

  • Status changed from new to assigned
  • Priority changed from Not Set to Blocker

Can you try isolating the cause for me? With 2.7.1 installed, backup the server binary:

cd /Applications/Utilities/XQuartz.app/Contents/MacOS/
sudo cp X11.bin X11.bin-2.7.1

Next, install XQuartz-2.7.2_beta2, then restore the old server binary:

cd /Applications/Utilities/XQuartz.app/Contents/MacOS/
sudo cp X11.bin X11.bin-2.7.2_beta2
sudo cp X11.bin-2.7.1 X11.bin

If it works, this means it's a server issue. If it still fails, then it's probably a client issue.


joelbrownstein@… commented on Mar 12, 2012

The problem with the cursor coordinates in 2.7.2_beta2 vanished after cp X11.bin-2.7.1 -> X11.bin as you suggested -- this means it's a server issue.


e.g.marklund@… commented on Mar 12, 2012

Replying to jeremyhu@…:

Can you try isolating the cause for me? With 2.7.1 installed, backup the server binary:

cd /Applications/Utilities/XQuartz.app/Contents/MacOS/
sudo cp X11.bin X11.bin-2.7.1

Next, install XQuartz-2.7.2_beta2, then restore the old server binary:

cd /Applications/Utilities/XQuartz.app/Contents/MacOS/
sudo cp X11.bin X11.bin-2.7.2_beta2
sudo cp X11.bin-2.7.1 X11.bin

If it works, this means it's a server issue. If it still fails, then it's probably a client issue.

It works with both mouse and intuos if I do what you outlined, suggesting it is a server issue.

I was wrong initially. The mouse works as it should also with the plain 2.7.2_beta2, but my Wacom Intuos 3 is off vertically by 20 pixels or so with 2.7.2_beta1/2, which wasn't the case with 2.7.1. Sorry about the confusion.


charlie.clark@… commented on Mar 18, 2012

I can confirm this bug in combination with a Wacom graphics tablet (Bamboo). Reverting to 2.7.1 resolves the problem. The problem does not occur when using the mouse.


joelbrownstein@… commented on Mar 21, 2012

The problem is still there in beta3 using wacom intuos3 with mouse.


jeremyhu@… commented on Mar 25, 2012

I have a fix for this. Please try beta4 when it is out (probably next weekend-ish).


jeremyhu@… commented on Mar 26, 2012

  • Status changed from assigned to closed
  • Resolution changed from to fixed

http://cgit.freedesktop.org/xorg/xserver/commit/?id=74fb534bf15687610367248071341fe4bfd1d8bf


joelbrownstein@… commented on Apr 11, 2012

Fixed in beta4 -- thanks!