Skip to content
Permalink
Branch: master
Find file Copy path
Find file Copy path
Fetching contributors…
Cannot retrieve contributors at this time
91 lines (54 sloc) 2.69 KB
original_url created_at updated_at closed_at status type resolution reporter owner priority milestone component version cc
2013-08-13 15:32:41 -0700
2015-10-17 11:07:23 -0700
2015-10-17 11:07:23 -0700
closed
usability
Cannot Reproduce
umalhi@…
jeremyhu@…
Important
later
pbproxy
2.7.4 (xserver-1.13.0)
keithbsmiley@…

Mac Pasteboard and X11 Clipboard do not sync

PLATFORM: OS X 10.8.4 Terminal 2.3 (309) Xquartz 2.7.4 (Xorg-server 1.13.0) xclip 0.12 - http://sourceforge.net/projects/xclip

RELEVANT SETTINGS: *For Quartz, under Pasteboard the following are checked:

Enable Checking, Update Pasteboard when CLIPBOARD changes, Update CLIPBOARD when Pasteboard changes, Update PRIMARY when pasteboard changes, Update Pasteboard immediately

  • Xclip is configured as ./configure CPPFLAGS=-I/opt/X11/include LDFLAGS=-L/opt/X11/lib. Notice u may have to create a soft link at /usr/include/x11 pointing too /opt/X11/include/X11

STEPS TO REPRODUCE:

  1. Start Xquartz
  2. Start terminal

3 (Optional). echo $DISPLAY to verify it is set correctly. Mine DISPLAY is set to /tmp/launch-c8RgwI/org.macosforge.xquartz:0

  1. Copy something into mac clipboard via Ctrl C
  2. Run xclip -o on the terminal and observed that the it thinks the X11 CLIPBOARD is empty. (I had originally observed the problem with vim with clipboard sharing. Running xclip to simplfy reproduction)
  3. Run xclip -i <input> and notice that does not syc to clipboard

*Steps 5 and 6 is the bug*

  1. Run xclock from terminal
  2. Repeat 4 to 5 (Multiple times to reassure oneself if needed). Notice that now, "xclip -o" will correct output content that was copied via Cmd-C into Mac clipboard.

jeremyhu@… commented on Nov 15, 2013

  • Milestone changed from 2.7.5 to 2.7.6

jeremyhu@… commented on Apr 6, 2014

  • Priority changed from Blocker to Important
  • Component changed from xserver to pbproxy
  • Milestone changed from 2.7.6 to later

keithbsmiley@… commented on Mar 3, 2015

  • Cc keithbsmiley@… added

jeremyhu@… commented on Oct 17, 2015

  • Status changed from new to closed
  • Resolution set to Cannot Reproduce

At step 5, it pastes what I copied.

You can’t perform that action at this time.