No description or website provided.
PHP
Fetching latest commit…
Cannot retrieve the latest commit at this time.
Permalink
Failed to load latest commit information.
examples
lib
.gitignore
README.md
composer.json
init.php

README.md

Xfers PHP bindings

You can sign up for a Xfers account at https://xfers.io.

Requirements

PHP 5.3.3 and later.

Composer

You can install the bindings via Composer. Run the following command:

composer require xfers/xfers-php

To use the bindings, use Composer's autoload:

require_once('vendor/autoload.php');

Manual Installation

If you do not wish to use Composer, you can download the latest release. Then, to use the bindings, include the init.php file.

require_once('/path/to/xfers-php/init.php');

Dependencies

The bindings require the following extension in order to work properly:

  • curl, although you can use your own non-cURL client if you prefer
  • json

If you use Composer, these dependencies should be handled automatically. If you install manually, you'll want to make sure that these extensions are available.

Getting Started

Simple usage looks like:

\Xfers\Xfers::setApiKey('ENfbme3sus9EjgzXDHoV8W9-MXPj25e4udYst2CGync');
\Xfers\Xfers::setSGSandbox();
$resp = \Xfers\User::retrieve();
print_r($resp);

Documentation

Please see http://docs.xfers.io/ for up-to-date documentation.