Skip to content
New issue

Have a question about this project? Sign up for a free GitHub account to open an issue and contact its maintainers and the community.

By clicking “Sign up for GitHub”, you agree to our terms of service and privacy statement. We’ll occasionally send you account related emails.

Already on GitHub? Sign in to your account

Error install Siberian CMS #253

Closed
satyakresna opened this issue Mar 29, 2017 · 34 comments

Comments

@satyakresna
Copy link

commented Mar 29, 2017

Hi, I have a problem install Siberian CMS SAE especially when I want to go to Installation step after fill the database name, username, host, and password, it says error like this screenshot.
screenshot 2017-03-28 22 21 32

I already read the documentation if during the connection to the database, if I get a message “error”, I must contact with my hosting provider. I already do that and they already do their best. But, when I tried, it same again like that screenshot before.

Please your advice. Thank you.

@SiberianCMS

This comment has been minimized.

Copy link
Contributor

commented Mar 29, 2017

You can check if .htaccess file is used, otherwise it won't work.

@satyakresna

This comment has been minimized.

Copy link
Author

commented Mar 29, 2017

@dbyzero

This comment has been minimized.

Copy link
Contributor

commented Mar 31, 2017

Did you use apache or nginx ?

@satyakresna

This comment has been minimized.

Copy link
Author

commented Mar 31, 2017

@dbyzero

This comment has been minimized.

Copy link
Contributor

commented Mar 31, 2017

I make a full user install from https://www.siberiancms.com website.and the only issue that occured was my disk full.. may be you have same problem ? You need at least 2Go free space before downloading.

selection_313

I cannot reproduct so, I you want to go further, please give your server access to contact@siberiancms.com.

@dbyzero dbyzero closed this Mar 31, 2017

@dbyzero dbyzero self-assigned this Mar 31, 2017

@dbyzero dbyzero added the wontfix label Mar 31, 2017

@satyakresna

This comment has been minimized.

Copy link
Author

commented Mar 31, 2017

@wbhagan

This comment has been minimized.

Copy link

commented Aug 18, 2017

I pulled from git and also got the "error" message at the database configuration page. And the firebug console read http error 404 for the page "/siberian/index.php". "siberian" is my web directory under /var/www/html (Apache2 in use) where I copied the files to.
After much battling without any luck, I downloaded the zipped file and extracted to my server. Voila! I'm fine.
Can't seem to identify what is wrong with the git clone.

@Dhar

This comment has been minimized.

Copy link

commented Sep 19, 2017

I'm also seeing a 404 when trying to access the check script. I was trying to evaluate this product, but it seems to be another "open source" project that mysteriously doesn't work unless you pay money...

@onedayweb

This comment has been minimized.

Copy link

commented Oct 11, 2017

Hello,

I have the same issue, error message when entering the database infos.
I looked in the .htaccess the mod_rewrite is enable, still not working.
I contacted the host and they tell me that the mod_rewrite is always enable with them.

Sorry I am a newbie and don't know a lot about those things so if more infos would help contact me

Thank you

@mag-hub

This comment has been minimized.

Copy link

commented Dec 2, 2017

Me too facing same issue, but exactly what is going wrong?

@Saalko

This comment has been minimized.

Copy link

commented Jan 17, 2018

I hade to enable AllowOverride in my apache server, than it worked.
Here you can see how to do it in Ubuntu ([https://stackoverflow.com/questions/18740419/how-to-set-allowoverride-all])
(Just edit your apache2.conf and ad:)

<Directory /var/www/>
        Options Indexes FollowSymLinks
        AllowOverride All
        Require all granted
</Directory>

(You need to edit the directory path to your siberian folder)

[https://developers.siberiancms.com/documentation/]

The documentation gave me the right hind.

@techgirlcrystal

This comment has been minimized.

Copy link

commented Jan 19, 2018

omg if anyone can help me get this install i actually bought the PE edition and i am having the hardest time getting the databases to connect. mod_rewrite is indeed enable check with my host i was just looking above and i'm new so i wasn't for sure where i would need to go to oedit the apache server i am using cpanel and whm, i know they are in france but i did contact them any help would be great thank you
screen shot 2018-01-18 at 7 14 32 pm

@rahmaidoudi

This comment has been minimized.

Copy link

commented Mar 4, 2018

image

I have already done all the steps of the installation but I am stuck in step 5.
then my error in the level of password entry as shown on the screen, can you help me?

@shmatoka

This comment has been minimized.

Copy link

commented Mar 21, 2018

Hello , I have exactly the same problem with admin creation can you help me
screen shot 2018-03-21 at 14 07 58

@shmatoka

This comment has been minimized.

Copy link

commented Mar 22, 2018

I finished installing it, and the problem turned out to be a version of the program and I just changed the version of the older one and the problem was fine. The other thing I did was here.
<Directory /var/www/>
Options Indexes FollowSymLinks
AllowOverride All
Require all granted

Changed AllowOverride None ----> AllowOverride All in httpd.conf in appache

@gardaakhir

This comment has been minimized.

Copy link

commented Mar 24, 2018

hello @shmatoka could you please explain a little bit more about changing the version to the older one? 'cause i've got exactly the same problem..
pls help.

thanks.

@shmatoka

This comment has been minimized.

Copy link

commented Mar 24, 2018

Hi , I spoke with Siberian team and their tell me this .PHP 7.2 is not supported by Siberian, please use version 7.0 or below. Version 5.6 (minimum) is the best for Siberian. When i trying to install my version on php was 7.2 and I changed my version to 7.0. Here is another answer from SIberian Team.
ok, the issue can be due to two different causes:

Don’t forget Siberian can be installed on a main domain or subdomain only, and so if you install on localhost you may want to install it at the root (http://localhost/) or to configure your /etc/hosts file with a domain/subdomain.

@jj19

This comment has been minimized.

Copy link

commented Apr 10, 2018

Im not an active contributor but wanted to provide a clear answer to what worked for me on this error.

I'm using CentOS 6 and all I had to do was to look for my apache conf file it could be apache2.conf or in my case it was httpd.conf and look for the lines that had AllowOverride none and change them to AllowOverride All and then restart apache with service httpd restart and Bam! It worked.

@tigert10

This comment has been minimized.

Copy link

commented Apr 10, 2018

I am having this same problem. Getting "error" when trying to connect to database. Chrome console says the error is a 404 not found referring to a installer/installation_database/check which is a directory that does not exist.
I have tried all of the different versions from the website and github and they all give the same error. Obviously I am overlooking something but I don't know how to troubleshoot it.
I have edited my apache2.conf file as suggested above to no avail. I have checked and double checked the database and user/password. This install is on a local LAMPS server. Any help would be appreciated. Thanks!

@tigert10

This comment has been minimized.

Copy link

commented Apr 10, 2018

shmatoka - could you talk more about what you mean "if you install on localhost you may want to install it at the root (http://localhost/) or to configure your /etc/hosts file with a domain/subdomain."? Thanks in advance!

@shmatoka

This comment has been minimized.

Copy link

commented Apr 10, 2018

Hello, I mean it needs to be installed in the main folder that could be htтpd or web. Can not be installed in an extra folder such as a Siberian to be located in httpd.

@tigert10

This comment has been minimized.

Copy link

commented Apr 10, 2018

Ok. So it is installed in /var/www/html
Does that sound right?

@shmatoka

This comment has been minimized.

Copy link

commented Apr 11, 2018

if this is main folder for your server YES.

@Evenecer

This comment has been minimized.

Copy link

commented May 4, 2018

same error Solved!!!!

I already do the next steps
1- edited apache2.conf

<Directory /var/www/>
     Options Indexes FollowSymLinks
     AllowOverride All
     Require all granted
</Directory>

and not work

## this is my solution

you need to type in konsole
sudo a2enmod rewrite
and
sudo service apache2 restart

and it work for me

@jeanbelmont

This comment has been minimized.

Copy link

commented May 19, 2018

Problem SOLVED Shared Hosting!!
I had the same problem and since im installing Siberian SAE on a shared hosting I dont have acces to Apache stuff like all of you but what is solved the problem for me was to click on MultiPHP INI Edditor
and enabled
allow_url_fopen
allow_url_include
asp_tags
enable_dl
file_uploads
on both Home Directory and Domain Directory

after that i was able to install Siberian CMS

Spanish Answer for Latin America / Respuesta en español

PROBLEMA RESUELTO en Hosting Compartido !!
Ya que en un hosting compartido no se puede acceder a las configuraciones de Apache
el problema se resuelve haciendo click en Editor INI de MultiPHP y habilitar lo siguiente tanto en el directorio Home como en el directorio de su dominio
allow_url_fopen
allow_url_include
asp_tags
enable_dl
file_uploads

captura

@gilbreth

This comment has been minimized.

Copy link

commented Jun 19, 2018

Can somebody help me please cannot get past the database install for Siberian CMS, keep getting the dreaded "error." I have tried for hours (newbie) all the suggestions above, but nothing helps. Any help at all is much appreciated!
capture

@Jurgon1976

This comment has been minimized.

Copy link

commented Jul 20, 2018

Which PHP-Version have u got? 7.2 is not supported, got the same error. PHP 7.0 might work, 5.6 is recommended.

@gilbreth

This comment has been minimized.

Copy link

commented Jul 20, 2018

@Jurgon1976

This comment has been minimized.

Copy link

commented Jul 20, 2018

And is it working now? Or still got the error Message?

@GiddyNaya

This comment has been minimized.

Copy link

commented Aug 29, 2018

Can somebody help me please, I was formally getting error at the point of setting up database while installing SiberianCMS and i got passed the error after re-configuring php version to 5.6+. But now i'm stalk at Admin creation following all the steps above without success.
Running on CentOS 7 with php5.6+
screenshot_10

@LikoV2

This comment has been minimized.

Copy link

commented Aug 29, 2018

Hi @GiddyNaya

Be careful as you responded to a closed issue.

The "error" in the Admin setup is mostly caused by PHP greater than 7.0. PHP 7.1 and 7.2 are not yet supported.

PHP 7.0 is fine.

@GiddyNaya

This comment has been minimized.

Copy link

commented Aug 29, 2018

Thanks. @LikoV2 i never noticed it was closed. I am facing the error even while i have php5.6+ configured.

@p-andreas

This comment has been minimized.

Copy link

commented Nov 22, 2018

I am facing the same issue. - I also can't get past the Error on the db connection screen.

I tried to create a docker image with siberian installed so I downloaded the zip, extracted it and tried to install it into a docker container on my dev machine.

Here is my dev docker image (not clean but sufficient for the prototyping work I am doing)

FROM php:5.6-apache
RUN apt-get update \
    && apt-get install -y libpng-dev zip unzip gnupg software-properties-common curl \
    && docker-php-ext-install -j$(nproc) gd \
    && docker-php-ext-install -j$(nproc) pdo_mysql
RUN curl -sL https://deb.nodesource.com/setup_8.x | bash -
RUN apt-get install -y nodejs gcc g++ make
ADD Siberian-master /root
RUN chmod -R a+rwx /root
RUN cd /root && npm install && ./bin/install
RUN /root/sb init << "hello"
RUN ls -al /root/
RUN rm -Rf /var/www/html && mv /root/siberian /var/www/html

docker built -t foo .

Then I am using the image locally to deploy a stack on my dev machine:

version: "3.3"
services: 
  siberian:
    image: foo
    ports: 
      - 8080:80
  db:
    image: mysql:5.7
    environment:
      MYSQL_DATABASE: "siberian"
      MYSQL_USER: "siberian"
      MYSQL_PASSWORD: "siberian"
      MYSQL_ROOT_PASSWORD: "siberian"

docker stack deploy -c docker-compose.yml siberian

Can you please help me out and point me to a possible solution?

@neodavids

This comment has been minimized.

Copy link

commented Jan 9, 2019

My siberian application is stuck at creating app name and it doesn't live to done! I ignored it and refreshed and I'm having a fatal error :
(
[storage:ArrayObject:private] => Array
(
[exception] => Zend_Db_Statement_Exception Object
(
[_previous:Zend_Exception:private] =>
[message:protected] => SQLSTATE[HY093]: Invalid parameter number: no parameters were bound
[string:Exception:private] =>
[code:protected] => 0
[file:protected] => /home/nuelogic/public_html/drupe/lib/Zend/Db/Statement/Pdo.php
[line:protected] => 234
[trace:Exception:private] => Array
(
[0] => Array
(
[file] => /home/nuelogic/public_html/drupe/lib/Zend/Db/Statement.php
[line] => 303
[function] => _execute
[class] => Zend_Db_Statement_Pdo
[type] => ->
[args] => Array
(
[0] => Array
(
)

                                    )

                            )

                        [1] => Array
                            (
                                [file] => /home/nuelogic/public_html/drupe/lib/Zend/Db/Adapter/Abstract.php
                                [line] => 480
                                [function] => execute
                                [class] => Zend_Db_Statement
                                [type] => ->
                                [args] => Array
                                    (
                                        [0] => Array
                                            (
                                            )

                                    )

                            )

                        [2] => Array
                            (
                                [file] => /home/nuelogic/public_html/drupe/lib/Zend/Db/Adapter/Pdo/Abstract.php
                                [line] => 238
                                [function] => query
                                [class] => Zend_Db_Adapter_Abstract
                                [type] => ->
                                [args] => Array
                                    (
                                        [0] => Zend_Db_Table_Select Object
                                            (
                                                [

It's very long... This are just the first few lines.. any help?
I'm using SAE - v4.15.5
My URL/back office works fine but the main URL is showing the error

Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment
Projects
None yet
You can’t perform that action at this time.