Permalink
Browse files

Merge pull request #2236 from YOURLS/travis

Shorten travis config file && add 7.2
  • Loading branch information...
ozh committed Apr 23, 2017
2 parents 91dfd39 + 39d59fc commit e36ec69d42f4ebc219a3bb9fc3ab5f94c5380c89
Showing with 4 additions and 28 deletions.
  1. +4 −28 .travis.yml
View
@@ -8,52 +8,28 @@ php:
- 5.6
- 7.0
- 7.1
+ - nightly
- hhvm
matrix:
fast_finish: true
allow_failures:
+ - php: nightly
- php: hhvm
env:
- DB=mysql
before_script:
+ - which phpunit
+ - phpunit --version
- git clone git://github.com/YOURLS/YOURLS-unit-tests.git tests
- git clone git://github.com/ozh/YOURLS-fr_FR.git user/languages/fr
- cp user/languages/fr/fr_FR.* user/languages
- mysql -e 'create database IF NOT EXISTS yourls_tests;'
- cp tests/yourls-tests-config-travis.php user/config.php
- - |
- # Export Composer's global bin dir to PATH
- composer config --list --global
- export PATH=`composer config --list --global | grep '\[home\]' | { read a; echo "${a#* }/vendor/bin:$PATH"; }`
- - |
- # Install the specified version of PHPUnit depending on the PHP version:
- case "$TRAVIS_PHP_VERSION" in
- 7.1|7.0|hhvm)
- echo "Using PHPUnit 5.7"
- composer global require "phpunit/phpunit=5.7.*"
- ;;
- 5.6|5.5|5.4|5.3)
- echo "Using PHPUnit 4.8"
- composer global require "phpunit/phpunit=4.8.*"
- ;;
- *)
- echo "No PHPUnit version handling for PHP version $TRAVIS_PHP_VERSION"
- exit 1
- ;;
- esac
- - which phpunit
- - phpunit --version
script: phpunit --configuration ./tests/phpunit-travis.xml.dist
-after_script: rm user/config.php
-
notifications:
email: false
- irc:
- channels:
- - "irc.freenode.org#YOURLS"
- use_notice: true

0 comments on commit e36ec69

Please sign in to comment.