Skip to content
New issue

Have a question about this project? Sign up for a free GitHub account to open an issue and contact its maintainers and the community.

By clicking “Sign up for GitHub”, you agree to our terms of service and privacy statement. We’ll occasionally send you account related emails.

Already on GitHub? Sign in to your account

Chaturbate URLs don't send back a title when shortened, and behave funkily #2529

Open
moonsbtt opened this issue Jun 16, 2019 · 2 comments

Comments

Projects
None yet
3 participants
@moonsbtt
Copy link

commented Jun 16, 2019

I build a private url shorten service for myself with the newest code~~
everything works great but today I have a problem with a long URL:

https:// xxxx.com /in/?track=default&tour=LQps&campaign=GfeR8&room=testaff
The xxx should be "chaturbate" (it's an xcam affiliate link)

Here is a very strange thing:

1: It don't work this this "chaturbate" domain
It do generate a short url but the long url of this generated short url will be blank. Sorry for my English, hope you can understand!

2: If change the the domain to others, such as Google or Youtube or something else, it works!
I have tested with some random words, and it works!

@moonsbtt moonsbtt added the bug label Jun 16, 2019

@ozh

This comment has been minimized.

Copy link
Member

commented Jun 16, 2019

I think that's because the page sends an X-XSS-Protection header that prevents from accessing the URL from a shortener (that's mostly useless and dumb). Or maybe it's another header they send/

Interestingly, the shortened URL behaves funnily: works for me if I click it with left button but not if I mid-click it to another tab: http://yourls.org/e8. This behavior seems to be browser dependant.

Anyway, I don't know. Leaving this open if anyone wants to dig in.

@ozh ozh changed the title URL not shorten correctly for a specific domain Chaturbate URLs don't send back a title when shortened, and behave funkily Jun 16, 2019

@LeoColomb

This comment has been minimized.

Copy link
Member

commented Jun 17, 2019

Interestingly, the shortened URL behaves funnily: works for me if I click it with left button but not if I mid-click it to another tab: http://yourls.org/e8. This behavior seems to be browser dependant.

This is a common behavior for ad blockers. They prevent accessing some domains when opened in a new tab (i.e. not a direct access).

Ad blockers may be the "issue" for the whole report. Can you check @moonsbtt?

Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment
You can’t perform that action at this time.